X
Tap here to go to the mobile version of the site.

Support Forum

keyboard arrows, Home, End keys

Posted

In a edit box, such as a search box, my keyboard arrows, Home, End keys do not work since I upgraded to FireFox 8

In a edit box, such as a search box, my keyboard arrows, Home, End keys do not work since I upgraded to FireFox 8

Chosen solution

Caret browsing doesn't affect the behavior in a text input field like you experienced. An extension (theme) or plugin can cause such behavior like you found out. It may be a problem with the Adobe Reader on Windows 2000 as that is an old and no longer supported OS.

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Shockwave Flash 11.0 r1
  • 4.0.60531.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.0; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

More Information

FireFox 8
Windows 2000 SP4

Helpful Reply

I found out that if one of the tabs has a PDF opened, then these keys work on none of the other pages opened.

(I had several saved tabs with sites opening everytime FF is started).


Anyone know how to correct this? Or is it a problem caused directly by Adobe?

I found out that if one of the tabs has a PDF opened, then these keys work on none of the other pages opened. (I had several saved tabs with sites opening everytime FF is started). Anyone know how to correct this? Or is it a problem caused directly by Adobe?

Modified by cclint

David McRitchie 320 solutions 3092 answers

Helpful Reply

my keyboard arrows, Home, End keys do not work...

That problem is caused by "caret cursor" and the way that Mozilla works with it. Press "F7" reply "No" to turn if off. F7 toggles the setting and you may or may not see the warning but if you do see "No" that would mean you have it on and "No" would turn it off. For a more complete resolution see

See how you do with Adobe PDF files after fixing the above. You can have PDF files open by default without Firefox involved except to download them, but I expect you chose to view in your browser. You have a lot more control of reading PDF files outside of Firefox. The plug-in is what allows you to open them in a browser.

''my keyboard arrows, Home, End keys do not work...'' That problem is caused by "caret cursor" and the way that Mozilla works with it. Press "F7" reply "No" to turn if off. F7 toggles the setting and you may or may not see the warning but if you do see "No" that would mean you have it on and "No" would turn it off. For a more complete resolution see * [http://dmcritchie.mvps.org/firefox/firefox-problems.htm#caret Caret Browsing] in<br>http://dmcritchie.mvps.org/firefox/firefox-problems.htm#caret See how you do with Adobe PDF files after fixing the above. You can have PDF files open by default without Firefox involved except to download them, but I expect you chose to view in your browser. You have a lot more control of reading PDF files outside of Firefox. The plug-in is what allows you to open them in a browser.

Question owner

I had already tried turnung off the carot cursor and that didn't help. (And, in the warning, the "No" is always visible on my system and local.)

Right now, with it turned off, all I need to do is load a PDF in the browser and the problem is there again.

I had already tried turnung off the carot cursor and that didn't help. (And, in the warning, the "No" is always visible on my system and local.) Right now, with it turned off, all I need to do is load a PDF in the browser and the problem is there again.
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157849 answers

Chosen Solution

Caret browsing doesn't affect the behavior in a text input field like you experienced. An extension (theme) or plugin can cause such behavior like you found out. It may be a problem with the Adobe Reader on Windows 2000 as that is an old and no longer supported OS.

Caret browsing doesn't affect the behavior in a text input field like you experienced. An extension (theme) or plugin can cause such behavior like you found out. It may be a problem with the Adobe Reader on Windows 2000 as that is an old and no longer supported OS.

Question owner

Thank you. You are right: The carot cursor doesn't have anything to do with my problem, otherwise turning it off would have solved it.

Both, not loading a PDF or deactivating the Adobe Reader plug-in solves the problem.

And, I believe you are right: The Adobe Reader version installed just isn't capatable with my system. There are no compatable versions for my system and the version of FF used.

Thank you. You are right: The carot cursor doesn't have anything to do with my problem, otherwise turning it off would have solved it. Both, not loading a PDF or deactivating the Adobe Reader plug-in solves the problem. And, I believe you are right: The Adobe Reader version installed just isn't capatable with my system. There are no compatable versions for my system and the version of FF used.

Modified by cclint

Question owner

In order that those keys work inside the PDF window/Tab, the Adobe Reader plug-in installed (9.4.0) apparently uses (at least on my W2000 system) a windows hook, (or maybe even just a simple key capture via timer), on the complete FF thread, instead of just on the PDF tab, in order to capture these keys.

When I press one of these keys in a different tab's edit box, and return to the PDF, the cursor position there changed by the exact amount of key-presses.

In order that those keys work inside the PDF window/Tab, the Adobe Reader plug-in installed (9.4.0) '''apparently '''uses (at least on my W2000 system) a windows hook, (or maybe even just a simple key capture via timer), on the complete FF thread, instead of just on the PDF tab, in order to capture these keys. When I press one of these keys in a different tab's edit box, and return to the PDF, the cursor position there changed by the exact amount of key-presses.
px03afk 0 solutions 3 answers

I have the same problem and in my case it is definitely caused by the Adobe plugin. Close the tab with the open pdf doc and the keys come back. Open the tab again and the keys have gone.

I have the same problem and in my case it is definitely caused by the Adobe plugin. Close the tab with the open pdf doc and the keys come back. Open the tab again and the keys have gone.

Modified by px03afk