Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The "Clear Recent History" setting under "Tools" suddenly stopped working about two weeks ago and is still not working with version 8.0. I am running Mac OX 10.6.8 on a desktop

  • 15 replies
  • 6 have this problem
  • 9 views
  • Last reply by cor-el

more options

Until a couple of weeks ago I could clear my history under the "Tools" setting.

Now the only way I am able to clear history is to open the history, select all, and then delete---all manually.

All Replies (15)

more options

A possible cause is a problem with the file places.sqlite that stores the bookmarks and the history.


Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Dear cor-el:

I did restart in Safe Mode; however, I DID make change in the Safe Mode restart window, resetting to defaults.

Not only did this not help, but now it is worse, as my history won't show up when I click "Show All History" so I am unable to clear history even manually.

Did I misunderstand your suggestion? I've been using Firefox with various versions of OX 10 for years w/o such a problem, and now have so many bookmarks on Firefox that I hate to abandon the browser.

However, I do not wish to have a permanent, unclearable history.

Below is a screenshot of how the Safe Mode page appeared.

more options

Did you check for a corrupted places.sqlite file in the first part of my above post?

more options

Thanks cor-el. It now seems to be working. I will see if it continues to work properly over the next few days; if so, I will post this as on the "solved" link.

I truly appreciate your help.

Now if I can only find someone who can help me figure out how I can set up Gmail filters under my Apple mail app so that I don't get duplicates of "sent" messages but rather have them exist only in the appropriately filtered archive box!

more options

You're welcome

more options

Dear Cor-El---


Sorry to say, but problem has recurred.

Any other thoughts on the matter?

Thanks again.

more options

Do you have that problem with all items in Clear Recent History or only with the history?

more options

Where would I look to see if the other items (cookies, cache, browsing and download, forms and search history, active logins) were being cleared or not?

more options

What makes you think that Clear Recent History isn't working?

  • You can see the current cache usage on the about:cache page.
  • Cookies: Tools > Options > Privacy > Cookies: "Show Cookies"
  • Downloads: Firefox/Tools > Downloads
  • History: Firefox > History > Show All History

The other are not easy to check.

more options

Because when I clear history the history doesn't clear.

Also, I tried deleting and reinstalling firefox, and the problem went away, but I've lost all my bookmarks.

However, everything is backed up on my time capsule. But when I "restored" the session prior to the delete and reinstall, I still could not see my bookmarks---but the problem returned.

This truly sucks and I am about ready to abandon Firefox completely.  They've taken an excellent browser and screwed it up and I am too busy to waste much more time.  I will give it one more shot.

I appreciate your help.

more options
more options

Please see screenshot. This does not show up when I try to use "Restore" in the library. At the moment I now have a worse problem than before===years of useful bookmarks are not available although clearly backed up.

How can I restore from JSON when they don't show up in restore and when I use safe mode the restore option doesn't work? Can I just manually drag one of the JSON folders? What about time capsule? Please be specific if possible.

I have wasted hours but am ready to give up. See screenshot. The backups are there.

more options

That can be caused by a problem with the place.sqlite file like I posted above.

Did you try to delete all places.* files (places.sqlite and possible other places files like places.sqlite-journal) ?

Firefox will then try to restore the bookmarks automatically from the most recent JSON backup in the bookmarkbackups folder.

more options

It won't show any backup beyond yesterday when the problem occurred, although there are JSON files going back to November 7 under "Bookmarks Backup."

more options

On Mac you can see if you can find a working backup or an older copy of places.sqlite in the Time Machine.