X
Tap here to go to the mobile version of the site.

Support Forum

It is impossible to upgrade tot 8.0. When I do it, is runs, but the website says I have not the latetst. I Have tried evrything.

Posted

For example Gmail says that I have to upgrade Firefox. Firefox itself says it when I try to give feedback. But I do every step by the 'book'

For example Gmail says that I have to upgrade Firefox. Firefox itself says it when I try to give feedback. But I do every step by the 'book'

Chosen solution

Your UserAgent string in Firefox is probably messed up by another program that you installed.
http://en.wikipedia.org/wiki/User_Agent

type about:config in the URL bar and hit Enter
If you see the warning, you can confirm that you want to access that page.
Filter = general.useragent.
Right-click the preferences that are bold, one line at a time, and select Reset.
Then restart Firefox

Read this answer in context 0

Additional System Details

This happened

Not sure how often

This started when...

since latest update to 8.0

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • 4.0.60831.0
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • NPWLPG
  • Office Live Update v1.4
  • CANON iMAGE GATEWAY Mycamera Plugin
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 (.NET CLR 3.5.30729)

More Information

pawiecki 5 solutions 21 answers

Try following this steps: (I don't have english version right now so names may vary from what you'll see)

1. Go to www.getfirefox.com and download latest stable version.

2. Go to menu: Bookmarks => Show all bookmarks (or Ctrl+Shift+B)=> from menu "import & backup" (or smth like this) choose to make backup copy (*.json file) and choose where to save it. Now just to be a bit more sure from the same menu choose to export bookmarks (*.html file) and again show where to save it.

3. Go to menu: History => Clear history (or Ctrl+Shift+Del) => choose to clear all history from drop-down menu and click show details. Now check all boxes and click "clear now"

4. Now uninstall Firefox via Add/Remove Programs (from Windows Control Panel)

5. Delete "Mozilla Firefox" folder (most probably it's on C:/Program Files/Mozilla Firefox/)

6. Restart Windows

7. Install Firefox from file you downloaded (in 1st step)

8. Run Firefox and import your bookmarks (like in 2nd step but instead of backup, choose to recover from file and find your previously saved *.json file. If you encounter any problems with *json file, try to import bookmarks from *.html file)

9. Adjust settings to fit you, and install extensions/addons you like.

10. Enjoy Firefox, that should be version 8 now :)


  • If the above won't help, than it must be something paranormal with you ;)
Try following this steps: (I don't have english version right now so names may vary from what you'll see) 1. Go to www.getfirefox.com and download latest stable version. 2. Go to menu: Bookmarks => Show all bookmarks (or Ctrl+Shift+B)=> from menu "import & backup" (or smth like this) choose to make backup copy (*.json file) and choose where to save it. Now just to be a bit more sure from the same menu choose to export bookmarks (*.html file) and again show where to save it. 3. Go to menu: History => Clear history (or Ctrl+Shift+Del) => choose to clear all history from drop-down menu and click show details. Now check all boxes and click "clear now" 4. Now uninstall Firefox via Add/Remove Programs (from Windows Control Panel) 5. Delete "Mozilla Firefox" folder (most probably it's on C:/Program Files/Mozilla Firefox/) 6. Restart Windows 7. Install Firefox from file you downloaded (in 1st step) 8. Run Firefox and import your bookmarks (like in 2nd step but instead of backup, choose to recover from file and find your previously saved *.json file. If you encounter any problems with *json file, try to import bookmarks from *.html file) 9. Adjust settings to fit you, and install extensions/addons you like. 10. Enjoy Firefox, that should be version 8 now :) *If the above won't help, than it must be something paranormal with you ;)
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 solutions 40231 answers

Chosen Solution

Your UserAgent string in Firefox is probably messed up by another program that you installed.
http://en.wikipedia.org/wiki/User_Agent

type about:config in the URL bar and hit Enter
If you see the warning, you can confirm that you want to access that page.
Filter = general.useragent.
Right-click the preferences that are bold, one line at a time, and select Reset.
Then restart Firefox

Your UserAgent string in Firefox is probably messed up by another program that you installed. <br /> [http://en.wikipedia.org/wiki/User_Agent] type '''about:config''' in the URL bar and hit Enter <br /> ''If you see the warning, you can confirm that you want to access that page.'' <br /> Filter = '''general.useragent.''' <br /> Right-click the preferences that are '''bold''', one line at a time, and select '''''Reset'''''. <br /> Then restart Firefox

Question owner

Thank you so very much. That helped!!!!! Problem = solved. Yes! Finally.

Thank you so very much. That helped!!!!! Problem = solved. Yes! Finally.