X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox 9 bookmark icons missing

Posted

Firefox 9 bookmark icons have disappeared. this appears to have happened after updating to version 9 of Firefox for Mac. I only have a few add-ons, that should not conflict with the display of the icons. Menu bar bookmark icons still display, just not in the Bookmarks drop down menu.

Modified by Dave

Chosen solution

It's a bug in Firefox 9. Here's how to fix until we fix it:

  1. In the Location bar, type about:config and press Return.
    • The about:config "This might void your warranty!" warning page may appear. #Click I'll be careful, I promise!, to continue to the about:config page.
  2. In the filter section type, image.mem.decodeondraw
  3. Double-click the entry that results to change it's value to "False"
https://support.mozilla.com/en-US/kb/latest-firefox-issues#w_icons-missing-in-the-bookmarks-menu
Read this answer in context 90

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 10.2 r152
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • 4.0.50524.0
  • View PDF documents within your web browser.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0) Gecko/20100101 Firefox/9.0

More Information

maxboyd 0 solutions 2 answers

Me too. It happened after upgrading to 8.0. They were there before. Firefox please help! Driving me crazy.

eguatemala 0 solutions 1 answers

Go to View, select Toolbars & Customize, in Show select Icons & check small icons, large icons no longer used.

Question owner

"Go to View, select Toolbars & Customize, in Show select Icons & check small icons, large icons no longer used. "

The icons display fine in the toolbar. It is in the drop down Bookmarks menu where I have lost the icons. dave.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Question owner

Hi Cor-el, No luck. As stated previously all favicon icons are there, except in the bookmarks drop-down menu (toolbar, history, etc all display the icons).

Modified by Dave

Question owner

This is the drop down bookmarks menu

Modified by Dave

Kalala 0 solutions 1 answers

Helpful Reply

Problem seems pretty common based on a google search. Found an article on techlogon addressing this problem. Using one of their suggestions, I was able to get most (but not all) of my favicons back by running the CheckPlaces add-on and checking the load favicons and reload favicons boxes.

Not a complete fix as there is clearly something amiss with favicons beginning with version 8 that I hope someone can figure out. I also hope they change the dotted box to something else.

Question owner

Hi Kalala, Thanx. I tried CheckPlaces 2.6.1 previously ( no success with the icons, good for duplicates and 404's)

julsssark 0 solutions 2 answers

Has a bug been opened in Bugzilla for this?

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Bug 701297 – Several favicons are lost in bookmarks with the upgrade to Firefox 8

(please do not comment in bug reports)

Question owner

Firefox 9 (Mac) is no better. There are also no rollover effects on the Home, Back, Forward, Reload, etc menu bar buttons.

Modified by Dave

julsssark 0 solutions 2 answers

Still broken in Firefox 9.0 beta 4

Question owner

I have noticed that Firefox's History drop down menu (Menu bar) on first click has no icons, clicking again (immediately) calls up the icons. This happens every time.

Question owner

Currently, the icons are back (Menu bar). Let's hope they stay. EDIT: They didn't, they have gone again. What is going on with Mozilla?

Modified by Dave

Michael Verdi
  • Administrator
  • Moderator
107 solutions 739 answers

Chosen Solution

It's a bug in Firefox 9. Here's how to fix until we fix it:

  1. In the Location bar, type about:config and press Return.
    • The about:config "This might void your warranty!" warning page may appear. #Click I'll be careful, I promise!, to continue to the about:config page.
  2. In the filter section type, image.mem.decodeondraw
  3. Double-click the entry that results to change it's value to "False"
https://support.mozilla.com/en-US/kb/latest-firefox-issues#w_icons-missing-in-the-bookmarks-menu

Question owner

Verdi, Fixed. I thank you. dave.

Modified by Dave

queenbness 0 solutions 1 answers

After I changed setting to false, the icons did not return. Any other suggestions? Thanks

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Try this extension:


Sgretola 0 solutions 1 answers

Smooth and fast. Thank you very much, Verdi!

dina111 0 solutions 1 answers

Thanks Verdi! Worked like a charm!!!