Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do certain websites default to bottom of page upon opening?

  • 58 replies
  • 68 have this problem
  • Last reply by Mr. News

more options

When I am opening up sites like and the web page defaults to the bottom of the page. It only happens on certain websites. I can open gmail, hotmail, amazon - and it stays at the top of the page.

All Replies (20)

more options

(First post!)

The two listed sites don't do that for me, so I don't know. Typically this would be because of a JavaScript file with something like scrollTo( [ something ] ) in it.

more options

I have exactly the same problem on some sites, and it also happened on the sites posted above. I think FF 12.0 is now misreading a certain javascript line contained on some sites' code. It's quite annoying, and happending on more and more sites. I thought it was my mouse at first. Someone should file a Bug report....

more options

One thing I noticed about both the REI and MountainHardwear sites is that they display ads from the DoubleClick network. I wonder whether there is a bad ad going around that only rotates in now and then? Could someone test with and without an ad blocker?

more options

Happening on many sites, including (Memory Lane). Checked source code and there is no DoubleClick ad on there. (Also blocked by my Hosts file).

more options

It's possible that one of your add-ons isn't fully compatible with Firefox 12. Could you try Firefox's Safe Mode to see whether we can rule that out?

First, I recommend backing up your Firefox settings in case something goes wrong. See Backing up your information. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the Safe Mode dialog, do not check any boxes, just click "Continue in Safe Mode."

If the problem sites loads normally, this points to an add-on or custom setting as the likely problem.

Any new info?

more options
more options

So if you disable JavaScript, the sites no longer scroll/leap to the bottom of the page. However, as you point out, that is not a practical solution. Since I visited all the sites with JavaScript enabled and didn't see anything unusual, I think we need to consider other possibilities.

Do you have to be logged in to the site to see the problem?

more options

No, and it does not happen on a laptop running FF 11, or on IE 8. Both computers are running Win XP SP3, latest Java, latest FlashPlayer, etc. Only difference is FF version....

more options

Tried disabling all plug-ins, no luck. I have "IE Tab 2" which causes the affected page to render correctly. Found earlier version of FF (11.0) but it's just a list of files, and I have no idea how to install it, without screwing up my entire system and all bookmarks, etc etc.

More and more websites are affected. Here's another, very public, one:

Modified by Mr. News

more options

And.... I reverted to Firefox v 11.0 and the problem disappeared. So Mozilla needs to address this issue with javascript before releasing v 13. Version 12 is a no-go for me. Not sure what the exact cause is, but it's a problem in 12, not 11, so something was changed that needs to be fixed.

more options

Tried disabling all plug-ins, no luck.

Plug-ins or Extensions? Make sure you test with all extensions disabled manually or in Safe Mode.

More and more websites are affected. Here's another, very public, one:

Sorry, I just cannot reproduce the problem when I visit any of these sites. Maybe there is something special about my configuration. I'll be curious to see whether we get more reports.

more options

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
more options

Plug-ins or Extensions? Make sure you test with all extensions disabled manually or in Safe Mode.

Disabled both plug-ins and extensions, one at a time and as a group: no joy. Since the problem disappears when v11 is re-installed, it's clear to me that it's a problem with v12 and my specific configuration: XP 32 bit "Media Center" w/ SP3. Tried disabling all A-V, firewalls, etc etc. Since only a few other folks are having this problem, I'm afraid this will go unaddressed. I'll try v13 when it is released, and revert back to v11 if the issue reoccurs. May have to switch to another browser...

more options

BTW, I have also noticed an increasing number of flaws in the way that FF handles javascript in general. Javascript commands are sometimes ignored in FF, while they work perfectly in IE (8).

I just used the Costco website storefinder in FF, and after entering zip code and clicking (or mousing over) "Go", saw "javascript: FindByNumber();" in the lower left notification area, and nothing happens!

This failure to process occurs on a number of javascript functions in FF. It may be due to web developers' failure to "keep up," but it is nevertheless quite annoying to deal with. Thank goodness for IE Tab 2...

more options

"Since only a few other folks are having this problem, I'm afraid this will go unaddressed."

If the problem can't be replicated by others, then it will go unaddressed...we really need to get a better understanding of the problem.

"I just used the Costco website storefinder in FF, and after entering zip code and clicking (or mousing over) "Go", saw "javascript: FindByNumber();" in the lower left notification area, and nothing happens!"

That's strange, the zip code search on this page works quickly for me:

Perhaps there is a setting carried forward from earlier versions of Firefox that is causing a previously unnoticed problem in Firefox 12? If you install Fx12 again, my next suggestion would be to create a new Firefox profile. In addition to bypassing current add-ons and custom settings, it should have completely fresh settings databases and a fresh cache folder.

To create a new profile, close Firefox and start up in the Profile Manager as described in Managing profiles. Any time you want to switch profiles, close Firefox and return to this dialog.

If the new profile manages to display pages from the top, you can move key settings like bookmarks from your problem profile to the new one. See Recovering important data from an old profile.

more options

Thanks for the help & tips, but I'll wait for v 13 and try to ignore the annoying "Upgrade Now!!" nag screens for now. Firefox has always been easier/cleaner/faster/more tweakable than IE, but I haven't the time to start "fixing" it. Obviously, it's a small number of people who do have this problem with Javascript commands in v 12, perhaps because we're still on XP and our hardware is pre-2010 (ie, antique). FF v 11 continues to work relatively well, so until there's a new version that doesn't require "rooting," I'll stick with 11.

more options

reverting back to version 11 solved this same issue for me, thanks !!!

more options

Hi chudddds, next time this occurs, please start a new discussion with your specific issue so you can get a custom answer. This thread has such a mix of script issues that we can't tell whether there is an easy solution that keeps you with a secure (current) version, or not.

more options

yes, i will do that. mine was pretty much the same. i purged all the extensions and add-ons to no avail. reverted back to ver 11, and completely resolved the issue of certain websites automatically jumping to the end of the page. it only happened on a few different sites. newegg's website was the worse, and i spend alot of time there everyday.

thanx for your time

more options

I filed a Bug Report, which was accepted... [] (edit comments added by a forum moderator:

  • Sorry to see from a later post that you have decided to use Chrome,
    but hope that works for you
  • At present the above linked, bug report status is unconfirmed.
    It is possible for instance that the problem is caused by interaction with other software ).

It remains to be seen if any developer can figure out what changed in v 12 that causes certain Javascript functions to malfunction in certain OS configurations. It may be difficult to track down, given that problem only occurs in a fraction of the FF installations. Fingers crossed...

Modified by John99

  1. 1
  2. 2
  3. 3