X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Arial font displays in only bold

Posted

I don't actually know how (to me it seems like it happened completely randomly) but I started up Firefox today and Wikipeda was displayed entirely in bold. After checking my problem on Google, I discovered that Google as well displayed every piece of text in bold. This has never happened before, and any search on my problem offers both solutions that do not solve the problem, and are relevant only to version 3.0 and 4.0 of firefox. Please help.

Modified by konami55321

Chosen solution

I believe my Arial font may have been corrupted by an old game (Age of Empires II) I installed and played with my kids this past weekend. This solved my problem. Try going to the fonts control panel by clicking start, control panel, then fonts. If you don't see "fonts" then look at the upper right of your control panel for the "view by" option and choose "small icons". You can also find it in Windows explorer by navigating to your Windows folder and then the fonts folder. Mine is at c:\windows\fonts. Once you are there, copy the Arial font by right clicking on it and choosing "copy" and paste it in a temporary folder of your choice or on the desktop. You can also just drag it to another folder or onto the desktop. It should paste about 9 different versions of the Arial font. Go to the folder you just pasted it to, right click arial.ttf and choose copy and then return to the fonts control panel, right click anywhere and choose paste. It should say the font is already installed and ask if you want to replace it. Say yes for all instances. If you dragged it to the desktop, then just drag it back to the fonts control panel and say yes to all the install questions. Hope this helps you. If you can't find the arial font in the fonts control panel, then your problem is most likely that it was deleted. You will have to download it from somewhere and re-install it. Sorry I can't help you with that.

Read this answer in context 12

Additional System Details

Sites Affected

http://www.wikipedia.org/

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.0 r1
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • NPWLPG
  • 4.0.50401.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • npdnupdater2
  • npdnu

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

More Information

Question owner

I've attached a snipping of a random wikipedia page, as well as a random google search, to show you what it looks like. Another interesting fact that might help; I tried typing in Arial in word, and it works fine. However, Arial Black has no difference between bold and non-bold.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Helpful Reply

If you have an ATI graphics display try to disable "Morphological Filtering" in the Catalyst display driver.

  • Catalyst Control Center > Gaming > 3D Application Settings > Disable Morphological Filtering

Question owner

I don't have an ATI graphics card. I actually have a toshiba satellite with an AMD Radeon HD 6250 Graphics card. Is it possible that my Radeon could have a similar problem, or is this an ATI exclusive problem?

Modified by konami55321

kivuli 0 solutions 2 answers

ATI is the old and now retired name of AMD's graphics card line/division, with new cards being branded as AMD now, so I would check and see if you have an option like that somewhere in your settings.

Morphological filtering is a kind of anti-aliasing, so finding and disabling anything having to do with anti-aliasing in your graphic driver settings might or might not help, (assuming you don't find a morphological filtering setting. It may be called morphological filtering anti-aliasing, or MFAA for short.)

Anyways, I am running an Nvidia GTS450 and the problem is happening to me as well, and I don't have a morphological filter setting anywhere in the nvidia drivers. I have manually turned off anti-aliasing in firefox, and don't see a change. It appears that all my internet browsers are affected. (IE9, Firefox 7) I can't tell if it is working in other apps because I don't know what it should look like.

I have reinstalled firefox without success.

Question owner

I can't seem to find a AMD equivalent to Catalyst Control Center, so I really don't know if and how I can disable Morphological Filtering. This only started happening a few days ago, and I've had this laptop for several months, and considering I haven't tinkered around with ANY video card options, I don't know if the problem would even be something like that. The only significant changes that I recently made are installing Age Of Empires, StarCraft, RollerCoaster Tycoon 2 and 3, and a boatload of steam games. I have windows 7, and as I said previously, I have a toshiba satellite with an AMD Radeon HD 6250 Graphics card.

minidatsun 1 solutions 1 answers

Chosen Solution

I believe my Arial font may have been corrupted by an old game (Age of Empires II) I installed and played with my kids this past weekend. This solved my problem. Try going to the fonts control panel by clicking start, control panel, then fonts. If you don't see "fonts" then look at the upper right of your control panel for the "view by" option and choose "small icons". You can also find it in Windows explorer by navigating to your Windows folder and then the fonts folder. Mine is at c:\windows\fonts. Once you are there, copy the Arial font by right clicking on it and choosing "copy" and paste it in a temporary folder of your choice or on the desktop. You can also just drag it to another folder or onto the desktop. It should paste about 9 different versions of the Arial font. Go to the folder you just pasted it to, right click arial.ttf and choose copy and then return to the fonts control panel, right click anywhere and choose paste. It should say the font is already installed and ask if you want to replace it. Say yes for all instances. If you dragged it to the desktop, then just drag it back to the fonts control panel and say yes to all the install questions. Hope this helps you. If you can't find the arial font in the fonts control panel, then your problem is most likely that it was deleted. You will have to download it from somewhere and re-install it. Sorry I can't help you with that.

Question owner

Aaaand that solved it. Thank you, minidatsun, wikipedia is no longer bold. I'm going to keep the arial folder on my desktop just in case it happens again (I still plan to play age of empires).

Pippymint 0 solutions 1 answers

Thanks Minidatsun the solution also worked for me. I just copied the Ariel font to my desktop and then straight back again choosing you yes when asked if I wanted to copy over the originals.

kivuli 0 solutions 2 answers

Thanks Minidatsun. That solved my problem as well. Funny, as I also just installed Age Of Empires. Wonder if that is where the problem actually lies. I just reinstalled almost all my games, so I'm not sure if it is the culprit or not, but seeing as all 3 of us just installed it....


Thanks Again!