Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I'm running version 3.6.23 can I update to version 5?

more options

After checking for reports of problems with version 7.0.1, I've decided I don't want to risk the memory leak problems others have been reporting. I'd like to update to an earlier version than 7.0 (like version 5.x.x) but can't find any on the Mozilla website. Anyone know where the download for an earlier version is?

Chosen solution

No - Firefox 5 isn't supported. Firefox 7.0.1 and 3.6.23 are the currently supported versions.

Read this answer in context 👍 2

All Replies (2)

more options

Chosen Solution

No - Firefox 5 isn't supported. Firefox 7.0.1 and 3.6.23 are the currently supported versions.

more options

Firefox 3.6.23 and 7.0.1 are the only supported and updated versions available. If you use an unsupported, superseded version, you are taking a security risk with your system and any personal information on your system.

I have experienced no "memory leak" issues with Firefox 7.0.1. If those reporting such an issue would take the time to investigate, the issue is most likely caused by one or more of their Add-ons (Extensions or Plugins). See:


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.