X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

VLC player plugin conflict with Windows Media Player plugin in Firefox 8.0.1

Posted

After I upgraded to Firefox 8.0.1, Windows Media Player stopped playing embedded videos within the Firefox browser.

If you go to Add-ons and disabled VLC player plugin, Firefox will start to plays any Windows Media Player videos without any issue.

The minute I click to enable VLC, Windows Media Player stop working again. This problem is not used to happen in Firefox 6.02.

Please help me with problem. any suggestions will be appreciated.

Modified by MacNimer

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • Cooliris embedded in a tab
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.0.0 for Mozilla browsers
  • 4.0.60531.0
  • GEPlugin
  • NPWLPG
  • npmnqmp 989898989877
  • Virtual Earth 3D 4.00100226006 plugin for Mozilla
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • np-mswmp
  • PDF-XChange Viewer Netscape Gecko Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

More Information

windows 7

finitarry 157 solutions 2175 answers

Helpful Reply

You can disable the VLC plugin from the Addons window. Choose Plugins, find VLC in the list and disable it.

Helpful Reply

Disabling the VLC plugin to play windows media player videos is temporally fix and work around this problem I have already tried it!

Whenever I visit a website have VLC video embedded format, I need to enable the VLC plugin again and then WMP will stop working.

I admit I can watch one video at the time! so I have to live with it. This is what we get from free browser with no serious professional support I guess!

finitarry 157 solutions 2175 answers

As much as possible, you can set Firefox to use helper applications rather than plugins for handling certain file extensions. That was the approach I took.

Prophit319 0 solutions 2 answers

i honestly cant believe firefox... i might actually go back to ie... as messed up as that sounds