Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mailto links not working

more options

I am running version 7.0.1; but I think this problem may have manifested itself when I updated to 6.0. When I click on a hyperlink that is supposed to open an email dialog nothing happens.

Chosen solution

There has to be an e-mail client set in order to see any effect if you select Mail items.
So you first have to make sure that that part is correct and that is the default mail program as set in the OS and the Mailto setting in Tools > Options > Applications.

Other settings that may interfere are mail prefs that you can inspect on the about:config page and a possible corruption of the file mimeTypes.rdf in the profile folder.

Read this answer in context 👍 0

All Replies (5)

more options

The problem is not the mail client, but the fact that the mailto window does not open a all! I.e. one clicks on the email/mailto link and NOTHING happens.

more options

Hi I am trying to say what I did to the best of my ability:

1. Enter about:config in the location bar and press Enter to access the advanced preferences. 2. Look for(type gecko in filter bar) "gecko.handlerService.allowRegisterFromDifferentHost" and double click it to set it to true. 3. Close the window. 4. Then go to MFF tools and set your email in applications. 5. Then again Enter about:config in the location bar and press Enter. 6. Type mailto in the filter bar. Find "network.protocol-handler.external.mailto" and double click to set it to true. 7. I suggest setting gecko.handlerService.allowRegisterFromDifferentHost back to false to prevent malicious web sites offering their own protocol handlers.

(This link and trial and error helped me: http://mozillalinks.org/2008/07/seamonkey-1110-update-available-now/) Now I jsut have a problem that the mailto opens in the same window/tab when I leftclick.

more options

Chosen Solution

There has to be an e-mail client set in order to see any effect if you select Mail items.
So you first have to make sure that that part is correct and that is the default mail program as set in the OS and the Mailto setting in Tools > Options > Applications.

Other settings that may interfere are mail prefs that you can inspect on the about:config page and a possible corruption of the file mimeTypes.rdf in the profile folder.

more options

This worked, but when I went where you pointed me, "Use Microsoft Outlook" was already set as the Mailto default so I reset it to Mozilla Thunderbird (which my spouse uses), saved that and then changed it back to Outlook and IT WORKS!

Modified by joelos@rodrunner.com