X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox 7 Unacceptably Slow. There seem to be many other users with this complaint, most mentioning Windows 7 platforms. I'm still on Windows XP 32-bit, and I also have the problem.

Posted

I made the mistake of accepting an upgrade to Firefox 7; suddenly I experience serious performance issues loading new pages. How do I get back to Firefox 5 or 6 ?

If that is not possible, how do I transfer my Bookmarks list over to Internet Explorer while you guys fix the performance issues ?

Chosen solution

I had the same problem and found the solution here here

The solution involved going to about:config and changing "network.http.max-connections" line value from 256 to 48

Read this answer in context 7

Additional System Details

This happened

Every time Firefox opened

This started when...

I installed Firefox 7

Installed Plug-ins

  • Google Update
  • SiteAdvisor
  • McAfee MSC FF plugin DLL
  • Shockwave Flash 10.3 r181
  • GEPlugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.2"
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

More Information

Windows XP Professional 32-bit

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8016 answers

I am not noticing performance issues on Firefox running on an old XP.

Some users are getting hit by hangs or freezes, especially whilst syncing bookmarks. There is already a workaround for that and a proper fix will come in a later version of Firefox. see http://blog.bonardo.net/2011/09/30/is-your-firefor-freezing-at-regular-intervals

You may downgrade to Firefox 3.6.23 that is for now still supported and secure. It is not recommended downgrading to Firefox 5 or 6 they are not secure. See

It is relatively easy to transfer bookmarks between firefox and IE

Question owner

Yes and No. Not sure the referenced problem describes my issue. FF doesn't really "hang"-- it just takes its time getting where I want. Rest of reply was helpful.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8016 answers

I have not tried to look into the workaround, but think it just restructures the places.sqlite file, other than the few minutes to download and install the appropriate software, and the few minutes to run that; there should afaik be no costs or side effects of trying the workaround. It may be worth giving the workaround a try to see what happens.

Are you noticing problems after bookmark changes, or syncing; along with high CPU usage ? (Those are the symptoms the workaround is aiming to help with.)

Developers did mention other things were under investigation. As always with trying to investigate problems on firefox a first stage is trying to reliably define and reproduce the problem.

Lima62 0 solutions 1 answers

I'm not having hangs or freezes, it just takes an interminably long time for pages to load. I'm running vista(doesn't deserve a capital),& this has only been happening since updating to Firefox 7.

  I choose Firefox as much for what it isn't as for what it is,& up til now have been  happy with it,but its getting so that the everyday user who doesnt know a huge deal about computering,like me, has to put it in the too-hard basket. Will persevere but I hope a solution is sorted soon.

Modified by Lima62

Admission Jankari 0 solutions 1 answers

Sometimes when mozilla is overloaded with different tabs and many more it crashes and closed.After that it takes so much time to recover.Sometimes i have reinstall it again and this thing happen to new version also.And also some add ons are also not working with newer version too.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8016 answers

You may often see this advice repeated. This a forum and each thread is intended for one particular problem, start your own thread by posting your own question. There are many potential problems causing firefox to be slow or crash, and many combinations of software used with firefox.

I suggest if you consider the problem to be very closely related to the one described in this thread instead of describing it in full in this thread make a brief comment and post a link to your own thread.

See also

jneighbors 2 solutions 2 answers

Chosen Solution

I had the same problem and found the solution here here

The solution involved going to about:config and changing "network.http.max-connections" line value from 256 to 48

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8016 answers

Helpful Reply

If you have a slow internet connection it may be worth considering reducing the value of network.http.max-connections as mentioned by jneighbors

I posted about that potential solution earlier Today and an unreviwed modification to the KB article has now been made <-- click on + revision content if you try that link ---

To include

Lower the max number of HTTP connections

On slow connections, too many HTTP connections may cause timeouts.

   In the Location bar, type about:config and press Enter.
       The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise!, to continue to the about:config page. 
   In the Filter box at the top, type network.http.max-connections.
   Double-click on the network.http.max-connections preference, the "Enter integer value" dialog box will open.
   In the field, type 30 which was the default value in old versions of Firefox and click OK.

Question owner

I followed jneighbors' advice and it seems to have done the trick. For completeness, I should add that I used John99's advice to restore the old default of 30 (vs. jneighbors' value of 48). Problem apparently solved-- thanks all.

Modified by nedhubbard

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8016 answers

Glad we helped.

ralphbusdriver 0 solutions 19 answers

I had the same problem, but mostly fixed it selecting the eventual option under Help/Restart with Addons Disabled/Restart/Reset all user preferences to default menu. That reset FF without my previous personal settings.

I had at least two such personal settings from prior FF versions that worked well until FF6: Checking for new pages each time instead of cache, and another suggested setting to avoid getting the "Page not available" screen.

There are still severe memory leaks over time, though, and it slows down considerably. I close FF7 after a few hours and it still runs according to the Vista task manager for about 2 minutes using up to 40% of CPU resources. Upon restart after it really fully shuts down - it works fine for a few hours before bogging down again.

I also tried the suggestion above concerning the number of network connections with a new personal setting, but the default integer was already 32 - from my "Tweak Network" addon so I left it.

Modified by ralphbusdriver