X
Tap here to go to the mobile version of the site.

Support Forum

How do I get firefox to show the http:// in a web address?

Posted

I've noticed that suddenly, I can't get Firefox to show the http:// in a web address, even if I type it. How do I get Firefox to show it?

I've noticed that suddenly, I can't get Firefox to show the http:// in a web address, even if I type it. How do I get Firefox to show it?

Chosen solution

For this, you need to use the magical about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste urlbar and pause while the list is filtered

(3) Double-click browser.urlbar.trimURLs to toggle it from true to false (it should turn bold).

You're done, you can close that tab.

Does it work?

Read this answer in context 19

Additional System Details

This happened

Every time Firefox opened

This started when...

I noticed it shortly after the last update I downloaded.

Installed Plug-ins

  • Shockwave Flash 10.3 r181
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • 4.0.60531.0
  • iTunes Detector Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 12.0.1.609
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • npdnupdater2
  • npdnu
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • np-mswmp
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20100101 Firefox/7.0

More Information

jscher2000
  • Top 10 Contributor
6447 solutions 52788 answers

Chosen Solution

For this, you need to use the magical about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste urlbar and pause while the list is filtered

(3) Double-click browser.urlbar.trimURLs to toggle it from true to false (it should turn bold).

You're done, you can close that tab.

Does it work?

For this, you need to use the magical about:config preferences editor. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste '''urlbar''' and pause while the list is filtered (3) Double-click '''browser.urlbar.trimURLs''' to toggle it from true to false (it should turn bold). You're done, you can close that tab. Does it work?

Helpful Reply

Yes! It worked! Thank you so much!

Yes! It worked! Thank you so much!