X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox keeps loading pages forever... or stops loading pages

Posted

Hi everyone... the issue I have is pretty much this:

I open a website, or some websites, and one of them keeps loading forever and it makes the other sites also loading forever. So, Firefox stops working as if there was no response from the servers...

If I open a new tab, it goes to the same and loads forever, but never gets to actually load any content at all...

The only way to fix this is by closing the window, and starting all again...

There is no particularly site, sometimes happens with Hotmail, Emol.com (chilean newspaper site), a forum, or just any site...

I have this issue since Firefox 6, but it was a lot less recurrent, I was able to use almost normally... it the problem comes, just restart the browser... the same solution...

Also, I'm pretty sure is NOT a net issue, since I don't have any problem at all with Internet Exlorer, or any other software.

I usually use FF in Private Browsing, but this problem occurs in both normal and private mode.

What I think it could be? I noticed EVERY page that makes the issue come up, has flash content... maybe Flash Player is the guilty, or the Plugin-Container handling it...

Things I have tried:

  • Re-installing the browser as admin
  • Clearing Recent History (Everything)

I guess that's all, any question or suggestion, please post it, I'll be checking this thread as often as I can.

Thanks for your attention, even if you just readed this.


PS: Sorry for my english, I speak spanish...

Chosen solution

@yesyes - Did you perform the suggestions mentioned in the article provided my previous reply ?? IF Yes, then try the following:

Type about:config in the Location (address) bar and press the "Enter" key. When you see a warning, click I'll be careful, I promise! button.

-> In the Filter bar, type network.http.max-connections

  • Right click the preference network.http.max-connections and choose Modify
  • change the value to 30 or 48
  • click OK

-> Close the about:config tab

  • Restart Firefox.

Check and tell if its working.

Read this answer in context 16

Additional System Details

Sites Affected

A lot of websites

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • 4.0.60531.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"
  • NPWLPG
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

More Information

Configuración básica de la aplicación
Nombre
Firefox
Versión
7.0.1
Agente de usuario
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Directorio de perfil
Abrir la carpeta que lo contiene
Plugins activados
about:plugins
Configuración de compilación
about:buildconfig
Extensiones
Nombre
Versión
Activada
ID
Preferencias modificadas
Nombre
Valor
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20110928134238
browser.startup.homepage_override.mstone
rv:7.0.1
extensions.lastAppVersion
7.0.1
general.useragent.extra.brc
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1317259795
places.history.expiration.transient_current_max_pages
60035
print.print_printer
Microsoft XPS Document Writer
print.printer_Microsoft_XPS_Document_Writer.print_bgcolor
false
print.printer_Microsoft_XPS_Document_Writer.print_bgimages
false
print.printer_Microsoft_XPS_Document_Writer.print_command
print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts
false
print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_left
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_right
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_top
0
print.printer_Microsoft_XPS_Document_Writer.print_evenpages
true
print.printer_Microsoft_XPS_Document_Writer.print_footercenter
print.printer_Microsoft_XPS_Document_Writer.print_footerleft
&PT
print.printer_Microsoft_XPS_Document_Writer.print_footerright
&D
print.printer_Microsoft_XPS_Document_Writer.print_headercenter
print.printer_Microsoft_XPS_Document_Writer.print_headerleft
&T
print.printer_Microsoft_XPS_Document_Writer.print_headerright
&U
print.printer_Microsoft_XPS_Document_Writer.print_in_color
true
print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_left
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_right
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_top
0.5
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_orientation
0
print.printer_Microsoft_XPS_Document_Writer.print_page_delay
50
print.printer_Microsoft_XPS_Document_Writer.print_paper_data
1
print.printer_Microsoft_XPS_Document_Writer.print_paper_height
11,00
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_width
8,50
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_scaling
1,00
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
true
print.printer_Microsoft_XPS_Document_Writer.print_to_file
false
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top
0
privacy.cpd.siteSettings
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Gráficos
Descripción del adaptador
Intel(R) HD Graphics
ID del fabricante
8086
ID del dispositivo
0046
RAM del adaptador
Unknown
Controladores del adaptador
igdumd64 igd10umd64 igdumdx32 igd10umd32
Versión del controlador
8.15.10.2202
Fecha del controlador
8-25-2010
Direct2D activado
true
DirectWrite activado
true (6.1.7601.17563)
Parámetros de ClearType
Parámetros de ClearType no encontrados
Renderizador WebGL
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
Ventanas aceleradas mediante GPU
1/1 Direct3D 10

SlowMotionKarma 0 solutions 1 answers

Helpful Reply

I have this problem as well. There are also other questions here that seem to have the same core problem. Some of my personal troubleshooting process/config settings:

  • I'm running Windows 7 on my desktop and Windows Vista on my laptop. Both have this problem.
  • I'm running Firefox 7, this originated on Firefox 6 (Firefox 5 is fine. I uninstalled 7 and installed 5 to test. No problems on 5.). Has happened to me more often on 7 than it did on 6 as far as I can tell.
  • My internet IS working. IE9, Chrome, third-party download programs, etc. still work just fine as well, WHILE Firefox is stuck on loading sites.
  • Active downloads slow, then eventually stop at "0 kb/s" and stay that way until restart inside the Firefox download manager.
  • The site(s) inside tabs don't seem to matter. Browsing sites without any Flash elements still results in the loading error.
  • Running Firefox in safe-mode doesn't help.
  • Starting a new Profile doesn't help.
  • Uninstalling/re-installing doesn't help.
  • Even a "clean" install (Uninstalled, then removed all instances of Firefox from the registry, deleted all profiles/personal Firefox folders/setting files, etc.) on laptop and it still has this problem.
  • Removing and re-adding Firefox to my firewall's "allowed list", as well as disabling my firewall and virus protection program has no effect.
  • Closing Firefox and re-opening it allows content to load normally... at least until it gets stuck on the loading error again.
  • The error can happen at any time. Sometimes 5 minutes after opening Firefox, sometimes it's fine for hours before the error appears.

That's all I can think of right now. Hopefully someone knows of a fix for this, or hopefully it is being fixed. I'd really hate to leave Firefox after using it for so many years, but if it can't "do the basics" I might have to move over to Chrome or something until this has been ironed out... and I REALLY don't want to do that.

Hasan 477 solutions 5600 answers

Firefox can't load websites but other browsers can

Check and tell if its working.

Modified by Hasan

yesyes 0 solutions 3 answers

I have the same problem. I have found a few websites that always cause the problem: - ebay.co.uk (enter a search term and click search -> FF stops loading any pages) - youtube.com (also after doing a search) - Google Images (again, after a search, it loads a few of the image results, the rest remains grey and FF does not load any further pages)

When the issue occurs FF just says "Connecting to ....com" in the status bar whichever page I want to open. It also happens with pages that are already open and I click refresh.

At this point everything still loads fine in IE, so I doubt it is a network issue.

I have tried deleting temp files as mentioned in an earlier reply here but this has made no difference.

I'm currently running FF 7.0.1 but it also happened with 6.0.2 and earlier versions before I upgraded to FF7. OS is Win7 x64.

Oh, and it also happens when I start FF in safe mode (no add-ons loaded).

This is on my PC at work. It also happens on my girlfriend's PC (FF 7.0.1, Win7 x64) but NOT on my own PC at home (also FF 7.01 and Win7 x64).

Hasan 477 solutions 5600 answers

Chosen Solution

@yesyes - Did you perform the suggestions mentioned in the article provided my previous reply ?? IF Yes, then try the following:

Type about:config in the Location (address) bar and press the "Enter" key. When you see a warning, click I'll be careful, I promise! button.

-> In the Filter bar, type network.http.max-connections

  • Right click the preference network.http.max-connections and choose Modify
  • change the value to 30 or 48
  • click OK

-> Close the about:config tab

  • Restart Firefox.

Check and tell if its working.

Modified by Hasan

yesyes 0 solutions 3 answers

Hi mha007,

Now THAT has made all the difference. Thanks so much for that!!! I can buy stuff on ebay again .. ;-)

Would you mind explaining WHY that has helped, please? The default value was 256. Are these just too many connections? Isn't 30 a bit low now, seeing that the connections-per-server are set to 15.

Hasan 477 solutions 5600 answers

This value has been changed in Firefox 7. All earlier versions had value 30, that's why i asked you to change it to 30. You can try to use other values as well (just for checking purposes).

BTW i am also using Firefox 7 and i don't need to change the value to 30. I am using it with the default value 256.

yesyes 0 solutions 3 answers

I just checked here at home where everything works. It is also set to 256. But this machine is much more powerful and has more memory. Could this have something to do with it?

I'm happy that it works now but I do like to understand the issue and the resolution... ;-)

Fook 0 solutions 5 answers

i did the about:config deal- absolutely no change. I've tried in Safe Mode with add-ons disabled but it stalls on SFGate and NYTimes. Tired of switching browsers all the time. I am going through the tedious business of switching to another default browser. I have been with FF for quite some time but the last few months have been very frustrating. I no longer trust them. The new releases in quick succession are IMO a bad idea.

Question owner

mha007: I just did the about:config suggestion... and it worked! At first nothing happened, but I noticed my MSN Messenger had a message about network issues... so I decided to give it a try when my ISP fix the problems... so a couple of hours later, the net was ok, and I checked Firefox, and it was just perfect... just the change of that value fixed everything...

Thanks a lot, I really mean it... IE crashed for nothing, it's almost a headache to use it, though it's a lot better than older versions.

But, there is still the question, how the change of that value affects FF? and, what I think it's even more important, why doesn't work ok (at 256) to everyone?

I really hope someone at Mozilla shows up, or at least, checks this issue....

Hasan 477 solutions 5600 answers

I mentioned the reason in my previous reply. Though i don't know the technicalities of it.

Modified by Hasan

Question owner

@mha007: Yes, you said they changed the value from one version to the other... but not why, and how does it affects the browser, besides of the issues...

Hasan 477 solutions 5600 answers

To help other users find solutions, please return to this Thread and Sign-in to the forum with your Username and Password:

click on "Solved It" Next to the reply ABOVE that BEST solved your Question

DO NOT click "Solved It" next to this reply

wolverana 0 solutions 11 answers

I have had this issue since the last update. I am running 12.0 version and it's fully up to date as of this date posted (5/9/12 for anyone that can't see the date). This is a bad issue right now, most of the time the sites load without issues, but the loader stays running forever unless I hit the stop button. Please fix this problem.

Hasan 477 solutions 5600 answers

See this article -> Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Check and tell if the websites load normally while using Firefox Troubleshoot Firefox issues using Safe Mode.

wolverana 0 solutions 11 answers

Ok I have no other themes installed other than the default (which I did have until yesterday when I uninstalled the few I had because I wasn't sure if they were causing the issue). I went into safe mode and the issue is still there. I am now in the process of turning off plugins so I'll have to get back to you tomorrow on that as I need to log off. Hopefully the plugins are the issue because I've checked everything else I can think of. I've not changed any Firefox settings at all other than installing and uninstalling the themes (which could very well be the culprit, but they are gone now, so unless there are residual files somewhere that it didn't uninstall then I guess that's not it).

I'll get back on here tomorrow and let you know if the plugins had any effect or not. Thanks for trying so far :)

Hasan 477 solutions 5600 answers

See this article too -> Websites don't load - troubleshoot and fix error messages

wolverana 0 solutions 11 answers

Well that's the thing, I saw that article but it doesn't really pertain because the sites are loading, don't have much issues with that except once in a while a page doesn't load and I have to hit refresh or reopen the page, but for the most part the pages are loading fine, they finish loading visually, but the icon on the FF tab goes on forever even though the page looks fully loaded and functioning. I will take a look at that article again and see what it says to try. I already did all the scans and checks for spyware and viruses etc. that the one part of that article had on it.

There is a thread actually named for the issue I'm having that I read that part in, but nothing seemed to pertain to my particular problem at all with the site pages loading fine but the busy icon on the tab just going on forever.

Hopefully that all makes sense hehe, not sure what to call things so I just give them names :P

wolverana 0 solutions 11 answers

Ok so here's the results of all so far that have had no luck in fixing this. I'm about to reinstall Firefox and see if that works, but here's what I've tried so far:

Safe Mode
Turned off all Plugins (not safe mode)
Turned off Malwarebytes realtime protection completely
Turned off PC Tools Internet Security completely
Updated all Plugins
Scanned for any possible viruses/spyware/trojans/BHO
Checked Hijackthis to see if anything shows that shouldn't be there

None of these resulted in any fix for this and after I wrote that last message I have to recant that I have pages not load more often than I was thinking. It doesn't matter what site it's not any particular site, and it's only Firefox.

I'll reinstall Firefox and let you know what happens with that, it's all I can think of to try that's left.

Modified by wolverana

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Can you post a link to such a page where this happens?

It is possible that there is some problem with JavaScript that isn't running properly.

You can try to disable JavaScript temporarily to see if that works.

wolverana 0 solutions 11 answers

Well nothing has worked so far:

Reinstalled Firefox
Disabled Javascript as per your suggestion above

I'm out of ideas but this is getting really irritating. Pages are not loading as much as they were even yesterday, every 5th or 6th page is loading as much as maybe the menu on a page and then just loads for ever and ever and I have to hit the refresh button to get it to reload it correctly which it does.

The site this is happening the most on is this one (I'm actually wondering if it's the getclicky script they are running, but I have no way to know that as I set that as a trusted site on everything I could think of and it still does it so it might not be that.

http://coffeecup.com

That is a forum that I Admin on and Help on many times a day and I browse through a lot of the post that are posted each day and this loading forever (page finishes though visually) happens almost constantly after the first few pages.

I've checked with the other users and no one else seems to be having this issue, even those on the same version of Firefox I'm on (current release version).

Don't have a clue what happened, do you think I have some residual files somewhere maybe from the themes I was using that might be causing this? If so, do you have any idea where I'd go to look and how to get rid of it?