Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 7 takes a long time to load first web page.

  • 16 replies
  • 32 have this problem
  • 971 views
  • Last reply by SRD75

more options

After I have logged in to my Windows XP SP3 laptop, it takes a while for Windows to finish loading and for explorer.exe to become responsive and allow the Start menu to load.

Once the Start menu is working, I start Firefox, which opens, and it loads the tabs which were last open, which is okay, but it sits there and spins its wheels for about 2 minutes, doing nothing except displaying the hour glass icon and looking like it is trying to load the webpage, but no status messages appear in the status bar.

Why is it spinning it's wheels and doing nothing for so long?

I have 2 extensions and 1 plugin active:

Extensions: User Agent Switcher 0.7.3 Add to Amazon Wish List Button 1.7

Plugins: Shockwave Flash 10.3.183.10

Cheers.

Chosen solution

Also these?

Java Quick Starter 1.0 false jqs@sun.com
Microsoft .NET Framework Assistant 0.0.0 false
Read this answer in context 👍 0

All Replies (16)

more options

I have had that problem ever since 6 came out, 7 did not fix it. So I went back to 5. The moment I went back it was all fixed. I thought it was me, I thought it was my isp. But everything else would work fine, it was JUST Firefox 6 & 7. Take it back to 5. I was lucky enough to still have it stored. You will find it goes away. They need to fix the issue.

more options

Server not found

Check and tell if its working.

more options

I receive no errors as stated in the original post.

Eventually the webpage does load, but it takes 2 minutes for anything to start happening.

During that time, the program is responsive, but displays no errors or status messages.

This happened in Firefox version 6, as it did for the other poster in this thread.

more options

Even if you are not receiving any error messages, try the suggestions mentioned in the above article.

more options

Okay, thanks.

I rebooted, and loaded Google Chrome and Firefox at the same time. Chrome was able to load a website within 30 seconds, and Firefox was about 45 seconds, which is much quicker. Perhaps Chrome is connecting to the DSL router faster than Firefox is, and perhaps prompting the router to assign an IP address to the computer? If so, Firefox would not have to do this, which would reduce connection time. I will try this again first thing tomorrow morning, at which time the IP lease may have been dropped.

The other thing that might apply is DNS prefetching, which I've turned off. I will test the difference tomorrow.

Modified by SRD75

more options

Firefox has been much quicker since disabling DNS prefetching.

Thanks mha007

more options

I actually had to make a new profile, so I dont use the defult. That mean adding my addons all over again. Then I actually disabed IPv6 in the about:config part. ....well I set it to true. Fixed it instantly. I then managed to be able to use FF7 again.

more options

You mean IP6.disabled = true (in essence) ?

more options

bump

This is still occuring, in a different form.

When I first login to Windows, the first time Firefox loads, it always becomes "Not Responding".

If I end the firefox process and start it again, it will load quite normally the second time. The 2nd time I load it, the same plugins are enabled. Does this imply plugins are not the source of the problem?

DNS prefetching is still disabled, which initially cured Firefox spinning its wheels.

The following plugins are enabled:

  • Add to Amazon Wish List Button 1.7
  • Boomerang for GMail 1.0
  • DownThemAll! 2.0.8
  • Firebug 1.8.4
  • Memory Fox 7.4
  • User Agent Switcher 0.7.3

Firefox version is 7.0.1

I will disabled them, reboot, and see how Firefox performs on first run.

Cheers.

Modified by SRD75

more options

After disabling all Extensions and rebooting, Firefox starts fine, so it is Extension-related.

The most recent extensions installed are:

- Boomerang for GMail 1.0
- DownThemAll! 2.0.8 

I will leave them disabled, and enabled the others.

more options

Try to disable the Java Quick Starter extension.

  • Tools -> Add-ons -> Extensions
  • Control Panel -> Java -> Advanced tab -> Miscellaneous -> Java Quick Starter (disable)

Your above posted system details show multiple Java Console extensions.
You can uninstall and remove Java Console extensions, you do not need them to run Java applets.

See:

more options

-> Test for faulty extensions

Check and tell if its working.

more options

All the Java Consoles were already disabled when Firefox was initially not responding.

I do have the following Plugins though:

- Java Deployment Toolkit 6.0.240.7
- Java Platform SE 6 U24.
more options

Chosen Solution

Also these?

Java Quick Starter 1.0 false jqs@sun.com
Microsoft .NET Framework Assistant 0.0.0 false
more options

Yes, already disabled, thanks.

more options

It's working fine now. I think it is one of:

  • Boomerang for GMail 1.0
  • DownThemAll! 2.0.8