Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I restore the http:// prefix in FireFox 7

  • 1 reply
  • 54 have this problem
  • 245 views
  • Last reply by knorretje

more options

I have just installed Firefox 7 and I find that a new feature is that it removes the http:// prefix from URLs and makes other changes to URLs (I believe it removes trailing / characters) and greys out parts of URLs (www.). How can I restore the default behaviour of showing the full URL? A search of the support section; the web in general; Firefox options and about:config has not produced a solution.

All Replies (1)

more options

Hiding of the http: part

The protocol (http://) has been removed from the URL in the location bar for http:// pages only. https:// pages will still have the protocol. There's also a known bug where if you copy the URL after selecting it from the awesome bar dropdown (but before loading the page), it won't include the http:// part. Users can revert to the old behavior by setting browser.urlbar.trimURLs to false in about:config.

Urlbar highlighting

This is a feature in Firefox to highlight the domain in the URL bar. Other parts will become grey. You can change a preference to make the entire URL dark. Users can revert to the old behavior by setting browser.urlbar.formatting.enabled to false in about:config.

To change this preference:

type about:config in the Location/URL bar and press Enter.
if you see a warning, accept (promise to be careful)
Filter: browser.urlbar.formatting.enabled
in lower panel, double-click that item to toggle value to false