X
Tap here to go to the mobile version of the site.

Support Forum

I'm having problems playing fullscreen videos with Firefox 7... How do I fix?

Posted

Since installing Firefox 7 for Windows 7 x64, online videos opened to full-screen (YouTube, Vevo, etc...) open the player (Flash, Dixv, etc...) in the task bar as a separate program and the video now plays behind the task bar instead of in front of it... Please advise.

Since installing Firefox 7 for Windows 7 x64, online videos opened to full-screen (YouTube, Vevo, etc...) open the player (Flash, Dixv, etc...) in the task bar as a separate program and the video now plays behind the task bar instead of in front of it... Please advise.

Modified by corduroy1979

Additional System Details

This happened

Every time Firefox opened

This started when...

after installing Firefox 7

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • 4.0.60531.0
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Version 0.9.18, Copyright 2006-2009 Veetle Inchttp://www.veetle.com/
  • Version 0.9.18, copyright 2006-2010 Veetle Inchttp://www.veetle.com/
  • DivX Web Player version 1.5.0.52
  • np-mswmp
  • Yahoo! activeX Plug-in Bridge

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0) Gecko/20100101 Firefox/7.0

More Information

Hasan 469 solutions 5600 answers

Clear Cookies & Cache

Clear the Network Cache

Reload web page(s) and bypass the cache.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

Check and tell if its working.

Clear Cookies & Cache * https://support.mozilla.com/en-US/kb/Template:clearCookiesCache Clear the Network Cache * https://support.mozilla.com/en-US/kb/How%20to%20clear%20the%20cache#w_clear-the-cache Reload web page(s) and bypass the cache. * Press and hold Shift and left-click the Reload button. * Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) * Press "Cmd + Shift + R" (MAC) Check and tell if its working.

Question owner

no... online videos opened up to full screen are still playing behind the task bar instead of in front of it.

this doesn't happen in Netflix's web player... but does on all flash videos, divx, etc...

no... online videos opened up to full screen are still playing behind the task bar instead of in front of it. this doesn't happen in Netflix's web player... but does on all flash videos, divx, etc...
Hasan 469 solutions 5600 answers

Troubleshooting extensions and themes

Check and tell if its working.

Troubleshooting extensions and themes * https://support.mozilla.com/en-US/kb/Troubleshooting%20extensions%20and%20themes Check and tell if its working.
tryfos79 0 solutions 7 answers

Have the exact same problem. Flash player opens in task bar as separate programm and the video is played essentially on the desktop, behind the taskbar. Problem occurs only in fullscreen, normal mode is ok. IE is ok, so there must not be a problem with Flash player (latest version). Problem occurs ALSO in Firefox safe mode, so it's a Firefox 7 related problem, no plugins, no themes, no dvxa etc. OS win7 64

Have the exact same problem. Flash player opens in task bar as separate programm and the video is played essentially on the desktop, behind the taskbar. Problem occurs only in fullscreen, normal mode is ok. IE is ok, so there must not be a problem with Flash player (latest version). Problem occurs ALSO in Firefox safe mode, so it's a Firefox 7 related problem, no plugins, no themes, no dvxa etc. OS win7 64

Question owner

Yeah... I reverted back to Firefox 6.03 and everything is back to normal. This is definitely a Firefox 7 issue.

Yeah... I reverted back to Firefox 6.03 and everything is back to normal. This is definitely a Firefox 7 issue.
tryfos79 0 solutions 7 answers

Any solutions other than reverting back to previous versions? Anyone? Major bug!

Any solutions other than reverting back to previous versions? Anyone? Major bug!
cor-el
  • Top 10 Contributor
  • Moderator
17536 solutions 158566 answers

Try to disable the hardware acceleration in the Flash Player.

See:

Flash "Display settings" window:

Try to disable the hardware acceleration in the Flash Player. See: * https://support.mozilla.com/kb/Cannot+view+full+screen+Flash+videos * http://www.youtube.com/swf_test.html (right-click the player: Settings) Flash "Display settings" window: * http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html
tryfos79 0 solutions 7 answers

All above actions have been taken to no avail. This is a firefox 7 issue. It occurs even in safe mode! As stated above: Tried with no add-ons, no ha, all plugins (but flash) disabled. Similar threads exist and Mozilla does not provide a useful solution other than the usual "disable ha, clear cookies etc."!!! This has nothing to do with that. https://support.mozilla.com/en-US/questions/880714#answer-253160 https://support.mozilla.com/en-US/questions/880297

All above actions have been taken to no avail. This is a firefox 7 issue. It occurs even in safe mode! As stated above: Tried with no add-ons, no ha, all plugins (but flash) disabled. Similar threads exist and Mozilla does not provide a useful solution other than the usual "disable ha, clear cookies etc."!!! This has nothing to do with that. https://support.mozilla.com/en-US/questions/880714#answer-253160 https://support.mozilla.com/en-US/questions/880297
Hasan 469 solutions 5600 answers

Try Uninstalling & Reinstalling the Flash plugin

Uninstall Flash Player

How do I install the Flash plugin?

Check and tell if its working.

Try Uninstalling & Reinstalling the Flash plugin Uninstall Flash Player * http://kb2.adobe.com/cps/141/tn_14157.html How do I install the Flash plugin? * https://support.mozilla.com/en-US/kb/installing-flash Check and tell if its working.

Modified by Hasan

Question owner

Hey Tryfos79... just curious... are you using an HTPC (home theater PC)?

I'm only asking b/c as I've been trying to figure this out I've found several posts about Google Chrome having a similar problem last year (I don't believe they've been provided a solution) for people using Win 7 x64 on HTPCs... in particular people who changed the DPI settings in Win 7 to above 100% (which is a must if you're using your computer with an HDTV as the monitor and plan on being able to read the text).

That is my situation... HTPC connected to a Sony Bravia... DPI @ 200%. I have no idea if this is the issue for us, but like I said, Chrome apparently does the same thing as of about a year ago to folks w/the DPI maxed out.

Hey Tryfos79... just curious... are you using an HTPC (home theater PC)? I'm only asking b/c as I've been trying to figure this out I've found several posts about Google Chrome having a similar problem last year (I don't believe they've been provided a solution) for people using Win 7 x64 on HTPCs... in particular people who changed the DPI settings in Win 7 to above 100% (which is a must if you're using your computer with an HDTV as the monitor and plan on being able to read the text). That is my situation... HTPC connected to a Sony Bravia... DPI @ 200%. I have no idea if this is the issue for us, but like I said, Chrome apparently does the same thing as of about a year ago to folks w/the DPI maxed out.

Modified by corduroy1979

tryfos79 0 solutions 7 answers

Ok here's the deal: I'd spotted those threads about Chrome and DPI myself too, but didn't bother since Firefox is another browser, but after reading your advice I decided to give it a try. I do have my PC connected to a HDTV (not technically a HTPC it's custom built) and I did have the dpi settings to 113% (not 200%). I reverted to normal 100% and bam the situation was resolved! But here's an interesting twist: Since the display on the HDTV is practically unbearable with DPI at 100%, I decided to revert back to 113-115% and -what a surprise!- the problem did NOT come back. Strange things, I don't know if it was Firefox or Flash on the first place, but someone has to look into it. Not sure though about what that option in the custom DPI settings "use win xp style dpi setting" is... Thanks a lot my friend!

Ok here's the deal: I'd spotted those threads about Chrome and DPI myself too, but didn't bother since Firefox is another browser, but after reading your advice I decided to give it a try. I do have my PC connected to a HDTV (not technically a HTPC it's custom built) and I did have the dpi settings to 113% (not 200%). I reverted to normal 100% and bam the situation was resolved! But here's an interesting twist: Since the display on the HDTV is practically unbearable with DPI at 100%, I decided to revert back to 113-115% and -what a surprise!- the problem did NOT come back. Strange things, I don't know if it was Firefox or Flash on the first place, but someone has to look into it. Not sure though about what that option in the custom DPI settings "use win xp style dpi setting" is... Thanks a lot my friend!

Question owner

Awesome! Glad that worked for you. I didn't have time to test it this morning as I was still on Firefox 6.

Just upgraded to Firefox 7 and same thing... when DPI is set to 100%, problem resolved. Unfortunately for me this is on a TV in my living room and having the DPI at anything under 150% is unbearable. When I resorted back to 200%... no luck, same problem. Then again at 150%, same problem. DAMMIT!

I guess it's Firefox 6 for me until they get this resolved (fingers crossed). It's def a Firefox issue, not Flash, as Divx vids and the Divx player are doing the same exact thing.

At least we know what the hell's going on though I guess...

Awesome! Glad that worked for you. I didn't have time to test it this morning as I was still on Firefox 6. Just upgraded to Firefox 7 and same thing... when DPI is set to 100%, problem resolved. Unfortunately for me this is on a TV in my living room and having the DPI at anything under 150% is unbearable. When I resorted back to 200%... no luck, same problem. Then again at 150%, same problem. DAMMIT! I guess it's Firefox 6 for me until they get this resolved (fingers crossed). It's def a Firefox issue, not Flash, as Divx vids and the Divx player are doing the same exact thing. At least we know what the hell's going on though I guess...
simby 0 solutions 1 answers

Try Firefox 7.0.1, it solved this issue for me.

Try Firefox 7.0.1, it solved this issue for me.
youvegottobekiddingme 0 solutions 3 answers

Thanks corduroy and tryfos, It is a DPI issue for me as well. Problem occurs at 150%, switched to 100% problem went away, switched back to 150% and problem returns, tried 125% and problem went away again. I'm using 125% right now but everything's a bit small for me, so i'll be looking for other solutions. I'll either go with a large magnifying glass set on a stand between me and the TV, or a different web browser, but i haven't decided yet. Good luck to all.

Thanks corduroy and tryfos, It is a DPI issue for me as well. Problem occurs at 150%, switched to 100% problem went away, switched back to 150% and problem returns, tried 125% and problem went away again. I'm using 125% right now but everything's a bit small for me, so i'll be looking for other solutions. I'll either go with a large magnifying glass set on a stand between me and the TV, or a different web browser, but i haven't decided yet. Good luck to all.
tryfos79 0 solutions 7 answers

youvegottobekiddingme try to set a custom DPI from the win7 settings. For example 130 or 140%. I don't know from which point the problem starts. Try step by step until the problem occurs and then revert back to the last DPI setting. 140 from 150 is not a big difference.

youvegottobekiddingme try to set a '''''custom '''''DPI from the win7 settings. For example 130 or 140%. I don't know from which point the problem starts. Try step by step until the problem occurs and then revert back to the last DPI setting. 140 from 150 is not a big difference.

Helpful Reply

Alright... I found a fix!

Right click on your Firefox icon (not the one in your task bar), if it's not on your desktop, find it in the Mozilla Firefox program folder.

After right clicking, select Properties, then the Compatibility tab, then check the box that says Disable display scaling on high DPI settings.

That's it. I'm now back to using 200% DPI and have no problems with fullscreen videos. What a pain in the ass!

Alright... I found a fix! Right click on your Firefox icon (not the one in your task bar), if it's not on your desktop, find it in the Mozilla Firefox program folder. After right clicking, select Properties, then the Compatibility tab, then check the box that says Disable display scaling on high DPI settings. That's it. I'm now back to using 200% DPI and have no problems with fullscreen videos. What a pain in the ass!

Modified by corduroy1979

gaillimh 0 solutions 3 answers

That worked for me, corduroy1979. Thanks!

That worked for me, corduroy1979. Thanks!
mraca 0 solutions 1 answers

corduroy1979, Thank you very much for ending my nightmare. I was waiting patiently for a fix from Firefox to no avail. Your solution worked perfectly. Lesson learned, I will wait at least a week before applying updates.

Thanks again. Alex (Toronto)

corduroy1979, Thank you very much for ending my nightmare. I was waiting patiently for a fix from Firefox to no avail. Your solution worked perfectly. Lesson learned, I will wait at least a week before applying updates. Thanks again. Alex (Toronto)

Modified by mraca

youvegottobekiddingme 0 solutions 3 answers

Thanks corduroy, That worked for me as well. You saved me a lot of aggravation.

Thanks corduroy, That worked for me as well. You saved me a lot of aggravation.