X
Tap here to go to the mobile version of the site.

Support Forum

reset certificate settings

Posted

I attempted to remove all the certificates from Firefox, but apparently I just set them all as untrusted. Now I have problems viewing several websites. Is there a way to reset or remove or set to default all the certificate settings?

I attempted to remove all the certificates from Firefox, but apparently I just set them all as untrusted. Now I have problems viewing several websites. Is there a way to reset or remove or set to default all the certificate settings?

Chosen solution

You can click the Edit button in the Certificate Manager and restore the trust bits to make Firefox use that certificate as a root certificate.
Only do that for certificates that show as "Builtin Object Token" and never for intermediate certificates that show as "Software Security Device".

  • Tools > Options > Advanced : Encryption: Certificates - View Certificates

Rename the file cert8.db to cert8.db.old in the Firefox Profile Folder to reset all root certificates.

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

This will also remove all intermediate certificates that Firefox has stored by visiting secure websites.

Firefox will automatically store new intermediate certificates when you visit websites that send them.

Read this answer in context 3

Additional System Details

This happened

Every time Firefox opened

This started when...

I did something stupid.

Installed Plug-ins

  • np-mswmp
  • Winamp Application Detector
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • Google Update
  • Shockwave Flash 10.3 r183
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60531.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

Chosen Solution

You can click the Edit button in the Certificate Manager and restore the trust bits to make Firefox use that certificate as a root certificate.
Only do that for certificates that show as "Builtin Object Token" and never for intermediate certificates that show as "Software Security Device".

  • Tools > Options > Advanced : Encryption: Certificates - View Certificates

Rename the file cert8.db to cert8.db.old in the Firefox Profile Folder to reset all root certificates.

  • Help > Troubleshooting Information > Profile Directory: Open Containing Folder

This will also remove all intermediate certificates that Firefox has stored by visiting secure websites.

Firefox will automatically store new intermediate certificates when you visit websites that send them.

You can click the Edit button in the Certificate Manager and restore the trust bits to make Firefox use that certificate as a root certificate.<br /> Only do that for certificates that show as "Builtin Object Token" and never for intermediate certificates that show as "Software Security Device". *Tools > Options > Advanced : Encryption: Certificates - View Certificates ----- Rename the file cert8.db to cert8.db.old in the Firefox Profile Folder to reset all root certificates. *Help > Troubleshooting Information > Profile Directory: Open Containing Folder This will also remove all intermediate certificates that Firefox has stored by visiting secure websites. Firefox will automatically store new intermediate certificates when you visit websites that send them.

Question owner

I did both these things and it seems to have worked. Thanks much :)

I did both these things and it seems to have worked. Thanks much :)
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159854 answers

You're welcome

You're welcome