X
Tap here to go to the mobile version of the site.

Support Forum

I want Foxit to be PDF reader when opening PDF documents, as I had previously.

Posted

Previously, though having Foxit Reader [my chosen default] and Adobe Reader as PDF readers, Foxit was used when I opened documents on Firefox. Now, PDF documents open in Adobe Reader which I DO NOT WANT to OPEN PDF. How can I revert back?

Previously, though having Foxit Reader [my chosen default] and Adobe Reader as PDF readers, Foxit was used when I opened documents on Firefox. Now, PDF documents open in Adobe Reader which I DO NOT WANT to OPEN PDF. How can I revert back?

Additional System Details

This happened

Every time Firefox opened

This started when...

within past couple of weeks...when Firefox 6.0 was update

Installed Plug-ins

  • np-mswmp
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • Google Update
  • Shockwave Flash 10.3 r183
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60531.0
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2

More Information

I always had my PDF documents open using Foxit Reader, but now it only opens using Adobe Reader.

SafeBrowser 543 solutions 2390 answers

I do not see the "Foxit Reader Plug-in for Mozilla" listed among the Plugins submitted with your question (click on "More system details" to the right of your original question). You may have Foxit installed but disabled (go to Add-ons > Plugins and look for the Foxit plugin). If you see it and see an "Enable" button, that means it is disabled; click the "Enable" button.

Personally, I removed Adobe Reader over a year ago due to a conflict in Firefox with Foxit Reader. I rely only on Foxit for PDF files.

Foxit Reader: http://www.foxitsoftware.com/Secure_PDF_Reader/


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.



Not related to your question, but...

You may need to update some plug-ins. Check your plug-ins and update as necessary:

I do not see the "Foxit Reader Plug-in for Mozilla" listed among the Plugins submitted with your question (click on "More system details" to the right of your original question). You may have Foxit installed but disabled (go to Add-ons > Plugins and look for the Foxit plugin). If you see it and see an "Enable" button, that means it is disabled; click the "Enable" button. Personally, I removed Adobe Reader over a year ago due to a conflict in Firefox with Foxit Reader. I rely only on Foxit for PDF files. Foxit Reader: http://www.foxitsoftware.com/Secure_PDF_Reader/ '''If this reply solves your problem, please click "Solved It" next to this reply when <u>signed-in</u> to the forum.''' ------------------------- Not related to your question, but... You may need to update some plug-ins. Check your plug-ins and update as necessary: *Plug-in check: https://www-trunk.stage.mozilla.com/en-US/plugincheck/ *Adobe Shockwave for Director Netscape plug-in: [https://support.mozilla.com/en-US/kb/Using%20the%20Shockwave%20plugin%20with%20Firefox#w_installing-shockwave Installing ('''''or Updating''''') the Shockwave plugin with Firefox] *Adobe PDF Plug-In For Firefox and Netscape: [https://support.mozilla.com/en-US/kb/Using%20the%20Adobe%20Reader%20plugin%20with%20Firefox#w_installing-and-updating-adobe-reader Installing/Updating Adobe Reader in Firefox] *Shockwave Flash (Adobe Flash or Flash): [https://support.mozilla.com/en-US/kb/Managing%20the%20Flash%20plugin#w_updating-flash Updating Flash in Firefox] *Next Generation Java Plug-in for Mozilla browsers: [https://support.mozilla.com/en-US/kb/Using%20the%20Java%20plugin%20with%20Firefox#w_installing-or-updating-java Installing or Updating Java in Firefox]

Modified by SafeBrowser

Question owner

Thank you kindly for your reply and insight: (1) I followed your suggestions and did NOT find a Foxit plug-in; (2) I've thought about removing Adobe Reader but I thought some sites INSIST on it...sort of like some INSIST on we using IE as a web browser versus Firefox or Google Chrome.

Thank you kindly for your reply and insight: (1) I followed your suggestions and did NOT find a Foxit plug-in; (2) I've thought about removing Adobe Reader but I thought some sites INSIST on it...sort of like some INSIST on we using IE as a web browser versus Firefox or Google Chrome.
SafeBrowser 543 solutions 2390 answers

I am not aware of any sites requiring Adobe Reader. If you open a PDF file, the browser looks for something to handle the file, but I am not aware the the site looking for a plugin. I have used Foxit alone for almost 2 years with no problem in opening PDF files.


If my previous reply solves your problem, please click "Solved It" next to THAT reply when signed-in to the forum.

I am not aware of any sites requiring Adobe Reader. If you open a PDF file, the browser looks for something to handle the file, but I am not aware the the site looking for a plugin. I have used Foxit alone for almost 2 years with no problem in opening PDF files. '''If my previous reply solves your problem, please click "Solved It" next to THAT reply when <u>signed-in</u> to the forum.'''

Question owner

I unistalled Adobe Reader, but now opening a PDF through Firefox only opens a window asking which program to use, and opens the PDF in a separate program, not as a tab in Firefox.

I unistalled Adobe Reader, but now opening a PDF through Firefox only opens a window asking which program to use, and opens the PDF in a separate program, not as a tab in Firefox.
SafeBrowser 543 solutions 2390 answers

Assuming you have installed Foxit Reader, you need to change your settings in Options > Applications for PDF files to "Use Foxit Reader Plugin for Mozilla (in Firefox)". If you have not already done so, after installing Foxit Reader, you may need to exit from Firefox, wait a few seconds (15-30), then restart Firefox.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Assuming you have installed Foxit Reader, you need to change your settings in Options > Applications for PDF files to "Use Foxit Reader Plugin for Mozilla (in Firefox)". If you have not already done so, after installing Foxit Reader, you '''''may''''' need to exit from Firefox, wait a few seconds (15-30), then restart Firefox. *See --> [https://support.mozilla.com/en-US/kb/Options%20window%20-%20Applications%20panel Options window-Applications panel] *See --> [http://support.mozilla.com/en-US/kb/Managing+file+types Managing file types] *See --> [http://kb.mozillazine.org/File_types_and_download_actions File types and download actions (Mozillazine)] '''If this reply solves your problem, please click "Solved It" next to this reply when <u>signed-in</u> to the forum.'''

Modified by SafeBrowser

Question owner

Thank you for sticking with me on this...though I read and followed the info provided...NADA. I finally contacted Foxit Software itself, and within a couple of minutes their Tech Support worked me through download of plugin, adjusting Foxit Reader "File Associations" and Bingo! I'm up and running both Firefox and IE9 while next attempting to solve the mystery on my Google Chrome browser [it uses their own PDF reader apparently]. Thank you again!!

Thank you for sticking with me on this...though I read and followed the info provided...NADA. I finally contacted Foxit Software itself, and within a couple of minutes their Tech Support worked me through download of plugin, adjusting Foxit Reader "File Associations" and Bingo! I'm up and running both Firefox and IE9 while next attempting to solve the mystery on my Google Chrome browser [it uses their own PDF reader apparently]. Thank you again!!
SafeBrowser 543 solutions 2390 answers

Helpful Reply

Had you set your preferences in the Foxit program, contacting Foxit tech support would not have been necessary.

In Foxit, click Tools > Preferences, then click File Associations. There is a button to make Foxit the default PDF viewer, which would changed your Windows file associations. I wrongly assumed that you were more familiar with Foxit since you said you had it previously installed.

  • There is an online manual that covers the basics; get to it by clicking, in Foxit, Help > User Manual.
  • During the install process you also have the option to make Foxit the default browser and set the file associations; see image at the bottom of page 20 in the online User Manual.

With any program, always look for Options or Preferences and verify the settings for each and every item. Help is usually available on the publisher's web site or forums for understanding the settings.

Had you set your preferences in the Foxit program, contacting Foxit tech support would not have been necessary. In Foxit, click Tools > Preferences, then click File Associations. There is a button to make Foxit the default PDF viewer, which would changed your Windows file associations. I wrongly assumed that you were more familiar with Foxit since you said you had it previously installed. *There is an online manual that covers the basics; get to it by clicking, in Foxit, Help > User Manual. *During the install process you also have the option to make Foxit the default browser and set the file associations; see image at the bottom of page 20 in the online User Manual. With any program, '''''always''''' look for Options or Preferences and verify the settings for each and every item. Help is usually available on the publisher's web site or forums for understanding the settings.

Modified by SafeBrowser

prpfeif 0 solutions 3 answers

Helpful Reply

1. Open Foxit reader 5.0 2. Under help- check for updates now and make sure you have the latest Foxit Reader plugin for Mozilla (2.1.1.720) installed 3 Under Tools/Preferences/File Association Make sure Display PDF in Brower is checked 4. In Firefox 7.0.1 Under Tools/Options/Applications Make sure PDF file (application/pdf) Use Foxit Reader Plugin for Mozilla (in Firefox) is selected

1. Open Foxit reader 5.0 2. Under help- check for updates now and make sure you have the latest Foxit Reader plugin for Mozilla (2.1.1.720) installed 3 Under Tools/Preferences/File Association Make sure Display PDF in Brower is checked 4. In Firefox 7.0.1 Under Tools/Options/Applications Make sure PDF file (application/pdf) Use Foxit Reader Plugin for Mozilla (in Firefox) is selected

Modified by prpfeif

desco 0 solutions 1 answers

Foxit plug-in for Firefox listed v 1.0.1.1117 Foxit is set to be the default PDF reader.

Opening a link that offers a PDF document ends in a blank stare from Firefox v8.0

Foxit plug-in for Firefox listed v 1.0.1.1117 Foxit is set to be the default PDF reader. Opening a link that offers a PDF document ends in a blank stare from Firefox v8.0
mtnk 0 solutions 1 answers

I had to disable the Adobe Acrobat plugin as well. After that all the sky turned blue again ... (*_*)

I had to disable the Adobe Acrobat plugin as well. After that all the sky turned blue again ... (*_*)