X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My touchpad will not scroll with the current version of foxfire.

Posted

The screen in foxfire will not scroll with the sliding of my finger on right side of the touchpad on my lenovo thinkpad or the navigation button. It does work with all other programs including windows explorer and google chrome.

Additional System Details

This happened

Every time Firefox opened

This started when...

updated foxfire

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 8.3.0
  • Shockwave Flash 10.3 r181
  • Google Update
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

Try to modify the pref ui.trackpoint_hack.enabled on the about:config page from the default value -1 to 0 or 1 to see if that makes the scroll pad work.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold(user set).
  • Preferences can be reset to the default or changed via the right-click context menu.
rickexner 0 solutions 3 answers

Helpful Reply

OK, this is the original poster again. The trackpad scrolling problem has been sporadic. Now I have realized that I have this problem (in Firefox 7.0 and 7.01) WHEN THERE IS A PDF DOCUMENT OPEN IN ONE OF THE TABS. When there is a .pdf open, trackpad scrolling works fine in *that* tab but not in any of the other Firefox tabs that are open. When I close or move away from the .pdf file, then the scrolling function returns in the other tabs. Is there something about the Acrobat plug-in (ver. 9.4.5) that isn't working correctly in Firefox 7.x?

SteveH_66 0 solutions 2 answers

Helpful Reply

That was a good catch by rickexner. I am having the exact same problem. If I have multiple tabs open and one of them has a PDF in the tab (I have Firefox settings set to open PDF's with Reader by default but some sites have the PDF embedded and open the PDF within the HTML page, such as www.free-ebooks.net for example) then scrolling doesn't work in any other tab, but works fine in the tab with the PDF open in it. But, if you close the tab or navigate it away from the page that has the embedded PDF, then touchpad scrolling functionality returns to all tabs, in my case at least. If you restart Firefox then occasionally you get intermittent touchpad scrolling again in the tab that happens to be active when the restart finishes, SOMETIMES. But when you go to another tab, it doesn't work even in the one that you had active when the restart finished if you go back to it. Close the tab with the embedded PDF or navigate away from that page and presto - scrolling works again in the other tabs. I say presto because it's just like a magic trick, lol. By the way, I went and changed the ui entry in about:config as suggested by another poster, still happens even with it changed to 0 or changed to 1, I tried both.

  • Windows 7, latest updates
  • Acer Aspire 5733Z-4851 notebook
  • Firefox 7.0.1
  • Started happening right after latest Firefox upgrade I believe.
  • Gish It is the only new extension I have added in the last week or so

Modified by SteveH_66

ptomes 0 solutions 3 answers

https://bugzilla.mozilla.org/show_bug.cgi?id=622410 Vertical scrolling with trackpoint (Thinkpad, Synaptics drivers) still won't work

https://bugzilla.mozilla.org/show_bug.cgi?id=626813 laptop touchpad scrolling doesn't work on other pages/tabs while PDF file is open through browser plugin in any tab in the same window

wollysf 0 solutions 4 answers

This worked for me, and might work for you too if you have a process called apoint.exe running on your computer and middle-mouse scrolling works in all other programs but NOT in Firefox . You can check for apoint.exe by pressing Ctrl-Alt-Delete to bring up Task Manager and sorting the processes by name, then checking for apoint.exe under the As.

When it starts up, apoint.exe reads a data file called tp4table.dat. There were several copies on my machine, so I searched the entire C:\ drive and then modified all of them. I opened each one in notepad.exe and added these lines:

Firefox
  • ,*,firefox.exe,*,*,MozillaWindowClass,WheelStd,0,9
  • ,*,firefox.exe,*,*,MozillaDropShadowWindowClass,WheelStd,0,9
  • ,*,firefox.exe,*,*,MozillaUIWindowClass,WheelStd,0,9

under the section whose comment says something like "these rules are loaded last". Make sure the lines are in the right section (e.g., not in the [Autoscroll] section) otherwise the firefox.exe lines won't have any effect.

After you're done editing all those files, close Firefox. Then go to Task Manager again and "End Process" apoint.exe. Then start it from Start->Run. On my system the full program path is C:\program files\apoint2k\apoint.exe. Confirm in Task Manager that apoint.exe reappears in the process list. Then start Firefox and try scrolling.

See this page for more info:

http://aslezak.com/thinkpad-trackpoint-scrolling-in-firefox

ikke 0 solutions 6 answers

If it's a Synaptics you could try [HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh] "UseScrollCursor"=dword:00000000

georgeskanoute 0 solutions 2 answers

Closing PDFs open in firefox indeed fixed the problem for me. But this is very silly. I often have a PDF open in one of my tabs and it's a serious handicap to have scrolling disabled while a PDF is open, which for me is pretty much all the time. How complciated can it possibly be to fix this if it worked in all previous versions!?!

SwingingSimian 0 solutions 1 answers

I have stumbled across this thread as am having problems with my new Dell XPS with synaptic touchpad v7.4.After reading this thread (http://www.howtogeek.com/howto/windows-vista/fixing-firefox-scrolling-problems-with-dell-synaptics-touchpad/) I decided to mess around with the preferences. The fix specified in that thread is no an option for me, but I found disabling 'autoscroll' restored scrolling function in firefox. Hope this helps.