X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox wont save my passwords even though I have ticked the box?

Posted

I have ticked the box to save my passwords, but I have to add them everytime Firefox loads. How do I get it to save them?

Chosen solution

-> click Firefox button and click Options

  • Privacy panel -> History section -> Firefox will: select "Use Custom Settings for History" -> REMOVE Checkmark from Permanent Private Browsing mode -> place Checkmarks on:
    • 1) Remember my Browsing History 2) Remember Download History 3) Remember Search and Form History 4) Accept Cookies from sites -> click Exceptions... button and click Remove All button -> click Close 5) Accept Third-party Cookies -> Keep Until : select They Expire
    • -> REMOVE CHECKMARK from CLEAR HISTORY WHEN FIREFOX CLOSES
  • Security panel -> place Checkmark on Remember Passwords for sites -> click Exceptions... button and click Remove All -> click Close

-> Click OK on Options window -> Restart Firefox

Check and tell if its working.

-> IF you use Clear Recent History feature, DO NOT select Cookies, Forms and Search History, Active Logins, Site Preferences

-> IF you use Privacy Cleanup softwares like CCleaner, DON'T SELECT FIREFOX IN ITS SETTINGS. These softwares can be responsible for Deleting your Firefox Settings.

Read this answer in context 7

Additional System Details

This happened

Every time Firefox opened

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • Shockwave Flash 10.3 r183
  • McAfee MSC FF plugin DLL
  • 4.0.60531.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.2) Gecko/20100101 Firefox/6.0.2

More Information

dynamite 60 solutions 382 answers

See if the possible reasons provided in this article help to solve your problem: Usernames and passwords are not saved.

Hasan 477 solutions 5600 answers

Chosen Solution

-> click Firefox button and click Options

  • Privacy panel -> History section -> Firefox will: select "Use Custom Settings for History" -> REMOVE Checkmark from Permanent Private Browsing mode -> place Checkmarks on:
    • 1) Remember my Browsing History 2) Remember Download History 3) Remember Search and Form History 4) Accept Cookies from sites -> click Exceptions... button and click Remove All button -> click Close 5) Accept Third-party Cookies -> Keep Until : select They Expire
    • -> REMOVE CHECKMARK from CLEAR HISTORY WHEN FIREFOX CLOSES
  • Security panel -> place Checkmark on Remember Passwords for sites -> click Exceptions... button and click Remove All -> click Close

-> Click OK on Options window -> Restart Firefox

Check and tell if its working.

-> IF you use Clear Recent History feature, DO NOT select Cookies, Forms and Search History, Active Logins, Site Preferences

-> IF you use Privacy Cleanup softwares like CCleaner, DON'T SELECT FIREFOX IN ITS SETTINGS. These softwares can be responsible for Deleting your Firefox Settings.

Modified by Hasan

Question owner

Thanks all.... problem now solved :o)