Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Middle mouse button not opening links in new tab anymore

  • 9 replies
  • 180 have this problem
  • Last reply by DC Cardwell

more options

Sinc ea few days ago I can no longer open links in a new tab with my middle mouse button. All the other features in firefox that use it remain the same. (ie. middle click tab to close, tab bar to reopen last tab,scrolling.) I have changed no settings and have gone over them multiple times, but to na avail. Is it Firefox 6.0.1? Please help I like opening tabs without having to use a right click function.

All Replies (9)

more options

I can only help you get around the problem (circumvention).

You could use the keyboard shortcuts that existed before Mozilla tried to usurp user control of the their middle-click button (mine is set to "Enter") Ctrl+click on link, and Ctrl+Shift+click on link.

Keyboard Shortcuts:

You might try updating to Firefox 6.0.2 via Help > About Firefox, but I doubt that it would affect that.

Modified by David McRitchie

more options

None of the shortcuts are working anymore either. I love firefox, but if it means using internet explorer I will have to switch

more options

This problem started for me today too.

Middle Click / CTRL Click links would not open those links in a new tab; though Middle Click would scroll the page as normal.

I fixed it by creating a new Firefox profile using Profile Manager, starting Firefox using the new profile (now Middle Click / CTRL click worked fine), closed Firefox and reopened it using my original profile - and Middle Click / CTRL click now work fine.

more options

@Rmkdec: Made an account just to say thanks for this, it works perfectly now.

Modified by Randomini

more options

This would help if i knew how to get to profile manager, or what it is.. kind of a noob. Anyone have a simpler/more detailed explaination? Do I have to get an add-on? Thanks

more options

This can be a problem with Greasemonkey and Tab Mix Plus


Modified by cor-el

more options

Thanks! Disabled grease monkey and now it works perfectly.

more options

You can also update to the unreviewed Greasemonkey 0.9.11:

more options

Thanks cor-el - this has been driving me nuts for days but I upgraded to Greasemonkey 0.9.11 and it fixed the problem for me :)