X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Arabic text displayed incorrectly on sites!

Posted

Arabic text characters are all connected one to another in a word, but FireFox displays the letters right, except they are disconnected and each letter is on its own, making it very difficult if not impossible to read.

What I used to do in the past is, pages that contain Arabic Text for me such as Facebook, I used to install IETAB2 and set facebook to always open with IETAB and then the text would display correctly.

The strange thing is, if you use IE, it would display the same garbage isolated Arabic letters, but the IETAB with IE7 emulation works like a charm.

With that said, recently, FF stopped displaying arabic text correctly even with IETAB2

But Google Chrome always works like a charm without the need for anything.

I have tried changing the encoding on the site but that doesn't help

Can anyone suggest anything please?

Google Chrome, Correct display of Arabic Text:

http://img148.imageshack.us/img148/9937/chromefc.png


FireFox with IETAB or without, same result:

http://img11.imageshack.us/img11/8855/firefoxlh.png


Anything other than UTF-8 will just display as jibberish.

But the problem with UTF-8 is that the Arabic letters are not linked one to the other, each one is seperated, makeing it very difficult to read.

What's even weirder is, I checked with Chrome, which displays Arabic Text just fine, and it is also using the UTF-8 encoding but it works!? Please help as I don't want to use Chrome :(

Chosen solution

Maybe there is a problem with the Lucida Grande font (font-family:"lucida grande") that Facebook uses on their website that doesn't work well in Firefox.

As a test you can try to disable the website fonts and try some different default fonts like Arial or Verdana.

  • Tools > Options > Content : Fonts & Colors > Advanced > [ ] "Allow pages to choose their own fonts, instead of my selections above"
Read this answer in context 10

Additional System Details

Sites Affected

http://www.facebook.com

Installed Plug-ins

  • Google Update
  • Shockwave Flash 10.3 r183
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_27 for Mozilla browsers
  • 4.0.60531.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • 12.0.1.666
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • BlackBerry WebSL Browser Plug-In
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

More Information

Question owner

I just realised this only happens in www.facebook.com . other sites with arabic text display fine, but Google Chrome always displays everything right even in Facebook

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Chosen Solution

Maybe there is a problem with the Lucida Grande font (font-family:"lucida grande") that Facebook uses on their website that doesn't work well in Firefox.

As a test you can try to disable the website fonts and try some different default fonts like Arial or Verdana.

  • Tools > Options > Content : Fonts & Colors > Advanced > [ ] "Allow pages to choose their own fonts, instead of my selections above"

Question owner

Wow!!! Thanks a lot man!!! That was so easy! I unchecked that option and now it worked as it was selected by default!!

Thank you sooooooooooo much!! Now I can install that crappy Google Chrome!!!!!!!!!!!! :)

Noone on any other forum was able to solve this issue!

Modified by Matrix Leader

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

The point is to see if disabling that setting temporarily and selecting some other fonts makes a difference.
It is possible that the Lucida Grande font that you have isn't working properly.

Question owner

You're right, when I set the font to Lucia Grande, the Arabic text gets messed up and each letter is separated, so it is the default font that Facebook uses which is the problem. Great find man! You're a true pro!