X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to save passwords after you've said "no" to the prompt or after changing them on another computer

Posted

How do I prompt Firefox to ask to save a password. Once I say "no" it never asks again (but now I would like it to remember the password for certain sites). I have also changed my password on some sites (while on another computer) and I cannot find out how to get Firefox to remember new passwords. I'm using Firefox 6.0.1 on a mac. I'm not using private browsing. I have 'remember passwords for sites' clicked and there are no exceptions. I've tried removing cookies, history, looking at page info.

Modified by jfenske

Chosen solution

The website may be using autocomplete=off to prevent Firefox from saving the name and password.
You can remove autocomplete=off with a bookmarklet to make Firefox save the name and password.


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • iPhoto6
  • Office Live Update v1.0
  • Shockwave Flash 10.1 r102
  • 4.0.51204.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

More Information

accessibility.typeaheadfind.flashBar0browser.history_expire_days.mirror180browser.places.importBookmarksHTMLfalsebrowser.places.smartBookmarksVersion2browser.startup.homepagehttp://www.google.ca/browser.startup.homepage_override.buildID20110830092941browser.startup.homepage_override.mstonerv:6.0.1extensions.lastAppVersion6.0.1network.cookie.prefsMigratedtrueplaces.database.lastMaintenance1315165971places.history.expiration.transient_current_max_pages120795places.last_vacuum1300843045privacy.sanitize.migrateFx3Prefstrueprivacy.sanitize.timeSpan0security.warn_viewing_mixedfalse

cor-el
  • Top 10 Contributor
  • Moderator
10755 solutions 96800 answers

See:

If you clicked "Never" then you have created an exception that you need to remove. Remove site(s) from the Exceptions:

  • Firefox > Preferences > Security: Passwords: Exceptions

If you let Firefox fill the wrong password then you can replace that password with the correct password and Firefox should offer to store the new password.

If you need to remove a saved password in case Firefox didn't ask:

  • Click the (empty) input field on the web page to open the drop down list
  • Highlight an entry in the drop down list
  • Press the Delete key (on Mac: Shift+Delete) to remove it.

Question owner

I tried all three of these suggestions. 1. I did not say never so there are no sites under 'exceptions' 2. If I fill in the wrong password, the website itself tells me it is wrong and I fill in the right one as usual. No prompt to save the new password 3. I removed the drop down list. Added the new username for the website and again, was not prompted to save password (and now it won't save the username anymore either).

Modified by jfenske

cor-el
  • Top 10 Contributor
  • Moderator
10755 solutions 96800 answers

Make sure that you do not run Firefox in permanent Private Browsing mode.

  • https://support.mozilla.com/kb/Private+Browsing
  • You enter Private Browsing mode if you select: Firefox > Preferences > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Firefox > Preferences > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Permanent Private Browsing mode"

The website may be using autocomplete=off to prevent Firefox from saving the name and password.
You can remove autocomplete=off with a bookmarklet to make Firefox save the name and password.

Modified by cor-el

Question owner

No, I'm not using Private Browsing, I just checked.

I know the websites are not the problem because there are two people using this computer (two different computer accounts when you turn it on) and one person kept their settings and passwords are still saved. Also, for one particular site, two people have usernames and passwords. One is still working and the one that I shift+deleted has been removed and will not pop back up.

cor-el
  • Top 10 Contributor
  • Moderator
10755 solutions 96800 answers

You do have remember passwords enabled?

  • Tools > Options > Security: Passwords: "Remember Passwords"

You can try to reset all data saved from that website (domain) by using "Forget About This Site" in the right-click context menu of an history entry of that website (Sidebar: Ctrl+H or History > Show All History)

This will also remove all bookmarks from that domain, so you need to recreate those if necessary.

Question owner

I have passwords enabled and I can see all the sites for which I have passwords saved.

I did the 'forget about this site' and it removed all the saved usernames and their passwords. And now it won't save them back.

I just want that little key to show up on the top right and ask 'do you want to save this password' or whatever. There MUST be a way to get it.... no?

Hasan 477 solutions 5600 answers

-> click Firefox button and click Options -> Privacy panel -> History section -> Firefox will: select "Use Custom Settings for History" -> REMOVE Checkmark from Permanent Private Browsing mode -> place Checkmarks on:

1) Remember my Browsing History 2) Remember Download History 3) Remember Search and Form History 4) Accept Cookies from sites -> click Exceptions... button and click Remove button for all websites which have statuses other than Allow -> Now type the addresses of the websites on which you want to Allow Cookies to be stored e.g. login.live.com , mail.live.com , hotmail.com , live.com , msn.com , login.yahoo.com , mail.yahoo.com , yahoo.com , mail.google.com , google.com , etc. -> click Allow for each, One by One 4a) Accept Third-party Cookies -> Keep Until : select They Expire

-> REMOVE CHECKMARK from CLEAR HISTORY WHEN FIREFOX CLOSES

-> click Firefox button and click Options -> Security panel -> place Checkmark on Remember Passwords for sites -> click Exceptions... button and click Remove All -> click Saved Passwords button -> select the websites whose Username & Password you want to change and click Remove button -> click Close

-> Click OK on Options window -> Restart Firefox

Now go the website whose Username & Password you want to Save

  • Enter your Username & Password on the website (it should not auto-fill your username & password right now since you just Deleted them)
  • click the Log-In OR Sign-In button on the website
  • Now click Remember Password button

Check and tell if its working.

Modified by Hasan

Question owner

Where is the 'ok' button? I do not see one so I just press "return" (as per usual for many things on the mac). When I go back to 'Firefox' - 'Preferences' - 'Privacy' it has gone back to 'Firefox will: remember history'. ie it does not save my changes.

I followed those instructions though and manually put a website in question into the allow cookies section. Although it did not save my 'use custom settings for history', it saved that website in the 'allow' section. No other websites are in the list. I tried that website and it still does not prompt me to save my password.

No, I don't have private browsing on.

I'm using Firefox 6.0.1 on a mac

cor-el
  • Top 10 Contributor
  • Moderator
10755 solutions 96800 answers

Chosen Solution

The website may be using autocomplete=off to prevent Firefox from saving the name and password.
You can remove autocomplete=off with a bookmarklet to make Firefox save the name and password.


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Question owner

Thanks! The bookmarklet worked. Why would Firefox have such an obscure way to re-save passwords (that is why I didn't try it before)! I like the save password option and it worked fine until I had to change my passwords (as some email providers require you to do occasionally), etc. Anyway, it works now so thank you for all your help!

cor-el
  • Top 10 Contributor
  • Moderator
10755 solutions 96800 answers

You're welcome.

The website may have changed this recently and added autocomplete=off if it worked in the past without the bookmarklet.

Hasan 477 solutions 5600 answers

To help other users find solutions, please return to this Thread and Sign-in to the forum with your Username and Password:

click on "Solved It" Next to the reply ABOVE that BEST solved your Question

DO NOT click "Solved It" next to this reply