X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why won't firefox allow me to open and access my comcast emal?

Posted

I use firefox and have had no problems with it until about a week ago. Suddenly and without reason, it will allow me to go to my comcast.net email page, but when I try to access and load my emails, it will not do it. But I can do it on IE. I contacted comcast help and they said it is a problem with firefox. Help please.

Chosen solution

I honestly don't understand why Comcast puts their customers thru this every time they update or change their web mail portal interface; why they can't test it in Firefox and see if it works, before releasing the changes and then taking a few months to fix whatever is wrong.

When you're logged into Xfinity Connect open Preferences > General and change it to Xfinity Connect Lite. The "Lite" interface works fine in Firefox for me.

Read this answer in context 8

Additional System Details

Sites Affected

http://comcast.net

Application

  • User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; InfoPath.2)

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24406 answers

Chosen Solution

I honestly don't understand why Comcast puts their customers thru this every time they update or change their web mail portal interface; why they can't test it in Firefox and see if it works, before releasing the changes and then taking a few months to fix whatever is wrong.

When you're logged into Xfinity Connect open Preferences > General and change it to Xfinity Connect Lite. The "Lite" interface works fine in Firefox for me.

Question owner

Wow, I did what the-edmeister suggested and it worked!!! Thank you very much!!! Excellent info!!! Thank you!!!

airwulf 0 solutions 2 answers

It does not work for me as I can't open Preferences--it only goes to my Inbox.

airwulf 0 solutions 2 answers

Helpful Reply

It works now but I had to set Preferences from IE.

davestover@comcast.net 1 solutions 13 answers

I did what the ed-meister said but it didn't work. I sure agree with his frustration with comcast.net and the xfinity bunch. Every time there is an update from anyone, I am distrustful because half the time it takes hours to fix.

There is , I know, some combination of about:config changes or elimination of tasks in the control panel

davestover@comcast.net 1 solutions 13 answers

Going to Xfinity Connect Lite is a work around, not a true solution. It is not working for me.

davestover@comcast.net 1 solutions 13 answers

I found the solution to this problem. I noticed someone was trying to get rid of the Babylon search engine that mysteriously appeared on my computer also replacing Google in the tool bar.

A solution to eliminating Babylon eliminated my problem with trying to get my email through Comcast.net. I think.

To eliminate Babylon: Go to my computer, Go to the C Drive, Go to Program Files, Go to Mozilla Folder and Open, Open searchplugins folder, Drag Babylon to the trash. I also dragged a couple other search engines out of there.

Then I shut the computer down, but choose straight "Shut Down" not "Shut Down with Add Ons." I am not sure that is important but it sounded like a good thing to do.

Then, my problems with not being able to access my comcast.net email when using Firefox went away. Hope this helps others.

davestover@comcast.net 1 solutions 13 answers

See my reply. Scroll down. I found that eliminating Babylon on the tool bar solved the problem. Go to Computer, Go to C drive, Go to Program Files, Go to Mozilla Firefox folder, Go to searchplugins folder, Drag Babylon to trash. Shut the computer down. Use straight Shut Down, not Shut Down with Add Ons Allowed. My email through comcast.net was back.

davestover@comcast.net 1 solutions 13 answers

Sorry about the duplication. Dave