Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Need URL to download Firefox 5.0

  • 1 reply
  • 1 has this problem
  • Last reply by John99

more options

HI:

I need to download Firefox 5.0.

I can not use 6.0 because I cant use my Internet Banking with that version.

Help me to me the URL to download the Firefox 5.0. Please

Thanks Andy

All Replies (1)

more options

As Firefox 5 is no longer supported it is recommended you use Firefox 3.6. As you may only use Firefox 3.6 for the one site it may be worth considering Firefox portable, you are then able to use your ordinary Firefox 6 day to day, and keep all your settings and passwords, and just use Firefox 3.6 portable for the one site.

What is the bank you use ?
(From your system details I guess you are on 3.6 at present)
When you are on Firefox 6 use the feedback button to report the problem with the Bank Site. (I am not sure that can be done with Firefox 3.6, it could not be done earlier this year) link http://input.mozilla.com/feedback