Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how do i customize my bookmarks toolbar into small icons instead of just icons and text?

  • 3 replies
  • 4 have this problem
  • 1 view
  • Last reply by cor-el

more options

i can only have ten bookmarks on my bookmarks toolbar because i can't seem to get the small icons to work. the small icons works on the navigation toolbar, but not the bookmarks toolbar.

All Replies (3)

more options
more options

You have an item "My Web Search . . ." plug-in which is a well known troublemaker.

You should work through the following removal instructions as far as you need to (Google for information if you have any doubts.)

Courtesy of Helper7677 -

You have an item installed that is considered malware/spyware/adware. To see the Plugins reported with your question, click "More system details..." to the right of your original question or, on the Firefox menu, click Tools > Add-ons > Plugins.

   My Web Search Plugin Stub for 32-bit Windows 

This type of pest is usually installed along with software you download from the internet; generally free programs, but not always. Carefully watch for "extra" items that will be installed and un-check or opt-out of them.

   You can check to see if you have any of these from [Fun] Web Products" installed:
       Control Panel > Add or Remove Programs, click on any that you find and click "Remove": Ask.com Bar, My Search Bar, MyWay Speed Bar, My Web Search Bar, Fun Web Products Easy Installer
       See:
           http://www.safer-networking.com/removemywebsearch.php
           PC Hell: My Web Search Removal Instructions
           http://helpint.mywebsearch.com/intlinfo/help/toolhelp.jhtml#q3 
   Also see: http://kb.mozillazine.org/Uninstalling_toolbars
   You MAY need to change a preference if when typing one or two words in the URL/Location/Address Bar sends you to some search page other than the one you expect. To reset your default URL/location bar search provider:
       Enter about:config in the address/URL bar and press the Enter key
       If you see a warning, accept it (Promise that you will be careful)
       Filter = keyword.URL
       Below the Filter, if keyword.URL is bold, right-click on keyword.URL and choose "Reset"
       Restart Firefox (File > Restart Firefox)
       See: http://kb.mozillazine.org/Keyword.url

Modified by alan_r

more options

Add code to userChrome.css below the @namespace line.

You can use the ChromEdit Plus or Stylish extension to have easier access to the customization files.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

/* Set icon size on Bookmarks toolbar */
#personal-bookmarks .bookmark-item > .toolbarbutton-icon { height:16px!important; width:16px!important; }

/* Hide text on Bookmarks toolbar */
#personal-bookmarks .bookmark-item > .toolbarbutton-text { display:none!important; }