X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how to make my default search engine to google global

Posted

I'm experiencing the problem below,

http://content.screencast.com/users/moshingbananas/folders/Default/media/94cd02e0-ec5b-4a7b-87c7-d65ba43d8ad0/search%20page%20on%20firefox.jpg

and the results will always lead to the following,

http://content.screencast.com/users/moshingbananas/folders/Default/media/a9d67d96-7825-445d-a788-a2295747426e/icq%20SERP.jpg

Therefore, is there an option whereby I can change it according to my needs?

Appreciate any form of advise.

Chosen solution

Check if setting this hidden option helps:

  1. Open a new tab and in the address bar, type about:config and then press Enter
  2. Click the I'll be careful, I promise button
  3. In the Filter text box at the top, type keyword.url
  4. You will be presented with the setting for keyword.url.
  5. Right click on it and select Modify
  6. Paste the following address: http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=
  7. Click OK
Read this answer in context 11

Additional System Details

This happened

Every time Firefox opened

This started when...

After I've deleted an ICQ add-on.

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.5
  • Version 2.1.8.0
  • np-mswmp
  • Adobe PDF Plug-In For Firefox and Netscape
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 12.0.1.647
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 10.1 r85
  • Adobe Shockwave for Director Netscape plug-in, version 11.6
  • DivX Web Player version 2.1.1.94
  • DivX VOD Helper Plug-in
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.60531.0
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.0"

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

dynamite 60 solutions 382 answers

Chosen Solution

Check if setting this hidden option helps:

  1. Open a new tab and in the address bar, type about:config and then press Enter
  2. Click the I'll be careful, I promise button
  3. In the Filter text box at the top, type keyword.url
  4. You will be presented with the setting for keyword.url.
  5. Right click on it and select Modify
  6. Paste the following address: http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=
  7. Click OK

Question owner

Thanks, buddy!

The ICQ is gone.

Though, the funny thing is that when i tried typing in any random words, they immediately brought me into the site itself (and not the Google SERP).

Why is this so?

(Once again, thanks much!)

dynamite 60 solutions 382 answers

Helpful Reply

You're welcome!

The URL that I provided above is for Google's Browse By Name feature. It means that if Google finds a site matching your search term, it will take you directly to it; else, it will show the search results page. If you want to always perform a Google search, set the value of keyword.url to: http://www.google.com/search?ie=UTF-8&q=

See these articles for more information:
Location Bar Search
Google's browse by name in Firefox

Question owner

Awesome, it works.

Thanks again.