Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I need to restore YahooMail to the mailto: application list

  • 14 replies
  • 1 has this problem
  • 532 views
  • Last reply by k89c

more options

I accidentally removed Yahoo from the mailto: applications list: options>applications.

I found instructions here: http://support.mozilla.com/en-US/questions/668267 for re-adding it to about:config but it hasn't gone from about:config.

Firefox 5.0 under Windows 7 x64

Modified by dovestar

Chosen solution

So, you have a prefs with the value to open Yahoo mail?

Did you also check the other mailto prefs (network.protocol-handler) ?


Set the pref gecko.handlerService.allowRegisterFromDifferentHost to true on the about:config page.
Run this javascript code via copy and paste to the location bar and press the Enter key to run the code.

javascript:navigator.registerProtocolHandler('mailto','http://compose.mail.yahoo.com/?To=%s','Yahoo! Mail');


Do not forget to reset the pref gecko.handlerService.allowRegisterFromDifferentHost to false after you have added Hotmail.

(corrected javascript coded - C)

Read this answer in context 👍 0

All Replies (14)

more options

Is Yahoo Mail your default mail client? If it is, go to Start>Default Programs and make sure you have it set correctly.

more options

No, but it never has been. My other PC has Firefiox 5 running with Yahoo Mail ok and Yahoo Mail isn't the Windows default there either.

I'm talking about the setting within Firefox itself: Firefox Options -> Applications -> Mailto -> Application Details: Here you get an option to remove applications from the list. I removed Yahoo Mail, now I want it back.

more options

Sorry to be so long. I've been away. In your applications click on "Mail to" and it will show your default email. Click on the little drop arrow and it will show you the usual web mail alternatives including Yahoo.

This will help with possibilities and procedures -

https://support.mozilla.com/en-US/kb/Changing%20the%20e-mail%20program%20used%20by%20Firefox?s=mail+to&as=s

more options

This is where I deleted Yahoo Mail, it no longer appears in the drop down - see image below.

Modified by dovestar

more options

I'm afraid you'll need someone else's help.

Is the about:config entry for Yahoo the same as G.Mail and Hot Mail?

This will take you back to Page 1.

more options

Help anyone?

more options

You have to add your preferred email client to the Internet Options menu like this:

  1. Open Microsoft Internet Explorer and then click Tools and go to Internet Options.

  2. Click the Programs tab and where you see "Email", choose your email client.

  3. Remove the checkmark from where it says "Tell me if Internet Explorer is not the default browser" in the same menu.

  4. Click Apply/OK and close Internet Explorer.

  5. Next, start Firefox and click the orange Firefox button, go to Options | Options | Advanced.

  6. In the General tab, System Defaults at the bottom, checkmark the option: "Always check to see if Firefox is the default browser on startup" and then click the "Check Now" button.

  7. Click OK, close Firefox and then restart it again.

You should be able to see Yahoo as an option in the Applications panel.

more options

You can open the about:config page via the location bar and do a search for mailto via the Filter at the top of the about:config page.
You can reset all mailto related prefs via the right-click context menu to their default values.

more options

What should work is opening Options > Applications, clicking the item beside "mailto", selecting from the menu "Use other", then browsing to the application you want to use and choosing it. That item should then appear in that list. Choose it.

more options

Thanks for the effort guys but none of these help:

Xircal - It's nothing to do with the Windows default as explained earlier.

cor-el - I've already checked the about:config as explained earlier, Yahoo Mail is set correctly there.

finitarry - That would work if I was using an application but Yahoo Mail is a web app and so you can't browse to it.

more options

Chosen Solution

So, you have a prefs with the value to open Yahoo mail?

Did you also check the other mailto prefs (network.protocol-handler) ?


Set the pref gecko.handlerService.allowRegisterFromDifferentHost to true on the about:config page.
Run this javascript code via copy and paste to the location bar and press the Enter key to run the code.

javascript:navigator.registerProtocolHandler('mailto','http://compose.mail.yahoo.com/?To=%s','Yahoo! Mail');


Do not forget to reset the pref gecko.handlerService.allowRegisterFromDifferentHost to false after you have added Hotmail.

(corrected javascript coded - C)

Modified by cor-el

more options

Great job cor-el! Problem solved with your instructions only I had to put "Javascript: " in front of the line of code you gave me otherwise the location bar just ran a search. So the final solution is:

1 - Set the pref gecko.handlerService.allowRegisterFromDifferentHost to true on the about:config page.

2 - Copy the code below into the location bar and press enter:

javascript: navigator.registerProtocolHandler('mailto','http://compose.mail.yahoo.com/?To=%s','Yahoo! Mail');

3 - Set the pref gecko.handlerService.allowRegisterFromDifferentHost to false on the about:config page.

more options

ok cool it kinda works but everything is in the To: part of the email. subject and everything. For example the to: has "mailto:sale-c3e9m-2523143464@craigslist.org?subject=xxxxxxxx (city)" I cant figure that out. Any ideas? Thanks!

more options

I had the same problem after I removed Yahoo! Mail and tried to replace it. When I performed all of the steps you laid out with the javascript line, Yahoo! Mail was still not listed as an option to set up under mailto. I am running FireFox 6 and even tried unistalling and reinstalling without success (running Windows 7).

Any other ideas?