X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

pictures do not display in my yahoo emails, but they show up if I go to forward the email, since I went to version 5.0 please help, win7

Posted

Since I updated to version 5.0 of firefox, 95% of pictures do not display in the body of emails using my yahoo account. If I go to forward the email however I can find them displayed in the forwarding window. I do have all pictures set to display in the ff settings, and have not made any setting changes before or after the update. At first I thought it was the "New" yahoo mail, which I switched to from the "classic", but I cannot switch back. I finally opened my yahoo mail in IE, and the pictures show right up.

Additional System Details

This happened

Every time Firefox opened

This started when...

updated to version 5.0

Installed Plug-ins

  • Cooliris embedded in a tab
  • Garmin Communicator Plug-In 2.9.3.0
  • Office Plugin for Netscape Navigator
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Coupons, Inc. Coupon Printer DLL
  • Coupons, Inc. Coupon Printer Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.0
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60531.0
  • Office Live Update v1.5
  • NPWLPG
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0

More Information

I have also been experiencing the occasional browser crash, and some screen lockups when in yahoo since the update. I am running windows7.

Hasan 477 solutions 5600 answers

Taken from https://support.mozilla.com/en-US/questions/851423

If images are missing then check that you aren't blocking images from some domains.

See:

   http://kb.mozillazine.org/Images_or_animations_do_not_load 
   Check the permissions for the domain in the current tab in Tools > Page Info > Permissions
   Check that images are enabled: Tools > Options > Content: [X] Load images automatically
   Check the exceptions in Tools > Options > Content: Load Images > Exceptions 

You can use these steps to check if images are blocked:

   Open the web page that has the images missing in a browser tab.
   Click the website favicon (Site Identity Button) on the left end of the location bar. 
   Click the "More Information" button to open the "Page Info" window with the Security tab selected (also accessible via "Tools > Page Info").
   Go to the Media tab of the "Tools > Page Info" window. 
   Select the first image link and scroll down through the list with the Down arrow key.
   If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain. 

Check and tell if its working.

Question owner

I have checked everything listed above and there are no restrictions etc. Specifically when a friend sends an email with pictures in the body of the email, they do not display. If I press the forward button they will show up in the forwarding window. This only happens in my yahoo mail. I can forward the email to a hotmail acct, or to a gmail acct, and they also show right up. Kinda lost here.

Question owner

BTW, thanks mha007 for taking a shot at it.

Hasan 477 solutions 5600 answers

-> Tap ALT key or press F10 to show the Menu Bar

-> go to Help Menu -> select "Restart with Add-ons Disabled"

Firefox will close then it will open up with just basic Firefox. Now do this:

-> Update ALL your Firefox Plug-ins https://www.mozilla.com/en-US/plugincheck/

-> go to View Menu -> Zoom -> click "Reset" -> Page Style -> select "Basic Page Style"

-> go to View Menu -> Toolbars -> unselect All Unwanted toolbars

-> go Tools Menu -> Clear Recent History -> Time range to clear: select EVERYTHING -> click Details (small arrow) button -> place Checkmarks on Cookies, Cache, Site Preferences -> click "Clear Now"

-> go to Tools Menu -> Options -> Content -> place Checkmarks on:

1) Block Pop-up windows 2) Load images automatically 3) Enable JavaScript

-> go to Tools Menu -> Options -> Privacy -> History section -> Firefox will: select "Use Custom Settings for History" -> REMOVE Checkmark from "Permanent Private Browsing mode" -> place CHECKMARKS on:

1) Remember my Browsing History 2) Remember Download History 3) Remember Search History 4) Accept Cookies from sites -> select "Exceptions..." button -> Click "Remove All Sites" at the bottom of "Exception - Cookies" window

   4a) Accept Third-party Cookies -> under "Keep Until" select "They Expire"

-> REMOVE CHECKMARK from CLEAR HISTORY WHEN FIREFOX CLOSES

-> When using the Location Bar, suggest: select "History and Bookmarks"

-> go to Tools Menu -> Options -> Security -> place Checkmarks on:

1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries 4) Remember Passwords for sites

-> Click OK on Options window

-> click the Favicon (small drop down menu icon) on Firefox SearchBar (its position is on the Right side of the Address Bar) -> click "Manage Search Engines" -> select all Unwanted Search Engines and click Remove -> click OK

-> go to Tools Menu -> Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious Extensions (Add-ons) -> Restart Firefox

You can enable your Known & Trustworthy Add-ons later. Check and tell if its working.

Question owner

Well, ran through that list, which covers a lot of things, some unrelated, but ran through it anyway, still the problem persists. Let me mention another observance of mine, but it is not consistent. Sometimes the picture is just missing, there is no dead space or other indication that anything is was or should be there. but sometimes there is a line of info that starts with cid: or several lines. I just opened another email and there is actually jpg file names listed where the pictures should be, but they are not a link, nor are there attachments. I of course checked by opening the same email again in IE and the pictures were right there. So three different scenarios. ! no indication that anything is missing 2 cid: and a string of characters 3 jpg file name

The only other thing I want to mention, probably not related at all, but when I was going through the list above, while clearing recent history, I got a script message window that popped up. I was able to complete the task but I will paste it here in case it means anything:

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete. Script: chrome://browser/content/sanitize.js:133


Thanks again.

cor-el
  • Top 10 Contributor
  • Moderator
10758 solutions 96833 answers

Firefox doesn't support embedded images via CID (ContentID) (src="cid:image").
You need an email program to see such embedded images.

Modified by cor-el

Question owner

Thank you Cor-el, if that is the case then that would indicate that something is amiss with my yahoo mail program when I use it with Firefox, as I stated earlier (and just double checked), when I go to forward the email, the CID images show up just fine in the message window? Again I feel at a loss here. I appreciate the input.

wlotsberg 0 solutions 2 answers

Actually, I am running Firefox 8.0 and have the same problems on one of my laptops. Both Windows 7. One is running 32 bit OS and has the problem. The other is running 64 bit OS and has that problem rarely. 64 bit seems to handle the images more often than 32 bit. IE does not have this problem, so it should not be anything to do with Yahoo mail.

Hasan 477 solutions 5600 answers

-> Clear Cookies & Cache

-> Clear the Network Cache

-> Reload web page(s) and bypass the cache.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Cmd + Shift + R" (MAC)

Check and tell if its working.

LeesaWho 0 solutions 1 answers

I have the same problem and I've tried all the solutions above with no success. The problem seems to be getting worse. I'm not getting the images in about half of my emails now.

Question owner

I'm inclined to agree that it is a firefox issue not yahoo. But it is frustrating and I wish the firefox developers would weigh in on the matter. As far as 64bit vs 32 bit, I am running windows7 64bit OS but I suspect that when I d/l firefox it took it upon itself to d/l the 32bit version. I do not remember why. Good luck. Btw, I have tried all the earlier suggestions such as deleting cookies & cache etc, etc, etc...to no avail.

Question owner

Thanks mha, but I've tried all of those things and more. I am at a standstill. Guess I'll have to use IE for yahoo until when and if......

mainlymot 0 solutions 6 answers

I am having the same problem with Firefox 8.01 on Mac OSX 10.7.2. The images do show up inline on Safari. Starting FF in Safe Mode did nothing.

Hasan 477 solutions 5600 answers

@mainlymot

Create a New Profile as a test to check if your current profile is causing the problems.

-> Basic Troubleshooting - Make a New Profile

IF that New Profile works then you can recover your Bookmarks and Passwords from the Old Profile.

-> Recovering important data from an old profile

Check and tell if its working.

mainlymot 0 solutions 6 answers

I have tried to open the Profile Manager several times and I get this:

No such file or directory

I have used different variations (-p, -profilemanager,) but get the same results. Have closed Firefox and restarted the computer. Thanks

Hasan 477 solutions 5600 answers

Try Reinstalling Firefox

-> Uninstall Firefox from your computer - Uninstall your current Firefox

  • DO NOT SELECT TO REMOVE USER DATA AND SETTINGS
  • Restart your system

-> Download latest Firefox version from one of these links using some other Web Browser:

-> How to download and install Firefox on Mac

Check and tell if its working.

Modified by Hasan

mainlymot 0 solutions 6 answers

mha007

That seems to have worked. I sent inline images to myself from three other mail boxes and they opened in Yahoo Mail inline also. I'll know for sure when I get mail from other people. Thanks again.

Hasan 477 solutions 5600 answers

Glad to hear its working.

mainlymot 0 solutions 6 answers

Well, the changes that were done have not helped. Images do not show up in the body of the letters. Also, when a thumbnail of a picture is clicked (if there is one, right now there are thirty thumbnails and five have images in them), a sideshow window opens and it is usually solid black. I did switch back to Yahoo Mail Classic and everything worked as it should.