X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Have reset Firefox & completed all of steps in "Flash video won't play full screen on YouTube, Facebook and other websites", but video still won't work. Help!

Posted

I have reset Firefox, completed all the steps in "flash video won't play full screen on YouTube, Facebook and other websites". And the video still won't play in full screen. It will play, but frequently stops or sound continues and picture freezes. I have noticed that if I continually move my mouse, it plays fine. All these videos play fine in IE and Chrome.

Post a Reply

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • GEPlugin
  • Citrix Online App Detector Plugin
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Microsoft Lync 2010 Meeting Join Plug-in
  • 5.1.10411.0
  • IBM 821 Conference Plugin for Mozilla version 8.2.10.911
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

Was this helpful to you? 1
Reply
Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back soon.

Was this helpful to you? 0
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

Make sure that you have updated to Firefox 25.0.1
See Help > About

Was this helpful to you? 1
Reply

Question owner

That's what's posted and what I've done. No, that doesn't work.

Was this helpful to you?
Reply

Question owner

Already did that too.

Was this helpful to you?
Reply

Question owner

This is just the information on the web site. Tried all that multiple times. No it didn't work.

Was this helpful to you?
Reply
Wesley Branton
  • Top 25 Contributor
178 solutions 2062 answers

In order to be able to find the correct solution to your problem, we require some more non-personal information from you. Please do the following:

  • Click the Firefox button at the top left, then click the Help menu and select Troubleshooting Information from the submenu. If you don't have a Firefox button, click the Help menu at the top and select Troubleshooting Information from the menu.

Now, a new tab containing your troubleshooting information should open.

  • At the top of the page, you should see a button that says "Copy text to clipboard". Click it.
  • Now, go back to your forum post and click inside the reply box. Press Ctrl+V to paste all the information you copied into the forum post.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

Thanks in advance for your help!

Was this helpful to you?
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.


You can try out the current Firefox 26 beta to see if it still has this problem.

Do a custom install in a different program folder and use the Profile Manager to create a new profile for this version, so make sure not to start Firefox after the installation has finished.

Create a desktop shortcut with -P "profile" appended to the target to launch each Firefox version with its own profile.

See these mozillaZine KB articles for more information:

Was this helpful to you?
Reply
Fr15kyKa05 0 solutions 1 answers

I tried all of this, and I still cant get sound or anything from videos. And my facebook is laggy. I keep getting this popup.

Was this helpful to you?
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96758 answers

Try to disable hardware acceleration in Firefox (you need to close and restart Firefox).

You can check for problems with current Flash plugin versions and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)
  • disable hardware acceleration in the Flash plugin
Was this helpful to you? 0
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.