X
Tap here to go to the mobile version of the site.

Support Forum

How to install latest Firefox on CentOS or RHEL

Posted

I wanted to install latest version of FireFox on my CentOS box as it wont get updated of the latest version.

Step by step guidance is appreciated.

I wanted to install latest version of FireFox on my CentOS box as it wont get updated of the latest version. Step by step guidance is appreciated.

Additional System Details

Installed Plug-ins

  • nspluginwrapper is a cross-platform NPAPI plugin viewer, in particular for linux/i386 plugins.This beta software is available under the terms of the GNU General Public License.

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.18) Gecko/2010021718 CentOS/3.0.18-1.el5.centos Firefox/3.0.18

More Information

James
  • Top 25 Contributor
  • Moderator
699 solutions 5178 answers

Sorry but CentOS 5 is essentially outdated due to using packages that are from over years ago. The last version to perhaps work is Firefox 3.6.18 without doing dependency installs if possible like at http://warped.org/blog/2011/03/29/firefox4_redhat_5/

http://www.mozilla.com/en-US/firefox/all-older.html

This is the downside of using a LTS Linux distro as they choose to stay with old stable packages versus being more up to date.


http://www.mozilla.com/en-US/firefox/5.0/system-requirements/ http://www.mozilla.com/en-US/firefox/4.0/system-requirements/

Oh and Please do not comment in the bug 621704 bug mentioned in article as there is enough comment spam there already as bugzilla is not a forum or like a comment section of a blog.

Sorry but CentOS 5 is essentially outdated due to using packages that are from over years ago. The last version to perhaps work is Firefox 3.6.18 without doing dependency installs if possible like at http://warped.org/blog/2011/03/29/firefox4_redhat_5/ http://www.mozilla.com/en-US/firefox/all-older.html This is the downside of using a LTS Linux distro as they choose to stay with old stable packages versus being more up to date. http://www.mozilla.com/en-US/firefox/5.0/system-requirements/ http://www.mozilla.com/en-US/firefox/4.0/system-requirements/ Oh and Please do not comment in the bug 621704 bug mentioned in article as there is enough comment spam there already as bugzilla is not a forum or like a comment section of a blog.

Modified by James