X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

The proxy server is refusing connections

Posted

I am using FF 4.0.1 and have been a FF user since the earliest version released - never really had any issues UNTIL FF 4.0.1.

Every time I start up FF now, I get the error message: "The proxy server is refusing connections". I am not using a proxy server.

I have to go to Tools>Options>Connection Settings to select the "No Proxy" option EVERY TIME I start up FF. It does not remember this setting and keep resetting itself to think I'm using a proxy server. This must a be bug and I've seen many others post about this issue but haven't really found a workable solution as yet.

I have tested with Chrome and Explorer and don't have this problem with those browsers.

If there is a fix for this incredibly annoying, time-wasting problem, please share it.

Thanks

Chosen solution

Create a new profile as a test to check if your current profile is causing the problems.

See:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

Read this answer in context 1

Additional System Details

This happened

Every time Firefox opened

This started when...

Just after I installed FF 4.0.1.

Installed Plug-ins

  • Plug-in for Starfield utilities
  • Plug-in for Web-Based Email
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.709
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 10.3 r181
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60531.0
  • Virtual Earth 3D 4.00100226006 plugin for Mozilla

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Application Basics
Name
Firefox
Version
4.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
LastPass
1.73.0
true
support@lastpass.com
Firefox Sync
1.7
true
{340c2bbc-ce74-4362-90b5-7c26312808ef}
Download Statusbar
0.9.8
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
Torbutton
1.2.5
false
{e0204bd5-9d31-402b-a99d-a6aa8ffebdca}
WBE Paste
1.1
false
wbepaste@starfield
Starfield Zoom
1.1
false
zoomext@starfield
Java Console
6.0.17
true
{CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}
Java Console
6.0.19
true
{CAFEEFAC-0016-0000-0019-ABCDEFFEDCBA}
Java Console
6.0.20
true
{CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}
Java Console
6.0.21
true
{CAFEEFAC-0016-0000-0021-ABCDEFFEDCBA}
Java Console
6.0.22
true
{CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA}
Java Console
6.0.23
true
{CAFEEFAC-0016-0000-0023-ABCDEFFEDCBA}
Java Console
6.0.24
true
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
Screengrab
0.96.3
true
{02450954-cdd9-410f-b1da-db804e18c671}
Skype extension
5.3.0.7550
true
{82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}
Theme Font & Size Changer
1.2
true
{f69e22c7-bc50-414a-9269-0f5c344cd94c}
FoxyProxy Basic
2.0.1
true
foxyproxy-basic@eric.h.jung
Status-4-Evar
2011.04.06.18
true
status4evar@caligonstudios.com
PC Sync 2 Synchronisation Extension
1.0.0.723
false
bkmrksync@nokia.com
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/ig
browser.startup.homepage_override.buildID
20110413222027
browser.startup.homepage_override.mstone
rv:2.0.1
dom.max_script_run_time
1800
extensions.lastAppVersion
4.0.1
font.name.serif.x-western
Arial
font.size.fixed.x-western
14
font.size.variable.x-western
15
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1308237641
places.history.expiration.transient_current_max_pages
104642
places.last_vacuum
1297557193
print.print_printer
Samsung CLX-3170 Series
print.printer_Adobe_PDF.print_bgcolor
false
print.printer_Adobe_PDF.print_bgimages
false
print.printer_Adobe_PDF.print_command
print.printer_Adobe_PDF.print_downloadfonts
false
print.printer_Adobe_PDF.print_edge_bottom
0
print.printer_Adobe_PDF.print_edge_left
0
print.printer_Adobe_PDF.print_edge_right
0
print.printer_Adobe_PDF.print_edge_top
0
print.printer_Adobe_PDF.print_evenpages
true
print.printer_Adobe_PDF.print_footercenter
print.printer_Adobe_PDF.print_footerleft
&PT
print.printer_Adobe_PDF.print_footerright
&D
print.printer_Adobe_PDF.print_headercenter
print.printer_Adobe_PDF.print_headerleft
&T
print.printer_Adobe_PDF.print_headerright
&U
print.printer_Adobe_PDF.print_in_color
true
print.printer_Adobe_PDF.print_margin_bottom
0.5
print.printer_Adobe_PDF.print_margin_left
0.5
print.printer_Adobe_PDF.print_margin_right
0.5
print.printer_Adobe_PDF.print_margin_top
0.5
print.printer_Adobe_PDF.print_oddpages
true
print.printer_Adobe_PDF.print_orientation
0
print.printer_Adobe_PDF.print_page_delay
50
print.printer_Adobe_PDF.print_pagedelay
500
print.printer_Adobe_PDF.print_paper_data
1
print.printer_Adobe_PDF.print_paper_height
11.00
print.printer_Adobe_PDF.print_paper_size_type
0
print.printer_Adobe_PDF.print_paper_size_unit
0
print.printer_Adobe_PDF.print_paper_width
8.50
print.printer_Adobe_PDF.print_reversed
false
print.printer_Adobe_PDF.print_scaling
1.00
print.printer_Adobe_PDF.print_shrink_to_fit
true
print.printer_Adobe_PDF.print_to_file
false
print.printer_Adobe_PDF.print_unwriteable_margin_bottom
0
print.printer_Adobe_PDF.print_unwriteable_margin_left
0
print.printer_Adobe_PDF.print_unwriteable_margin_right
0
print.printer_Adobe_PDF.print_unwriteable_margin_top
0
print.printer_Samsung_CLX-3170_Series.print_bgcolor
false
print.printer_Samsung_CLX-3170_Series.print_bgimages
false
print.printer_Samsung_CLX-3170_Series.print_command
print.printer_Samsung_CLX-3170_Series.print_downloadfonts
false
print.printer_Samsung_CLX-3170_Series.print_edge_bottom
0
print.printer_Samsung_CLX-3170_Series.print_edge_left
0
print.printer_Samsung_CLX-3170_Series.print_edge_right
0
print.printer_Samsung_CLX-3170_Series.print_edge_top
0
print.printer_Samsung_CLX-3170_Series.print_evenpages
true
print.printer_Samsung_CLX-3170_Series.print_footercenter
print.printer_Samsung_CLX-3170_Series.print_footerleft
&PT
print.printer_Samsung_CLX-3170_Series.print_footerright
&D
print.printer_Samsung_CLX-3170_Series.print_headercenter
print.printer_Samsung_CLX-3170_Series.print_headerleft
&T
print.printer_Samsung_CLX-3170_Series.print_headerright
&U
print.printer_Samsung_CLX-3170_Series.print_in_color
true
print.printer_Samsung_CLX-3170_Series.print_margin_bottom
0.5
print.printer_Samsung_CLX-3170_Series.print_margin_left
0.5
print.printer_Samsung_CLX-3170_Series.print_margin_right
0.5
print.printer_Samsung_CLX-3170_Series.print_margin_top
0.5
print.printer_Samsung_CLX-3170_Series.print_oddpages
true
print.printer_Samsung_CLX-3170_Series.print_orientation
0
print.printer_Samsung_CLX-3170_Series.print_page_delay
50
print.printer_Samsung_CLX-3170_Series.print_pagedelay
500
print.printer_Samsung_CLX-3170_Series.print_paper_data
1
print.printer_Samsung_CLX-3170_Series.print_paper_height
11.00
print.printer_Samsung_CLX-3170_Series.print_paper_size_type
0
print.printer_Samsung_CLX-3170_Series.print_paper_size_unit
0
print.printer_Samsung_CLX-3170_Series.print_paper_width
8.50
print.printer_Samsung_CLX-3170_Series.print_reversed
false
print.printer_Samsung_CLX-3170_Series.print_scaling
1.00
print.printer_Samsung_CLX-3170_Series.print_shrink_to_fit
true
print.printer_Samsung_CLX-3170_Series.print_to_file
false
print.printer_Samsung_CLX-3170_Series.print_unwriteable_margin_bottom
0
print.printer_Samsung_CLX-3170_Series.print_unwriteable_margin_left
0
print.printer_Samsung_CLX-3170_Series.print_unwriteable_margin_right
0
print.printer_Samsung_CLX-3170_Series.print_unwriteable_margin_top
0
privacy.cpd.sessions
false
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 5800 Series
Vendor ID
1002
Device ID
689e
Adapter RAM
1024
Adapter Drivers
aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva
Driver Version
8.791.0.0
Driver Date
10-26-2010
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17563, font cache n/a)
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
GPU Accelerated Windows
1/1 Direct3D 10

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

See:

Helpful Reply

Thanks for the link.

My prefs.js file properties show it is not a read-only file, so that's not the issue; and the file is not corrupted since I can make and save other settings changes in FF that are 'remembered' when I next start up a new FF session. Its only the 'no proxy' setting that is not being saved.

But I went ahead and did the recommended procedure in the article anyways to test; that was to rename prefs.js to prefs.jsOLD and close/restart FF, but same problem. However I had about 8 tabs open and when FF restarted, I noticed that only my home page tab was displaying the "The proxy server is refusing connections" error message. That home page is my iGoogle page. The other tabs all loaded fine as they should have. This makes the problem even more strange.

Ultimately I still had to manually open Tools>Options>Connection Settings to select the "No Proxy" option to get my iGoogle home page to load properly.

Modified by bigdavemojo

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Question owner

I tried starting FF in Safe Mode as suggested, and the proxy issue/error message did not show up. iGoogle page (and other tabs) opened normally as they are supposed to.

When I restart FF normally without safe mode, the proxy warning message reappears.

I use the default theme by default, and I'm not sure which other add on I'm using would be causing this recurring proxy error problem.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

Helpful Reply

I have tried safe-mode again, disabling all extensions several times, but the problem is reoccurring. I'm getting "The proxy server is refusing connections" error message on my iGoogle home page and sometimes other tabs that are open, such as Yahoo. I am not using a proxy server and have fixed my settings in FF accordingly, but FF resets the settings every time I start a new FF session causing the error to occur again and again. I still have no idea why FF keep resetting the settings to 'with a proxy server'.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Chosen Solution

Create a new profile as a test to check if your current profile is causing the problems.

See:

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If that new profile works then you can transfer some files from the old profile to that new profile (be careful not to copy corrupted files)

See:

Question owner

Well that did it! I created a new profile, copied over my settings from my old profile, and FF starts with no more proxy error messages.

Problem solved completely.

Thanks so much....greatly appreciate your assistance with solving this issue.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

You're welcome

Question owner

Just a PS:

The problem has now re-occurred, 2 days after the profile change seemed to fix the problem.

Any further suggestions on fixes appreciated.

Thanks.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Did you try to delete the file prefs.js in the Firefox Profile Folder another time?

If you see other pref-##.js files then delete those as well

Do you have security or cleanup software that might corrupt that prefs.js file?

Question owner

I have deleted prefs.js file again; on restarting FF, this actually magnified the problem, since before, only my iGoogle home page tab would display the proxy error message; now all open tabs display this message.

The only security software running on this Win & PC is Microsoft Security Essentials.

I have tried disabling all add ins and still the problem occurs on FF start up every time. I have the same FF add ins and setup on my Thinkpad and it runs just fine - no incorrect proxy warning messages.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Did you try to change the connection setting to No proxy?

You can find the connection settings in Tools > Options > Advanced : Network : Connection


Did you try Save mode?

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Question owner

I have to change the connection setting to No proxy EVERY TIME I start a new FF session - that's the problem here. FF is not saving those settings. I have no proxy, but it thinks I do every time I have to start a new FF session. The only way to connect is manually go in and change the setting to No Proxy.

And yes I already did the safe mode start on default theme just as you described more than once - no solution there for me either.

Thanks for your suggestions.

I think I see Chrome in my future.