X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Disable Plugin Check

Posted

Is there anyway to disable the 'PluginCheck' website on firefox? It automatically opens up every time I open firefox. My home page also opens up as a separate tab so it's not the fact that my home page was changed (I also made sure in the settings). All my plugins are up to date so it's not that as well. It's extremely annoying. Help would greatly be appreciated.

https://www.mozilla.com/en-US/plugincheck/

Additional System Details

Sites Affected

https://www.mozilla.com/en-US/plugincheck/

Installed Plug-ins

  • Office Plugin for Netscape Navigator
  • np-mswmp
  • MetaStream 3 Plugin r4
  • 1.7.0069.3
  • NPTURNMED
  • BitTorrent Plugin 1
  • npdivxplayerplugin
  • 2.0.0048.0
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • Delivery Network Acceleration by BitTorrent™
  • DivX Web Player version 2.1.1.94
  • DivX VOD Helper Plug-in
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • 4.0.51204.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17 ( .NET4.0C)

More Information

mikeclark 3 solutions 35 answers

I uninstalled Viewpoint Media Player (and the AOL IM client "AIM", since apparently that's what forced Viewpoint Media Player on to my system.)

Viewpoint Media Player is responsible for the plugin called "MetaStream 3 Plugin r4", and I believe this plugin is triggering Firefox to open the plugincheck page. It is not enough to disable the plugin, it must be uninstalled.

For me, after uninstalling Viewpoint Media Player, the "plugincheck always opening" problem then went away.

If you do not have Viewpoint Media Player or the MetaStream plugin, then have a look at your Plugins list (Tools -> Add-ons -> Plugins). Do any of the plugins have a red warning icon next to them? My MetaStream plugin was the only Plugin with a red warning icon next to it, and that's how I decided it was the one I needed to remove. If any of your plugins have a red warning tag next to them, try uninstalling it or updating it. Doing so may stop the unwanted plugincheck tab from opening.

You are not the only person having this problem. Here are a few of the other people posting the same question:

Modified by mikeclark

FAUguy 0 solutions 10 answers

I've had this going on for 2 days now. I hope someone finds a way to turn it off!

Freethink 0 solutions 4 answers

It keeps telling me to update and install a plugin that I already have. I re-installed it but it still tells me I don't have it, and most ANNOYING of all, it installs McAfee security program. It's a good thing I have Revo Uninstaller to get rid of McAfee entirely. I might have to switch over to IE if this keeps up.

Modified by Freethink

Carlo Tafuro 0 solutions 2 answers

Try this:

  1. Open URL about:config
  2. in the filter box write: plugins.update
  3. then set: plugins.update.notifyUser = false
the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24387 answers

@carlo.tafuro

I think you get the cigar! That pref was set to false in all my Firefox installations (by default) and I switched it to true and now I get that Plugin Check page every time I open Firefox.

aaggag 0 solutions 1 answers

@carlo.tafuro

Nope, it's set to false and I get Check Plugins on start. Interestingly, if I try switching it to true and restarting Firefox, it's reverted to false again (still get the nag tab, though.)

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24387 answers

If you have the Quick Time plugin installed, try disabling it and then restart Firefox.

iamvictoria 0 solutions 4 answers

Helpful Reply

I have the same problem. I did notice though that people who are complaining about it (me included) have something in common. We are all using Firefox 3.6. Hmmm...is this their way of forcing us to switch to Firefox 4? Well, i don't have any plans of doing so anytime soon, especially that reviews are really bad

mikeclark 3 solutions 35 answers

I uninstalled Viewpoint Media Player. Viewpoint Media Player is responsible for the plugin called "MetaStream 3 Plugin r4", and I believe this plugin is triggering Firefox to open the plugincheck page. It is not enough to disable the plugin, it must be uninstalled.

For me, after uninstalling Viewpoint Media Player, the "plugincheck tab always opening" problem then went away.

Modified by mikeclark

Im_bonafide 0 solutions 2 answers

Helpful Reply

I did follow the steps, Open URL about:config, write: plugins.update, then I set: plugins.update.notifyUser = false. Except it was already User = false. So, I set it to User = true. When I reopened the browser it magically changed back to User = false. However, I continued to get that annoyance.

I went back into about:config > plugins.update > only this time on the line below plugins.update.notify, I (R) clicked plugins.update.url > modify > & deleted the url: https://www.mozilla.com/%LOCALE%/plugincheck/and replaced with my normal home page url.

No more annoyance.

Modified by Im_bonafide

Teddington 0 solutions 4 answers

Yes you can change the target address for 'plugins.update.url'

Change it from 'https://www.mozilla.com/%LOCALE%/plugincheck' to your homepage, or leave it blank etc..

This will not stop you getting a random unwanted tab opening - but at least you won't have to look at the page about updates anymore.

I have set it to Google search, while waiting for a proper solution, hopefully.

David Spalding 0 solutions 14 answers

Plugins.Update.Notifyuser doesn't seem to be a new setting, it's in my 3.6.15 FF at work, set to FALSE, but since updating from 3.6.16 to 3.6.17 at home, this suddenly started popping up in two separate profiles in the last week,set to TRUE. The plug-ins it's warning me about aren't new, so something must've flipped the setting on me. Hrmmmmm.

There's also a Extensions.Update.Notifyuser setting, default appears to be FALSE. I'm setting that to TRUE for farts 'n giggles to see what happens. But your answer is definitely the solution, resetting the value in config editor. Pity that so many users are subjected to this annoyware page unless they perform what is essentially a configuration change suitable for advanced uses only.

Firefox probably needs to amend the "plugins check" page with a button to "Turn off these checks" so users can opt out. In my case, the two plug-ins causing grief are Adobe Acrobat 7 (I'm still using Acrobat Standard 7, so I'm not downloading more recent version of the Reader), and Quicktime (a version which was installed either by Premiere Elements 2.0, or by a installer that provides the Apple mobile device support without installing all of iTunes) ... I'm certainly not installing all of Quicktime as it would break the Premiere Elements functionality on my systems. So Firefox has to bend on this, as helpful as it may seem.

[UPDATE] Corrrection, turning Plugins.update.NotifyUser to FALSE has not prevented the add'l tab from opening, only changing Plugins.Update.Url to null prevents the page (default value is https://www.mozilla.com/%LOCALE%/plugincheck/ ).

Modified by David Spalding

David Spalding 0 solutions 14 answers

Mike that only eradicates the problem for someone with that particular plug-in problem. Others are getting the page for different plug-ins. ;)

mikeclark 3 solutions 35 answers

David: I understand. However, 90% of the people posting a question to complain about the unwanted plugincheck tab, have had the "MetaStream 3 Plugin r4" plugin in their plugin list (click the "More System Details..." link on this or any other question, to see whether they do or not.) So mentioning it specifically should help a fair a mount of users.

I agree there should be a more general way to stop the plugincheck tab from automatically opening. I believe it is Firefox that is choosing to open the plugincheck tab, and so Mozilla should be able to tweak Firefox so that it does not do this uncontrollably.

Have a look at your Plugins list (Tools -> Add-ons -> Plugins). Do any of the plugins have a red warning icon next to them? My MetaStream plugin was the only Plugin with a red warning tag next to it, and that's how I decided it was the one I needed to remove. If any of yours have a red warning tag next to them, try uninstalling it or updating it. Doing so may get rid of the unwanted plugincheck tab.

Modified by mikeclark

FAUguy 0 solutions 10 answers

Thanks, that did the trick. Here's what I did.

1) Went into about:config and looked at the plugins.update.notifyUser listing and saw that it was already on False. I changed it to True and then back to False. Also, the URL that is below it, I deleted the URL.

2) Went into Windows Program Manager and uninstalled the Viewpoint Media Player.

3) Went back into FireFox and selected Tools and Addons and disabled the MetaStream 3 Plugin.

Restarted the PC, and now it's back to normal where it open opens one tab with the about:blank.

SirItGoBoomAlot 0 solutions 2 answers

I've gotten rid of all plugins that were in the red, I can't update the 2 in the yellow, and my boolean value is doing that stupid set to false but still coming up. Any actual mozilla reps on this?

David Spalding 0 solutions 14 answers

Yes, Mike, I see that for several posters the Viewpoint Media Player's Metastream plug-in was present and a culprit, but others (myself included) don't have that installed, never have. Those for whom Viewpoint is the problem, and the only problem, removing it is the solution. But any other plug-ins FF doesn't like, this page continues to come up.

I also don't have any plug-ins listed with a "red warning tag" on https://www.mozilla.com/%LOCALE%/plugincheck/ . The only non-green ones are Quicktime 7.1.5 and Acrobat 7.0 for Netscape, both marked "Outdated version" with sienna "Update" tags, and an Office 2003 with gray "unknown" tag. Even with all of the questionable plug-ins disabled, the plug-ins check page still comes up, every darned time. Even turning off the setting that supposedly controls it has no positive result. Very annoying, though Mozilla's contributors concern about security and stability is laudable.

Oddly enough, I have a plain profile with no bookmarks, no extensions, and the same plug-ins, and the first time I loaded it this evening, the plug-ins check page didn't come up. Then, with all subsequent loads, the page did come up, regardless of the state of Plugins.Update.NotifyUser. Cripes, this is a sour pickle to suck on!

mikeclark 3 solutions 35 answers

davidspalding,

The place I suggest to look for the "red tag" is not the plugincheck page itself. Rather, I suggest looking at the built-in Firefox list of installed plugins. In Firefox 3.6, this is accessed by going to Tools->Add-ons, and then clicking on the "Plugins" header.

It is this list that I believe determines whether the plugincheck tab will be opened automatically. Look through this list for a red-tagged plugin. That would be the culprit.

The reason I suggest looking at the Tools->Add-ons->Plugins list instead of the plugincheck list, is that status displayed in the Tools->Add-ons->Plugins list and the status on the plugincheck webpage, can disagree.

Quite frankly, the plugincheck webpage, and the Tools->Add-ons->Plugins list, seem to be using a different checking algorithm or data-source.

For example, in Tools->Add-ons->Plugins, my MetaStream plugin was flagged red, while it was definitely NOT flagged at all in the plugincheck page.

I believe that the Tools->Add-ons->Plugins list, and the status of the items in that list, is what determines whether the plugincheck tab will display. So really, it doesn't matter much what the plugincheck page tells you -- it's the status of items in Tools->Add-ons->Plugins that really matters -- at least with regards to whether the plugincheck tab will display or not.

Modified by mikeclark

TGDL 0 solutions 2 answers

I'm using Win XP and FF 3.6.13. I tried disabling all my plug-ins but this didn't seem to help. Removing Viewpoint Media Player (where did that come from?) with its metastream plugin, as suggested, didn't help either. HOWEVER subsequently up-grading Quicktime from v. 7.1.3 (which FF had actually disabled) to v. 7.6 seems to have solved it. Hope this helps others.

bobgldbrg 0 solutions 2 answers

mikeclark et al,

I, too, have this problem. The only "error" is see on the Plugin Check page is that is says the "Adobe PDF Plug-In For Firefox and Netscape 10.0.1" is an outdated version - but it is NOT.

I had already uninstalled the viewpoint media player (and the metastream 3 entry disappeared).

Also, my plugins.update.notifyuser setting under about:config was already set to "false."

And, my quicktime plugin is already 7.6.9.

I have no "red tag" items either on the Plugin Check page or the Mozilla "Add-ons" box.

I am going to try setting the plugins.update.url to null and see what happens.