X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

i cant get rid of this(http://www.searchqu.com/406) software did all i know how to do!

Posted

this software will not go away i deleted it and its still there. it over rides my setting. i have done everything but wipe the hd

Chosen solution

Searchqu gets installed if you don't opt-out of the installation when you install a 'free' app from bandoo.com which provides free emoticons.

If you have this app on your system now, uninstall it first, otherwise searchqu will reappear again after you complete the following steps.


To revert to Google as your preferred search engine, please do the following.

  1. In the location bar, type about:config and hit Enter.

  2. In the filter at the top, type: keyword.URL

  3. Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

  4. In the filter at the top again, copy/paste the following (remove keyword.URL first): browser.startup.homepage

  5. Right click it, choose Modify and then click Reset.

  6. Close the tab.

  7. Click the Firefox button, go to Add-ons, then Extensions and remove these add-ons if they're in there: Windows iLivid Toolbar , Searchqu Toolbar and Bandoo Media.

  8. Next, open Windows Explorer and navigate to C:\Program Files\Mozilla Firefox\searchplugins. In there, delete the following: SearchquWebSearch.xml

  9. Go to Add/Remove Programs and look for Windows iLivid Toolbar, Searchqu Toolbar and Bandoo Media again. Remove if found. You might possibly find a reference to "Web Search" (searchqu) in Add/Remove Programs too. If so, remove it.

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Go to Tools | Options | General

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.


N.B. You may also need to unregister searchqudtx.dll using regsvr32 /u searchqudtx.dll

Read this answer in context 173

Additional System Details

This happened

Every time Firefox opened

This started when...

2/3 days ago

Installed Plug-ins

  • np-mswmp
  • npdnu
  • npdnupdater2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • ClickPotatoLite Firefox Plugin
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.4"
  • 12.0.1.647
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • DivX Web Player version 2.1.1.94
  • DivX VOD Helper Plug-in
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Xircal 334 solutions 3835 answers

Chosen Solution

Searchqu gets installed if you don't opt-out of the installation when you install a 'free' app from bandoo.com which provides free emoticons.

If you have this app on your system now, uninstall it first, otherwise searchqu will reappear again after you complete the following steps.


To revert to Google as your preferred search engine, please do the following.

  1. In the location bar, type about:config and hit Enter.

  2. In the filter at the top, type: keyword.URL

  3. Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

  4. In the filter at the top again, copy/paste the following (remove keyword.URL first): browser.startup.homepage

  5. Right click it, choose Modify and then click Reset.

  6. Close the tab.

  7. Click the Firefox button, go to Add-ons, then Extensions and remove these add-ons if they're in there: Windows iLivid Toolbar , Searchqu Toolbar and Bandoo Media.

  8. Next, open Windows Explorer and navigate to C:\Program Files\Mozilla Firefox\searchplugins. In there, delete the following: SearchquWebSearch.xml

  9. Go to Add/Remove Programs and look for Windows iLivid Toolbar, Searchqu Toolbar and Bandoo Media again. Remove if found. You might possibly find a reference to "Web Search" (searchqu) in Add/Remove Programs too. If so, remove it.

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Go to Tools | Options | General

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.


N.B. You may also need to unregister searchqudtx.dll using regsvr32 /u searchqudtx.dll

Modified by Xircal

geetz 0 solutions 1 answers

Helpful Reply

thank u.....it really helped..

andrewk 0 solutions 2 answers

Brilliant! After a few days of trying different fixes, this lot finally worked. I think it was the modiications in the location bar and removal of the folder that completed it. You have to do every step in this solution.

lloydletta 0 solutions 1 answers

I'm getting an error when trying to unregister the dll.

gnyderek 0 solutions 1 answers

I made it to #7, but did not find in the add-on extensions any of the things listed to be removed- what should i do?

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

See also these threads about searchqu:

Brenadian 0 solutions 1 answers

I did all the above but when I open firefox I get this error:

TypeError: Components.classes[cid_siterank] is undefined

If I click ok or close that message firefox then opens as normal. What does this message mean?

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

@Brenadian

TypeError: Components.classes[cid_siterank] is undefined

That issue is caused by an extension that isn't working properly.
The name siterank in the error message should give you a clue.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

rayg 0 solutions 1 answers

Many many thanks for your help......this solution works! I have been searching the web for days trying one claimed solution after another with no success. It took me a couple of tries with this one and finally Firefox is rid of searchqu. Suggestion to others with this problem, double check the Add/Remove Programs as it is easy to miss one of the programs mention in 9.

motmuis 0 solutions 1 answers

Go to control panel to software and remove iLivid toolbar afterwards you can chance your home in firefox extra

Ginaellen 0 solutions 1 answers

Thank you so much. This worked perfectly.

Drotn 0 solutions 1 answers

I made it to #7; now I'm stuck on #8. How do I navigate to C:\Program Files\Mozilla Firefox\searchplugins on IE?

ZZANNH 0 solutions 2 answers

ON ANY BROWSER GO TO TOOLS!!! CLICK OPTIONS!! CLICK RESTORE HOME PAGE ON DEFAULTS! CLICK OK!!! LIKE MAGIC!!! AS ONE TWO!!!! ..http://www.searchqu.com/406 IT WILL BE GONE!!!!:):):):)

ishack33 0 solutions 1 answers

You definitely nailed it - well done and thanks. This was a particularily tough one to crack

olderandwiser 0 solutions 1 answers

The searchqu site is in Israel. The referring software that hijacks Firefox is made by someone called iLivid, and it is pernicious! They are scum, and disingenuous. If you go to their site to get info on how to remove their 'toolbar,' the so-called solution is a link to the Mozilla site on how to change your home page. It doesn't work though, because the iLivid software prevents any changes.

I used WinPatrol to remove it, and found that I had to remove 2 startup programs, 2 dlls, and 2 registry entries. Here's how to do it if you don't want to do 'brain surgery' on your system yourself.

1. Download the free version of WinPatrol and install it. 2. Reboot your system and go to the Start menu. Type in WinPatrol. 3. Click on the Startup tab in WinPatrol. WinPatrol will scan your system for all startup files and ask you to confirm if you want them. You should probably say 'yes' to most that you know are safe or recognize. 4. When you find a startup file by iLivid or searchqu, click on 'No.' There will be 2 of these files. 5. Next, WinPatrol will find 2 dll files by iLivid or searchqu. Click 'No' to both to get rid of them. 6. Finally, WinPatrol will find 2 registry entries. Again, click 'No' to get rid of them. It will warn you that they are in the System part of the registry, and ask if you really want to delete them? Click 'Yes,' because you really want to get rid of it. 7. You are now clean. Go into Firefox and reset your home page via Options on the Tools menu. 8. If you have been successful, show your appreciation to the WinPatrol developer. (I am in no way related!)

Brian_J 0 solutions 1 answers

Method worked, but on Vista there were some differences to the description. Seems to have though. Many thanks

roxi247 0 solutions 2 answers

I tried sooo many things, and nothing worked. This simple solution has worked for me. Go to the options tab in Mozilla and make google your homepage. When you try to get rid of searchqu a tab comes up in the right bottom corner of the browser for a few seconds saying something about the fact that a program wants to take over your search engine and searchqu is blocking it.

Quick before the tab disappears, click the link on the tab. (if you miss the link and tab the first time you try, close your browser and try to change your options tab to google as your homepage again). After you click the link, another tab opens up giving you the choice of changing to the search engine you picked. Click your choice and presto, when I opened up my browser again, searchqu was gone. Yeah!!!!! Reply

oldsalt04101 0 solutions 4 answers

I read a few of the entries from the searchqu support team saying it's a simple matter to get rid of searchqu: Just go to the control panel, find Windowssearchqu and uninstall it. The only problem is the support team is simply spreading more horse manure. I've uninstalled all traces of ilivid and bandoo.media, but when I search for searchqu, it somehow manages to hide. It's nowhere in my control panel. But it is very evident when I try to find my home page or try browsing. Then all I'm able to see on my screen is searchqu.com. The people who are behind searchqu should be put in jail -- or worse.

Kimita 0 solutions 1 answers

Thank you Xircal! Your steps worked a charm after trying simpler fixes. I appreciate you taking the time and detail to lay it out so clearly. Cheers!

SgtBaggins 1 solutions 2 answers

Thanks so much for this. I was able to disable the files in the add on, but things kept coming back. This procedure helped me get rid of everything to stop it.