Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox sometimes loses all my previous tabs even though I have configured it to restore them and it also loses my preferred search engine (google) in favour of babylon

  • 3 replies
  • 539 have this problem
  • 7 views
  • Last reply by Xircal

more options

I like to have a number of tabs open each time I use Firefox and have configured it accordingly. I have also configured the toolbar to use Google.

From time to time Firefox terminates abnormally (e.g. if the PC crashes) and then I lose all my tabs plus the toolbar has an extra line to use babylon search.

Is it possible for me to save information about all of my tabs in a backup file of my choosing so that I can restore the settings manually? What file does it have to be copied into to restore?

The babylon problem is less pressing as it is easy to lose that line - but it is still annoying.

All Replies (3)

more options

Please do the following.

  1. Go to Tools | Add-ons | Extensions and remove Babylon toolbar, or any other reference to babylon.
  2. In the location bar, type about:config and hit Enter.

  3. In the filter at the top, type: keyword.URL

  4. Double click it and remove http://search.babylon.com/?babsrc=HP_ss& (the url to babylon is longer than this actually, but I think this will suffice to explain what you should be looking for) and replace it with http://www.google.com/search?q=

The google URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.

  1. Go to the site you want to set as your homepage.

  2. Go to Tools | Options | General.

  3. Make sure it says "Show My Homepage" in the first dropdown menu.

  4. Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

After you complete the above steps, install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/

more options

Thanks for that, Xircal. I've done all that you suggested except I've not yet re-built all my tabs. Of course, I'll not have total confirmation of success until next time the PC crashes - which may not be too long!!

John

more options

Hi John,

You have a number of outdated Java Consoles installed which also expose your system to exploits. Go to Tools | Add-ons | Extensions and remove all of them up to 1.6.0_25 (keep that one).

Also a visit to the Plugins Check page might be in order to ensure nothing else is out of date.