X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to Remove the Babylon homepage from Firefox

Posted

Hi, I am having the worst time trying to remove Babylon homepage from Firefox, this is what I've already tried:

- Disable and Remove Babylon add on - Uninstall Babylon toolbar from Control Panel - Remove Babylon search engine from Manage Search Engines - Reset all lines that contain something about Babylon on about:config page - Change homepage from Tools > Options > General tab - Clean all registry keys, values and data with Babylon in it - Reset all registry keys to their default values - Uninstalling Mozilla Firefox - Deleting every file about Babylon - Reinstalling Mozilla Firefox - Resetting Firefox to factory defaults from about:support page - Resetting Firefox from Help > Restart with Add ons Disabled... - I have even tried to restore my system to a point before it started happening.

I have already read every forum in mozilla support, but nothing seems to work, I just can't get rid of it and it is absolutely annoying. There is nothing in babylon web page that has helped me.

Do you have any other ideas to remove completely this annoying issue?

Chosen solution

I had this problem as well. It's necessary to remove the 'browser manager'.

Check this page: http://www.explosiveknowledge.net/main/2012/08/19/browsemngr/

Just remove the subkey "Browser Manager" from this registery folders:

HKEY_LOCAL_MACHINE\SOFTWARE\ HKEY_CURRENT_USER\SOFTWARE\

and the entry "{b64982b1-d112-42b5-b1e4-d3867c4533f8}" in HKEY_CURRENT_USER\SOFTWARE\Mozilla\Firefox\Extensions\

I'm still looking how to delete the folder C:\ProgramData\Browser Manager..

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • Google Update
  • GEPlugin
  • 5.1.10411.0
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • McAfee MSC FF plugin DLL
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • SiteAdvisor
  • McAfee Virtual Technician plugin for Mozilla (Gecko Version: 1.8b1)
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Application Basics
Name
Firefox
Version
14.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Browser Manager
2.2.565.25
false
{b64982b1-d112-42b5-b1e4-d3867c4533f8}
General Crawler
2.0
false
gencrawler@some.com
McAfee ScriptScan for Firefox
14.4.1
false
{D19CA586-DD6C-4a0a-96F8-14644F340D60}
McAfee SiteAdvisor
3.4.1.195
false
{4ED1F68A-5463-4931-9384-8FFF5ED91D92}
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
4
browser.startup.homepage
about:home
browser.startup.homepage_override.buildID
20120713134347
browser.startup.homepage_override.mstone
14.0.1
extensions.lastAppVersion
14.0.1
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
104858
privacy.sanitize.migrateFx3Prefs
true
Graphics
Adapter Description
Intel(R) HD Graphics Family
Vendor ID
0x8086
Device ID
0x0116
Adapter RAM
Unknown
Adapter Drivers
igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
Driver Version
8.15.10.2253
Driver Date
11-28-2010
Adapter Description (GPU #2)
NVIDIA GeForce GT 525M
Vendor ID (GPU #2)
0x10de
Device ID (GPU #2)
0x0df5
Adapter RAM (GPU #2)
1024
Adapter Drivers (GPU #2)
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version (GPU #2)
8.17.12.6594
Driver Date (GPU #2)
11-29-2010
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Blocked for your graphics card because of unresolved driver issues.
GPU Accelerated Windows
1/1 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
1
Library Versions
Expected minimum version
Version in use
NSPR
4.9
4.9
NSS
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC
NSS Util
3.13.5.0
3.13.5.0
NSS SSL
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC
NSS S/MIME
3.13.5.0 Basic ECC
3.13.5.0 Basic ECC

jscher2000
  • Top 10 Contributor
2366 solutions 20922 answers

Where does Bablyon still appear?

  • Hijacks built-in home page (about:home) search box
  • Replaces home page with its own URL
  • In a new tab (instead of the thumbnails or your preferred page)

Question owner

It appears when I open Firefox. After changing the homepage to my default or some other page, I close Firefox and open it again, and there it comes again, some babylon search engine that I have already uninstalled and "cleaned" from my system. It also happened when opening a new tab, but that's already taken care of, my biggest problem is with my Firefox homepage.

Thanks for your reply.

jscher2000
  • Top 10 Contributor
2366 solutions 20922 answers

There are a couple of ways to override your settings changes. You could check for a user.js file here:

Help > Troubleshooting Information > Show Folder

This is your active Firefox personal settings folder (AKA your profile folder). If you find a file named user.js, you could rename it (e.g., user-old.js). This should prevent the contents of user.js from changing your preferences at your next startup.

smo 45 solutions 498 answers

If there is a problem with the build-in about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

   http://kb.mozillazine.org/about:config 
   Open the about:config page via the location bar
   Type in the Filter bar: mstone
   Right-click the browser.startup.homepage_override.mstone line and select: Reset
   Close and restart Firefox 

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

See these pages about Babylon Toolbar:

   http://support.babylon.com/index.php?/Knowledgebase/List/Index/48/english-faq
   http://support.babylon.com/index.php?/Knowledgebase/List/Index/37/installation--technical-support 
   /questions/746530 How do I fully remove Babylon

Question owner

Hi jscher2000, smo: I have already tried everything you suggested, but anything seems to solve it. Deleted the user.js file, but couldn't find the *_override.mstone entry. Perhaps I'm still missing something, when this babylon crap started happening, I first uninstalled it without disabling or removing the add-on from Firefox, so I reinstalled the babylon toolbar, disabled the add-on, removed it and then uninstalled it again, then cleaned all registry data referring to babylon, reset every Babylon entry in the about:config page, but it still comes out as my homepage every time I open Firefox. I even tried to change the search engine, but it comes back again with babylon. I think I'm giving up on this, I have no idea what else to do and it's very frustrating. If I find something else, I will tell.

Thanks

jscher2000
  • Top 10 Contributor
2366 solutions 20922 answers

If you notice that settings changes revert after a restart and there is no explanation, another possibility is a corrupted settings file. Please see this article: How to fix preferences that won't save.

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6639 answers

Make sure that you have uninstalled all Babylon related programs from your control Panel. this includes Babylon, Browser Protection, etc.

You can try some of the following programs to scan for malware:

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

q8marronglace 0 solutions 6 answers

Helpful Reply

SOLVED :)

Check this Vid  :

http://www.youtube.com/watch?v=GUQC7dSVft0

How To Remove babylon Toolbar From Firefox :

http://www.hthints.com/2012/08/how-to-remove-babylon-toolbar-from.html

Thanks a lot

Modified by q8marronglace

hedu 1 solutions 1 answers

Chosen Solution

I had this problem as well. It's necessary to remove the 'browser manager'.

Check this page: http://www.explosiveknowledge.net/main/2012/08/19/browsemngr/

Just remove the subkey "Browser Manager" from this registery folders:

HKEY_LOCAL_MACHINE\SOFTWARE\ HKEY_CURRENT_USER\SOFTWARE\

and the entry "{b64982b1-d112-42b5-b1e4-d3867c4533f8}" in HKEY_CURRENT_USER\SOFTWARE\Mozilla\Firefox\Extensions\

I'm still looking how to delete the folder C:\ProgramData\Browser Manager..

Question owner

Thanks to everyone, I didn't remove the Browser Manager before since I thought it was a built in software for every browser. Also deleted the registry and now homepage is not overriden by that annoying babylon thing. Thanks again.

shaneo 0 solutions 1 answers

OK so this question has been asked many times yet noone gets the right answer. So here it is.

1. Dont worry about playing with registras you might delete something you shouldn't. revo uninstaller takes 2 secs to download and makes no mistakes.

2. download revo uninstaller it will show a list of your programs, delete the ones to do with babylon. It will then give you the option to delete anything else attached to these programs, click ok and when it brings up a list you need to select everything in bold writing. then press delete. this will clear everything from your computer. (this is the biggest problem gone)

3. Now you have to deal with firefox.

4. click the arrow button beside the search box on the top right of your screen, then select manage search options. select babylon if it is there and delete it.

5. select firefox top left (presumably) of your screen, then select add-ons, then select extensions, delete babylon and anything unusual.

6. type about:config into your search bar where it usually displays the webite you are visiting (www.blahblah.com) for example. press enter. when it gives you a warning press ok and continue.

7. type babylon in the seach at top of screen in "about:config" right click everything in bold letters and then click reset.

8.now search "homepage" and double click "browser.startup.homepage" and change to www.google.com or whatever your preference is.

9. now search 'new tab" and doubleclick "browser.newtab.url" and change to www.google.com or whatever. This is for what you want to open when you open a new tab.

note: you can reset your homepage and your new tab if you want it to go back to default.

10. go to firefox at topleft of your screen and select options then select general beside where it says "when firefox starts" select show my homepage and change the address box what you want the homepage to be eg www.google.com.

If that doesn't get it. then you will have to pay someone. this worked for me and I had babylon riddled through my computer. Babylon = pathetic team of human being. get a real job you bunch of dicks!