X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When using google.com, the back button doesn't take me to where I was in my search results

Posted

This happened in 3.x and still occurs in 4.x

When I search for something on google.com and say scroll down towards the bottom of the search results - and click on a link - it takes me to the resulting site just fine. But when I click on the back button it will only take me back to the *top of the google search page* and I have to scroll all the way down the list to find where I left the results to go to page I came back from.

This is absolutely maddening.

I've tried restarting FF in safe mood to see if it still occurs and it does so I'm thinking it's not an add in or extension.

I've also seen refs to a problem with the Mcaffee site advisor breaking the back button but this is not the same issue. My back button works, it just doesn't take me back to google.com where I left it, so I have to scroll all the way down and check which links are purple to find where I left off. Crazy.

Note that this does NOT happen on other sites, only google.com which I happen to live in all day long with my work.

If anyone can help with this I'd sure appreciate it.

Thank you!

Additional System Details

Sites Affected

http://www.google.com

Installed Plug-ins

  • LogMeIn, Inc. Rescue Console
  • Office Plugin for Netscape Navigator
  • np-mswmp
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.4"
  • Provides additional functionality on Facebook. See our web site for details.
  • Shockwave Flash 10.1 r102
  • iTunes Detector Plug-in
  • CANON iMAGE GATEWAY Mycamera Plugin
  • GEPlugin
  • Picasa plugin
  • Next Generation Java Plug-in 1.6.0_23 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • Windows Activation Technologies Plugin for Mozilla
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

More Information

Application Basics
Name
Firefox
Version
4.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Add to Amazon Wish List Button
1.5
true
amznUWL2@amazon.com
Click&Clean
3.6.5.0
true
clickclean@hotcleaner.com
Conduit Engine
3.3.3.2
true
engine@conduit.com
LogMeIn, Inc. Remote Access Plugin
1.0.0.608
false
LogMeInClient@logmein.com
LogMeIn, Inc. Rescue Technician Console
6.3.0.984
true
TechnicianConsole@logmeinrescue.com
Speed Dial
0.9.5.8
true
{64161300-e22b-11db-8314-0800200c9a66}
uTorrentBar Community Toolbar
3.3.3.2
true
{bf7380fa-e3b4-4db2-af3e-9d8783a45bfc}
Adblock Plus
1.3.7
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Tab Mix Plus
0.3.8.6
true
{dc572301-7619-498c-a57d-39143191b318}
OpenDownload
1.0.0
false
{F0B6E3F9-ECD1-40b6-A25F-5C3FF68FB079}
Kaspersky URL Advisor
11.0.2.556
false
linkfilter@kaspersky.ru
Skype extension
5.0.0.6778
false
{AB2CE124-6272-4b12-94A9-7303C7397BD1}
Java Console
6.0.20
true
{CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}
Java Console
6.0.21
true
{CAFEEFAC-0016-0000-0021-ABCDEFFEDCBA}
Java Console
6.0.22
true
{CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA}
Java Console
6.0.23
true
{CAFEEFAC-0016-0000-0023-ABCDEFFEDCBA}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.drudgereport.com/
browser.startup.homepage_override.buildID
20110413222027
browser.startup.homepage_override.mstone
rv:2.0.1
browser.tabs.warnOnClose
false
extensions.lastAppVersion
4.0.1
keyword.URL
http://search.icq.com/search/afe_results.php?ch_id=afex&tb_ver=1.1.7&q=
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
108670
places.last_vacuum
1304431313
print.print_printer
Dell Color Laser 3110cn PCL6
print.printer_Adobe_PDF.print_bgcolor
false
print.printer_Adobe_PDF.print_bgimages
false
print.printer_Adobe_PDF.print_command
print.printer_Adobe_PDF.print_downloadfonts
false
print.printer_Adobe_PDF.print_edge_bottom
0
print.printer_Adobe_PDF.print_edge_left
0
print.printer_Adobe_PDF.print_edge_right
0
print.printer_Adobe_PDF.print_edge_top
0
print.printer_Adobe_PDF.print_evenpages
true
print.printer_Adobe_PDF.print_footercenter
print.printer_Adobe_PDF.print_footerleft
&PT
print.printer_Adobe_PDF.print_footerright
&D
print.printer_Adobe_PDF.print_headercenter
print.printer_Adobe_PDF.print_headerleft
print.printer_Adobe_PDF.print_headerright
print.printer_Adobe_PDF.print_in_color
true
print.printer_Adobe_PDF.print_margin_bottom
0.5
print.printer_Adobe_PDF.print_margin_left
0.5
print.printer_Adobe_PDF.print_margin_right
0.5
print.printer_Adobe_PDF.print_margin_top
0.5
print.printer_Adobe_PDF.print_oddpages
true
print.printer_Adobe_PDF.print_orientation
1
print.printer_Adobe_PDF.print_pagedelay
500
print.printer_Adobe_PDF.print_paper_data
1
print.printer_Adobe_PDF.print_paper_height
11.00
print.printer_Adobe_PDF.print_paper_size_type
0
print.printer_Adobe_PDF.print_paper_size_unit
0
print.printer_Adobe_PDF.print_paper_width
8.50
print.printer_Adobe_PDF.print_reversed
false
print.printer_Adobe_PDF.print_scaling
1.00
print.printer_Adobe_PDF.print_shrink_to_fit
true
print.printer_Adobe_PDF.print_to_file
false
print.printer_Adobe_PDF.print_unwriteable_margin_bottom
0
print.printer_Adobe_PDF.print_unwriteable_margin_left
0
print.printer_Adobe_PDF.print_unwriteable_margin_right
0
print.printer_Adobe_PDF.print_unwriteable_margin_top
0
print.printer_Dell_Color_Laser_3110cn_PCL6.print_bgcolor
false
print.printer_Dell_Color_Laser_3110cn_PCL6.print_bgimages
false
print.printer_Dell_Color_Laser_3110cn_PCL6.print_command
print.printer_Dell_Color_Laser_3110cn_PCL6.print_downloadfonts
false
print.printer_Dell_Color_Laser_3110cn_PCL6.print_edge_bottom
0
print.printer_Dell_Color_Laser_3110cn_PCL6.print_edge_left
0
print.printer_Dell_Color_Laser_3110cn_PCL6.print_edge_right
0
print.printer_Dell_Color_Laser_3110cn_PCL6.print_edge_top
0
print.printer_Dell_Color_Laser_3110cn_PCL6.print_evenpages
true
print.printer_Dell_Color_Laser_3110cn_PCL6.print_footercenter
print.printer_Dell_Color_Laser_3110cn_PCL6.print_footerleft
&PT
print.printer_Dell_Color_Laser_3110cn_PCL6.print_footerright
&D
print.printer_Dell_Color_Laser_3110cn_PCL6.print_headercenter
print.printer_Dell_Color_Laser_3110cn_PCL6.print_headerleft
print.printer_Dell_Color_Laser_3110cn_PCL6.print_headerright
print.printer_Dell_Color_Laser_3110cn_PCL6.print_in_color
true
print.printer_Dell_Color_Laser_3110cn_PCL6.print_margin_bottom
0.5
print.printer_Dell_Color_Laser_3110cn_PCL6.print_margin_left
0.5
print.printer_Dell_Color_Laser_3110cn_PCL6.print_margin_right
0.5
print.printer_Dell_Color_Laser_3110cn_PCL6.print_margin_top
0.5
print.printer_Dell_Color_Laser_3110cn_PCL6.print_oddpages
true
print.printer_Dell_Color_Laser_3110cn_PCL6.print_orientation
1
print.printer_Dell_Color_Laser_3110cn_PCL6.print_pagedelay
500
print.printer_Dell_Color_Laser_3110cn_PCL6.print_paper_data
1
print.printer_Dell_Color_Laser_3110cn_PCL6.print_paper_height
11.00
print.printer_Dell_Color_Laser_3110cn_PCL6.print_paper_size_type
0
print.printer_Dell_Color_Laser_3110cn_PCL6.print_paper_size_unit
0
print.printer_Dell_Color_Laser_3110cn_PCL6.print_paper_width
8.50
print.printer_Dell_Color_Laser_3110cn_PCL6.print_reversed
false
print.printer_Dell_Color_Laser_3110cn_PCL6.print_scaling
1.00
print.printer_Dell_Color_Laser_3110cn_PCL6.print_shrink_to_fit
true
print.printer_Dell_Color_Laser_3110cn_PCL6.print_to_file
false
print.printer_Dell_Color_Laser_3110cn_PCL6.print_unwriteable_margin_bottom
0
print.printer_Dell_Color_Laser_3110cn_PCL6.print_unwriteable_margin_left
0
print.printer_Dell_Color_Laser_3110cn_PCL6.print_unwriteable_margin_right
0
print.printer_Dell_Color_Laser_3110cn_PCL6.print_unwriteable_margin_top
0
print.printer_Epson_Stylus_Photo_RX620_(M).print_bgcolor
false
print.printer_Epson_Stylus_Photo_RX620_(M).print_bgimages
false
print.printer_Epson_Stylus_Photo_RX620_(M).print_command
print.printer_Epson_Stylus_Photo_RX620_(M).print_downloadfonts
false
print.printer_Epson_Stylus_Photo_RX620_(M).print_edge_bottom
0
print.printer_Epson_Stylus_Photo_RX620_(M).print_edge_left
0
print.printer_Epson_Stylus_Photo_RX620_(M).print_edge_right
0
print.printer_Epson_Stylus_Photo_RX620_(M).print_edge_top
0
print.printer_Epson_Stylus_Photo_RX620_(M).print_evenpages
true
print.printer_Epson_Stylus_Photo_RX620_(M).print_footercenter
print.printer_Epson_Stylus_Photo_RX620_(M).print_footerleft
&PT
print.printer_Epson_Stylus_Photo_RX620_(M).print_footerright
&D
print.printer_Epson_Stylus_Photo_RX620_(M).print_headercenter
print.printer_Epson_Stylus_Photo_RX620_(M).print_headerleft
print.printer_Epson_Stylus_Photo_RX620_(M).print_headerright
print.printer_Epson_Stylus_Photo_RX620_(M).print_in_color
true
print.printer_Epson_Stylus_Photo_RX620_(M).print_margin_bottom
0.5
print.printer_Epson_Stylus_Photo_RX620_(M).print_margin_left
0.5
print.printer_Epson_Stylus_Photo_RX620_(M).print_margin_right
0.5
print.printer_Epson_Stylus_Photo_RX620_(M).print_margin_top
0.5
print.printer_Epson_Stylus_Photo_RX620_(M).print_oddpages
true
print.printer_Epson_Stylus_Photo_RX620_(M).print_orientation
1
print.printer_Epson_Stylus_Photo_RX620_(M).print_pagedelay
500
print.printer_Epson_Stylus_Photo_RX620_(M).print_paper_data
1
print.printer_Epson_Stylus_Photo_RX620_(M).print_paper_height
11.00
print.printer_Epson_Stylus_Photo_RX620_(M).print_paper_size_type
0
print.printer_Epson_Stylus_Photo_RX620_(M).print_paper_size_unit
0
print.printer_Epson_Stylus_Photo_RX620_(M).print_paper_width
8.50
print.printer_Epson_Stylus_Photo_RX620_(M).print_reversed
false
print.printer_Epson_Stylus_Photo_RX620_(M).print_scaling
1.00
print.printer_Epson_Stylus_Photo_RX620_(M).print_shrink_to_fit
true
print.printer_Epson_Stylus_Photo_RX620_(M).print_to_file
false
print.printer_Epson_Stylus_Photo_RX620_(M).print_unwriteable_margin_bottom
0
print.printer_Epson_Stylus_Photo_RX620_(M).print_unwriteable_margin_left
0
print.printer_Epson_Stylus_Photo_RX620_(M).print_unwriteable_margin_right
0
print.printer_Epson_Stylus_Photo_RX620_(M).print_unwriteable_margin_top
0
privacy.cpd.extensions-tabmix
true
privacy.cpd.siteSettings
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce 6150SE nForce 430
Vendor ID
10de
Device ID
03d0
Adapter RAM
128
Adapter Drivers
nvd3dum
Driver Version
8.17.12.6099
Driver Date
10-16-2010
Direct2D Enabled
false
DirectWrite Enabled
false (6.1.7600.16763, font cache n/a)
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
GPU Accelerated Windows
0/1

Xircal 334 solutions 3835 answers

Right click the Back / Forward buttons to get a list of sites visited.

You can also install this add-on: https://addons.mozilla.org/en-US/firefox/addon/backforward-dropmarker/

Question owner

Thank you, but right clicking on back simply takes me back to page at the top of the list, it doesn't solve the problem. Appreciate the response, however.

Xircal 334 solutions 3835 answers

Hold down ALT while you press the left arrow key. It should take you to the same spot where you were when you clicked the link.

If it doesn't work, try running Firefox in Troubleshoot Firefox issues using Safe Mode. If it functions properly in that configuration, then one of your add-ons is the culprit.


Incidentally, you need to update to the latest version of Adobe Flash via http://get.adobe.com/flashplayer/

See this Adobe security advisory: http://www.adobe.com/support/security/advisories/apsa11-02.html

Question owner

Using ALT and back doesn't work. Still takes me to the top of the page. Also, I mentioned in my original post that the problem exists when running in safe mode.

Thanks, Xircal - I very much appreciate you trying to help and also the pointer on the Adobe Flash issue.

Question owner

Rather then creating a new profile I just tested this on an entirely different computer (a netbook with FF 3.x). The problem is there as well. These profiles share no information whatsoever. Strange. I can't be the only person that is being slowly insane by this ;)

Thanks again Xircal - you are a gentleman and a scholar for trying to help me!

Xircal 334 solutions 3835 answers

Please go to the Add-ons manager, then Plugins and disable Kapersky URL Advisor. Then try again. You can re-enable it if it doesn't make any difference.

While you're in there, please disable all the Java Consoles prior to the latest version which is 1.6.0_25. Older plugins are a security risk, though probably not the cause of your current problem.

Question owner

Kaspersky is listed as an extension, not a plugin. Already disabled. No joy. :(

Jave consoles removed - thanks for that tip. :)

Xircal 334 solutions 3835 answers

Sorry, I meant Extensions.

But I notice what I think might be the culprit in the form of your Skype installation. The version you have installed at the moment which is 5.0.0.6778 is on Mozilla's Blocklist: https://www.mozilla.com/en-US/blocklist/ (7th from the top).

Could you try updating that and see what happens?

Question owner

The Skype plugin is already disabled. Question: Do you have this problem?

Xircal 334 solutions 3835 answers

No, that's why I've suggested doing the above. When I use ALT+left arrow, it takes me back to where I left off.

Same goes for right clicking the back button and selecting from the list. Or using Backspace even.

Perhaps what might be a good idea is to download the free version of Malwarebytes from http://www.malwarebytes.org/products/malwarebytes_free and run a full system scan to eliminate malware as the culprit as is often the case.

Question owner

No malware detected but I didn't think this was the case as the problem appears on two different machines I use.

Well, I'm at a loss. Short of removing each and every addin or plugin I'm using I don't know what else to try, save creating a VM and testing an install in that. Lotta work just to fix a browser problem like this. Interestingly, this is the same reason I went away from FF many years ago to go to Opera. But Opera has (had) its issues as well. Anyway, I thank you again, Xircal for all your help to try and isolate this problem. If you've got any other ideas, I am happy to hear them. Maybe someone will stumble in who has this problem and knows how to fix it.

I'll give the addin you suggested way back in post 01 and see how that works.

Much appreciate your help, sir (ma'am?).

Question owner

Interesting addendum to this tale of woe: I just tried the same thing using the latest rev of Opera (11.11) and guess what - same thing happens.

If I were a more paranoid person, I'd think this was a purposely coded "feature" introduced by the bastids, I mean, people at Google to get people to use Chrome.

Strange.

Helpful Reply

Same exact problem exists in IE 8.x. Even more peculiar.

Question owner

I seem to have stumbled on a "solution" although why this works I have no idea.

By choosing the settings wheel in the upper far right corner of the Google home page then setting Google Instant to "Do not use Google Instant" this seems to fix the problem.

It's a crappy solution as I clear settings, cache, history and cookies when I leave FF so it's something I need to reset every time I come into FF.

Incidentally, I also tested with Google Chrome and got the same problem.

I disabled every addon I have (and removed the ones I'm not using) and this also did not fix the problem.

I guess I'll live with this for now, but if anyone has a more permanent solution that would be great.

Thanks again Xircal - appreciate all your efforts to help me with this.

cat

Xircal 334 solutions 3835 answers

Helpful Reply

Hi cat, you can do the following to disable Google Instant (I hate too).

  1. To set your home page:

  2. Go to http://www.google.com/webhp?complete=0&hl=en

  3. Click the Firefox button, go to Options | Options | General.

  4. Make sure it says "Show My Home Page" in the menu at the top.

  5. Click the button "Use Current Pages".

To reset the google search (for when you just type in a word in the location bar and hit Enter), do the following.

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.

Now it won't matter whether you clear cookies or not: you won't see Google Instant again :)

Question owner

Xircal,

Excellent. I had to tweak your suggestion just slightly as I use Tab Mix Plus to open new pages.

I copied your URL:

http://www.google.com/webhp?complete=0&hl=en/search?q=

and pasted this in Tab Mix Plus options "Events, New Tabs, Location" and voila - no more pesky Instant On and the back button issue is now history. :)

Muchos gracious for that link! :)

Xircal 334 solutions 3835 answers

You're welcome.

john989 1 solutions 8 answers

You have to go back two times. Right-click the back button and select the second page from the list.

This is a problem of Google's search results page where instead of linking directly to the web pages it uses a redirecting page. This problem is the same for other browsers too.