X
Tap here to go to the mobile version of the site.

Support Forum

How prevent link address from popping up in bottom of page?

Posted

Sorry if this is an awkward explanation ... but this is a design issue. I do not want links to appear in the small popup window at the bottom of the page, and I can't figure out how to disable this. Is this something i need to address in the HTML code for my web page?

I'm really desperate to find an answer for this if anyone can help.

Sorry if this is an awkward explanation ... but this is a design issue. I do not want links to appear in the small popup window at the bottom of the page, and I can't figure out how to disable this. Is this something i need to address in the HTML code for my web page? I'm really desperate to find an answer for this if anyone can help.

Additional System Details

This happened

Every time Firefox opened

This started when...

on my web site

Installed Plug-ins

  • npmnqmp 071303000006
  • Picasa plugin.
  • iPhoto6
  • Netscape plug-in that plays Rhapsody content
  • RealPlayer Plugin
  • DivX Web Player version 1.4.1.4
  • 4.0.50401.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Shockwave Flash 10.1 r102
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Version 2.0.4.2108
  • Google Talk Plugin Video Accelerator version:0.1.43.7

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

TonyE
  • Moderator
1044 solutions 8863 answers

Helpful Reply

The easiest way is to use the Status-4-Evar add-on. With it you can choose to not display any of the status messages or hover URL previews, or display them in the add-ons bar or location bar instead.

https://addons.mozilla.org/firefox/addon/status-4-evar

The easiest way is to use the Status-4-Evar add-on. With it you can choose to not display any of the status messages or hover URL previews, or display them in the add-ons bar or location bar instead. https://addons.mozilla.org/firefox/addon/status-4-evar
bmeiri 0 solutions 2 answers

This is a funny answer. You add something and in order to remove it you have to add something else?? What is wrong with you?? Why can't you just allow disabling it?? A couple of other issues with the failure named Firefox 4.0: 1. I tried to reply to this add, using FIREFOX but it didn't open so guess what..??? I am using Internet Explorer!! Can you believe this?!?!? Using a competitive browser because YOUR browser wouldn't open the reply window!! 2. When clicking "Back" arrow, it use to have a drop-down menu to select how far back you want to go. It is gone!!!

I believe that new version sshould be improved and this version is a total failure so far. I'm going to remove it

This is a funny answer. You add something and in order to remove it you have to add something else?? What is wrong with you?? Why can't you just allow disabling it?? A couple of other issues with the failure named Firefox 4.0: 1. I tried to reply to this add, using FIREFOX but it didn't open so guess what..??? I am using Internet Explorer!! Can you believe this?!?!? Using a competitive browser because YOUR browser wouldn't open the reply window!! 2. When clicking "Back" arrow, it use to have a drop-down menu to select how far back you want to go. It is gone!!! I believe that new version sshould be improved and this version is a total failure so far. I'm going to remove it

Question owner

I'm still not sure if I have explained the problem very well. An example can be found on this very page. When the cursor hovers over a link of any kind (such as the avatar to the left or any menu item above) the url appears in small letters in the lower left of the screen (sorry if there's an exact technical term for this). The problem is there are times when this text appearing on is a distraction, so I'd like to find a way to disable it, either in html code or maybe there is a preferences setting that will turn it off?

Thanks.

I'm still not sure if I have explained the problem very well. An example can be found on this very page. When the cursor hovers over a link of any kind (such as the avatar to the left or any menu item above) the url appears in small letters in the lower left of the screen (sorry if there's an exact technical term for this). The problem is there are times when this text appearing on is a distraction, so I'd like to find a way to disable it, either in html code or maybe there is a preferences setting that will turn it off? Thanks.
TonyE
  • Moderator
1044 solutions 8863 answers

Helpful Reply

You are describing the url hover preview and the status-4-evar add-on can be used to hide it. You can hide it without using an add-on. The following code will hide the url preview and the status messages.

  1. Open your profile folder, for details of how to find it see https://support.mozilla.com/kb/Profiles
  2. Close Firefox
  3. Inside the profile folder is there a folder called chrome? If there is open it, if not create a folder called chrome
  4. Inside the chrome folder, if there is a file called userChrome.css edit it using a text editor, or create a new file and name is userChrome.css
  5. Add the following code to userChrome.css
@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); /* only needed once */


#statusbar-display {display: none !important;}

As for the drop-down list for the back arrow, the feature is still present, you can get the drop down list by either right-clicking on the back/forward buttons, or holding down the left button until the list appears.

If you want the drop-down arrow you can add it with the Back/forward dropmarker add-on - https://addons.mozilla.org/firefox/addon/backforward-dropmarker

You are describing the url hover preview and the status-4-evar add-on can be used to hide it. You can hide it without using an add-on. The following code will hide the url preview and the status messages. # Open your profile folder, for details of how to find it see https://support.mozilla.com/kb/Profiles # Close Firefox # Inside the profile folder is there a folder called '''chrome'''? If there is open it, if not create a folder called chrome # Inside the chrome folder, if there is a file called '''userChrome.css''' edit it using a text editor, or create a new file and name is '''userChrome.css''' # Add the following code to userChrome.css @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); /* only needed once */ #statusbar-display {display: none !important;} ------ As for the drop-down list for the back arrow, the feature is still present, you can get the drop down list by either right-clicking on the back/forward buttons, or holding down the left button until the list appears. If you want the drop-down arrow you can add it with the Back/forward dropmarker add-on - https://addons.mozilla.org/firefox/addon/backforward-dropmarker

Question owner

Okay thanks very much. I can see now that you were understanding me and so I did your first suggestion which solved the problem. I must admit I don't use FireFox as my regular browser and so I'm fighting a learning curve (for example, after downloading the add-on it took me a pretty long time to even determine how to access the add-on, and I'm still not sure I know how to but it doesn't matter as it automatically removed the hovering text, perhaps as its default setting).

I think however this points to a larger problem, a somewhat philosophical one really. For example, if I'm developing a web environment (or web page) where I find that hovering text completely destroys the aesthetics or artistic quality of my design, it seems to me there should be some way that I, as web designer, can control whether or not this shows up. This is (to me, anyway) really an artistic freedom issue. At the very least, it should be easy for users of Firefox to disable something like this (for example, in Safari -- not my favorite browser by any means) they have this hovering text as part of the status menu bar. That means if you simply disable that bar it goes away. Very simple. The point being that if I design a site that I want people to visit in a full-screen mode, hovering URL text is a bit like adding subtitles to a movie that doesn't need them. Very troubling to me that issues like this aren't taken into greater consideration.

Thanks again for your help, however, which is greatly appreciated.

Okay thanks very much. I can see now that you were understanding me and so I did your first suggestion which solved the problem. I must admit I don't use FireFox as my regular browser and so I'm fighting a learning curve (for example, after downloading the add-on it took me a pretty long time to even determine how to access the add-on, and I'm still not sure I know how to but it doesn't matter as it automatically removed the hovering text, perhaps as its default setting). I think however this points to a larger problem, a somewhat philosophical one really. For example, if I'm developing a web environment (or web page) where I find that hovering text completely destroys the aesthetics or artistic quality of my design, it seems to me there should be some way that I, as web designer, can control whether or not this shows up. This is (to me, anyway) really an artistic freedom issue. At the very least, it should be easy for users of Firefox to disable something like this (for example, in Safari -- not my favorite browser by any means) they have this hovering text as part of the status menu bar. That means if you simply disable that bar it goes away. Very simple. The point being that if I design a site that I want people to visit in a full-screen mode, hovering URL text is a bit like adding subtitles to a movie that doesn't need them. Very troubling to me that issues like this aren't taken into greater consideration. Thanks again for your help, however, which is greatly appreciated.
gohankuten 0 solutions 1 answers

I want to know how to do the opposite of this question. I want the pop-up to always be there instead of being a pop-up. I dislike having it pop-up but I like having the link address shown so how can I make it always be there?

I want to know how to do the opposite of this question. I want the pop-up to always be there instead of being a pop-up. I dislike having it pop-up but I like having the link address shown so how can I make it always be there?
the-edmeister
  • Top 25 Contributor
  • Moderator
5387 solutions 39983 answers

That status display will show on cursor hover and while web page contents are being loaded. The status display disappears when it doesn't need to display anything - the cursor isn't on a hyperlink and when the page is finished loading, Done never appears and that's when that display is hidden.

To change that, use the Status-4-Evar extension to be able to restore the previous functionality of the old Statusbar.

That status display will show on cursor hover and while web page contents are being loaded. The status display disappears when it doesn't need to display anything - the cursor isn't on a hyperlink and when the page is finished loading, Done never appears and that's when that display is hidden. To change that, use the Status-4-Evar extension to be able to restore the previous functionality of the old Statusbar.
suwanneeredhead 0 solutions 4 answers

@the-edmeister, I cannot see any link preview status (or any other status) in my lower left on hover or otherwise, it is just not there. I see a few things with the Stats-4-Evar addon but it is not displaying the link preview either (just says "Done" most of the time). I need to see that link preview for my job! Is there any way to force it to stay on, as asked by gohankuten?

@the-edmeister, I cannot see any link preview status (or any other status) in my lower left on hover or otherwise, it is just not there. I see a few things with the Stats-4-Evar addon but it is not displaying the link preview either (just says "Done" most of the time). I need to see that link preview for my job! Is there any way to force it to stay on, as asked by gohankuten?
cor-el
  • Top 10 Contributor
  • Moderator
17262 solutions 156014 answers

It is possible that the screen is too high and that the scroll bar and the find bar and add-on bar fall off at the bottom.

If that works then close Firefox (File > Exit/Quit) to save that setting.

See also:

If the above didn't help then see:

It is possible that the screen is too high and that the scroll bar and the find bar and add-on bar fall off at the bottom. If that works then close Firefox (File > Exit/Quit) to save that setting. See also: * http://kb.mozillazine.org/Resizing_oversize_window If the above didn't help then see: * http://kb.mozillazine.org/Corrupt_localstore.rdf