X
Tap here to go to the mobile version of the site.

Support Forum

Open new tabs but stay in current tab

Posted

I have read a lot of threads, but I have not found that any help. I just reformatted my hard drive and installed FF4 fresh. . I open firefox to my homepage. No tabs opened at this point. If I right click on on the page to open a new link by opening a new tab, it stays on the current page and opens a new tab in the background. My problem is if I am on a page and I open a new tab by selecting a BOOKMARK, it switches to the new tab immediately. I want to stay on the current tab and have the bookmark tab open in a background tab. Any help? Thanks.

P.S. I have tried checking and unchecking "When I open a link in a new tab, switch to it immediately", I have tried safe mode, I have tried disabling all of the add-on's....nothing seems to work.

I have read a lot of threads, but I have not found that any help. I just reformatted my hard drive and installed FF4 fresh. . I open firefox to my homepage. No tabs opened at this point. If I right click on on the page to open a new link by opening a new tab, it stays on the current page and opens a new tab in the background. My problem is if I am on a page and I open a new tab by selecting a BOOKMARK, it switches to the new tab immediately. I want to stay on the current tab and have the bookmark tab open in a background tab. Any help? Thanks. P.S. I have tried checking and unchecking "When I open a link in a new tab, switch to it immediately", I have tried safe mode, I have tried disabling all of the add-on's....nothing seems to work.

Modified by xyphr3

Chosen solution

That is controlled by this pref (does affect Google search bar as well):

browser.tabs.loadBookmarksInBackground

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

Read this answer in context 4

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Helper7677 165 solutions 1653 answers

"I want to stay on the current tab and have the bookmark tab open in a background tab."

Un-check "When I open a link in a new tab, switch to it immediately":

  • Firefox button > Options > Options > Tabs
  • If using the Menu Bar: Tools > Options > Tabs

Also, some of the tab-related extensions (Tab Mix Plus, Tab Utilities, etc.) have options that can affect that behavior.

'''''"I want to stay on the current tab and have the bookmark tab open in a background tab."''''' Un-check "When I open a link in a new tab, switch to it immediately": *Firefox button > Options > Options > Tabs *If using the Menu Bar: Tools > Options > Tabs Also, some of the tab-related extensions (Tab Mix Plus, Tab Utilities, etc.) have options that can affect that behavior.

Question owner

I have tried checking and unchecking "When I open a link in a new tab, switch to it immediately", I have tried safe mode, I have tried disabling all of the add-on's....nothing seems to work.

I have tried checking and unchecking "When I open a link in a new tab, switch to it immediately", I have tried safe mode, I have tried disabling all of the add-on's....nothing seems to work.
cor-el
  • Top 10 Contributor
  • Moderator
12747 solutions 117142 answers

Chosen Solution

That is controlled by this pref (does affect Google search bar as well):

browser.tabs.loadBookmarksInBackground

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

That is controlled by this pref (does affect Google search bar as well): browser.tabs.loadBookmarksInBackground To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br /> If you see a warning then you can confirm that you want to access that page.<br />

Question owner

Cor-el, thanks for the help. You solved my problem

Cor-el, thanks for the help. You solved my problem
cor-el
  • Top 10 Contributor
  • Moderator
12747 solutions 117142 answers

You're welcome

You're welcome
sgriff 0 solutions 2 answers

That didn't work for me. I confirm I closed firefox down and restared it. No joy.

That didn't work for me. I confirm I closed firefox down and restared it. No joy.
cor-el
  • Top 10 Contributor
  • Moderator
12747 solutions 117142 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes). * Don't make any changes on the Safe mode start window. * https://support.mozilla.com/kb/Safe+Mode * https://support.mozilla.com/kb/Troubleshooting+extensions+and+themes