Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The firefox search using google engine is not giving me location option anymore, how do I get it back?

  • 5 replies
  • 16 have this problem
  • 2 views
  • Last reply by cor-el

more options

I am running Firefox 4. The search bar has google search engine and I used to get location specific search options when I searched using it! That is after I enter a search word and press return, I would get results and on the left of the page I had option to change my location web pages from my country or all over the world. But now it is gone. But when I go to google.com.sg, I am able to get that.

Chosen solution

Look here for additional Google search engines including google.com.sg:

Read this answer in context 👍 4

All Replies (5)

more options

Firefox 4 uses a special build-in home page called about:home that opens the default Google search page Google.com
That international page doesn't have a specific country selection.

So you will have to set the home page to http://google.com.sg/ to get results from Singapore.

See:

more options

I am using another homepage, I do not want google as my homepage. I was asking about the search box on the top right corner (instant search). When I make a search from that box using google engine, it used to take me to a google result page with country and location options on the left side until yesterday. But not anymore. But when I search directly from google.com.sg it does.

Modified by showstoprakesh

more options

Chosen Solution

Look here for additional Google search engines including google.com.sg:

more options

Thank you very much that has solved the issue. I tried a lot to add another search engine but none worked. Thanks a lot

more options

You're welcome