X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

some youtube videos don't play

Posted

I just recently reformatted my PC, installed Win 7 x64 and a full, clean (not upgraded) installation of Firefox 4.0

I went to youtube, it said i needed the Flash plugin, so I clicked to go to the flash webpage and downloaded & installed the latest version of Flash.

Well, some youtube videos play fine, but many of them simply don't play. When I click the play button on those videos, it just shows that buffering circle animation forever.

Chrome plays all youtube videos just fine. Changing resolution from 320p to 480p to 720p (etc) makes no difference. Some youtube videos just won't play in FF 4.

If I had to hazard a guess, I'd say that maybe Firefox is not allowing the Ads to play in the beginning of those youtube videos, and therefore Youtube won't play the content.

I did not have any extensions installed except for Devon Jensen's Download Statusbar (https://addons.mozilla.org/en-US/firefox/addon/download-statusbar/). Later, I installed Adblock Plus, but it made no difference... the certain youtube videos still do not play.

I searched around a little bit and it seems that other people with FF 4 are having some Flash problems too, except a lot of them say that there are crashes and freezes involved. There's no crashes or freezes involved in my problem.

Please help.. Thanks

Additional System Details

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.43.5
  • Version 1.9.2.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 10.2 r159
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Application Basics
Name
Firefox
Version
4.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Download Statusbar
0.9.8
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
Java Console
6.0.23
true
{CAFEEFAC-0016-0000-0023-ABCDEFFEDCBA}
Java Console
6.0.24
true
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
DownloadHelper
4.8.6
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Adblock Plus
1.3.6
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/
browser.startup.homepage_override.buildID
20110318052756
browser.startup.homepage_override.mstone
rv:2.0
browser.tabs.warnOnClose
false
extensions.lastAppVersion
4.0
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1303104096
places.history.expiration.transient_current_max_pages
257153
places.last_vacuum
1298170449
print.print_printer
PDFCreator
print.printer_PDFCreator.print_bgcolor
false
print.printer_PDFCreator.print_bgimages
false
print.printer_PDFCreator.print_command
print.printer_PDFCreator.print_downloadfonts
false
print.printer_PDFCreator.print_edge_bottom
0
print.printer_PDFCreator.print_edge_left
0
print.printer_PDFCreator.print_edge_right
0
print.printer_PDFCreator.print_edge_top
0
print.printer_PDFCreator.print_evenpages
true
print.printer_PDFCreator.print_footercenter
print.printer_PDFCreator.print_footerleft
&PT
print.printer_PDFCreator.print_footerright
&D
print.printer_PDFCreator.print_headercenter
print.printer_PDFCreator.print_headerleft
&T
print.printer_PDFCreator.print_headerright
&U
print.printer_PDFCreator.print_in_color
true
print.printer_PDFCreator.print_margin_bottom
0.5
print.printer_PDFCreator.print_margin_left
0.5
print.printer_PDFCreator.print_margin_right
0.5
print.printer_PDFCreator.print_margin_top
0.5
print.printer_PDFCreator.print_oddpages
true
print.printer_PDFCreator.print_orientation
0
print.printer_PDFCreator.print_page_delay
50
print.printer_PDFCreator.print_paper_data
9
print.printer_PDFCreator.print_paper_height
11.00
print.printer_PDFCreator.print_paper_size_type
0
print.printer_PDFCreator.print_paper_size_unit
1
print.printer_PDFCreator.print_paper_width
8.50
print.printer_PDFCreator.print_reversed
false
print.printer_PDFCreator.print_scaling
1.00
print.printer_PDFCreator.print_shrink_to_fit
true
print.printer_PDFCreator.print_to_file
false
print.printer_PDFCreator.print_unwriteable_margin_bottom
0
print.printer_PDFCreator.print_unwriteable_margin_left
0
print.printer_PDFCreator.print_unwriteable_margin_right
0
print.printer_PDFCreator.print_unwriteable_margin_top
0
privacy.cpd.siteSettings
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false
Graphics
Adapter Description
AMD Radeon HD 6800 Series
Vendor ID
1002
Device ID
6739
Adapter RAM
1024
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Driver Version
8.821.0.0
Driver Date
1-26-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17563, font cache n/a)
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows
1/1 Direct3D 10

Helpful Reply

I guess it was a botched install somehow. I uninstalled Flash & Firefox, re-downloaded & installed both, re-added my extensions, and it works now.

I think that I was right about the ads. Now that I can view all the youtube videos, I realize that the ones that refused to play before are the ones that have ads at the beginning.

I should have tried reinstalling before posting. Sorry for posting and wasting your time.

kasparhauser4 0 solutions 1 answers

Yes I have the exact same problem. I love Fire fox but I cannot use it on YouTube anymore, I have a Dell Dimension 3000 XP with 2GB Ram and a Cable high speed connection If this matters. This problem has been with me for at least a couple of months now. At first Firefox worked just fine with YouTube. I think it is the type of technology employed by the ad is a factor as well. But it is always at the very beginning. YouTube videos without ads work just fine. I NEVER encounter this problem when I am using Chrome or Explorer. I REALLY REALLY like Firefox though. I reloaded Firefox twice as well as adobe flash player twice but that does not fix the problem.