X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How to change search engine used within address bar from Yahoo! to Google?

Posted

When I enter an item within the address bar to search for using the search engine, it defaults to Yahoo! I do not want to use this search engine, how can I change it to for example Google?

Additional System Details

Installed Plug-ins

  • np-mswmp
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.3"
  • Google Update
  • Shockwave Flash 10.2 r159
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You can modify the pref keyword.URL on the about:config page to use a Google Lucky search.


You may have an extension (MyFreeze.com) that change the search engine.

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons is causing the problem.

  • Don't make any changes on the Safe mode start window.

See:

alicenarae 0 solutions 1 answers

Helpful Reply

I had the the same problem. You're going to have to type "about:config" into the address bar and enter into the firefox setting. In the search bar type "keyword.url" and this will change what search engine it uses when you go to type keywords in the address bar. if you want google enter "http://www.google.com/search?hl=en-GB&q=". You can also type "browser.search.defaultenginename" in the search bar and type what search engine you want to use. For google just type Google.

Modified by alicenarae

Question owner

Tried Alicenarae solution however that has not resolved my issue. Now my URL keyword search does not work at all now. I now need to return to the default option, looking for how to do that. Therefore I still have the same original issue, my Firefox URL Keyword search is in Yahoo! when I want in to use Google instead. Any help on both problems???

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Helpful Reply

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

See also:


chuckPR1ME 0 solutions 1 answers

I had a very similar Yahoo problem, and changing the "keyword.url" value in "about:config" seems to have fixed it.

My symptoms, just FTR: the default was Yahoo India (!), which was only half the malware problem. The other half was that clicking nearly any search result in the Yahoo India results list REDIRECTED me to different bullsht generic "low prices on [your search result]!" pages. I had installed Yahoo Messenger and some of its ancillary crap, but I had no Fileserve, and the one Yahoo extension I had went away after uninstalling all Yahoo software (via the Windoze "Programs" control panel) and relaunching FF. It seems that Yahoo had merely changed the keyword.url value, and nothing else. They didn't alert me they would do this, so I still consider it malware, akin to a normal browser hijacking.

BTW: I can't find how to specify Ixquick as the keyword.url value. (Ixquick does not log and track your searches like Google and the others do.) I already use Ixquick as my default search in the Search Bar; it would just be nice to have it be the default all around.