X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

opening new tab does not display my home page by default, what setting do I change to achieve this?

Posted

When selecting the open new tab option, in the past, the tab opened displaying my designated home page. It now opens displaying a YAHOO! search page. My home page settings have not changed and continue to display the correct address, selecting 'home' brings up the correct home page, at any time during browsing. Is there another location where this 'invalid' new tab address might be listed, and removed or reset ?

Additional System Details

Installed Plug-ins

  • Delivery Network Acceleration by BitTorrent™
  • Image Control Plugin for viewing images on Ancestry.com. Version 1.0.0.1
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Cooliris embedded in a tab
  • getplusplusadobe162100
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • eMusic DLM 4.1.3.2
  • Shockwave Flash 10.2 r153
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Office Live Update v1.5
  • Virtual Earth 3D 4.00100226006 plugin for Mozilla
  • NPWLPG
  • Google Update

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.16) Gecko/20110319 Firefox/3.6.16

More Information

ViridianCity 0 solutions 2 answers

Helpful Reply

I found I had this problem after I installed some new software from the Internet. Firstly what I did is I went into Tools > Add-ons. In Add-ons I noticed there was a new item called Freeze.com Net Assistant. I clicked on this and then clicked Disable. After I did this, I noticed that when I opened a new tab I just had a blank page rather than the annoying Yahoo! page. I then installed a new Add-on called New TabURL -

https://addons.mozilla.org/en-US/firefox/addon/newtaburl/

Click Add to Firefox. A bar will appear at the top of the screen asking if you want to intall the Add-on. Click 'Allow' and then it will ask you to restart Firefox. After this go back into the Add-ons, click on New TabURL and go into Options. Select the Home Page option (if you want your Homepage as your new-tab default page) and then click Save.

I found this sorted the problem! It didn't work until I disabled the Freeze.com Net Assistant. If you haven't got this program in your Add-ons then I wouldn't know what to recommend! Sorry, I'm not a computer expert! Anyways, maybe this'll help some of you!

Best wishes, VC.

Helpful Reply

Thanks VC, worked out just as you said, with the additional benefit of getting rid of that damn netassistant feature that was un requested and in the way.

twodkb 0 solutions 7 answers

I don't have the NetFreeze problem and even downloaded the NewTabURL add-on...twice in fact. And it does NOT solve my problem. I'm sick of getting a blank page every time I open a new tab! Should I just GET RID of Firefox altogether and go with Avant, Opera, or God Forbid...Chrome browser? Maybe Safari.

amum44 0 solutions 1 answers

Yes!!! NetFreeze was causing me the same problem. Thanks a million VC!

shrinandan 0 solutions 1 answers

VC you are a genius! I solved my problem with your solution. Thanks a lot!

ViridianCity 0 solutions 2 answers

I'm pleased my advice has been able to help some of you! I don't know where the Freeze.com Net Assistant came from. I've read some stuff on the internet that says it is an adware/spyware program. I was really frustrated when Yahoo! started appearing as my new tab, as I find it a totally useless search-engine. I guess once it's disabled it shouldn't be a problem, although it seems it can be difficult to get rid of the NetAssistant completely.

Viridian