Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not recognize when I change the settings for .torrent and .rar files to "do this automatically for files like this from now on", EVEN AFTER I change the setting in Tools>Options>Applications.

  • 5 replies
  • 25 have this problem
  • 750 views
  • Last reply by snapz

more options

Um, why is this? I think my Question pretty much covers it. Is there a way I can fix the settings so Firefox automatically opens .torrent files and .rar files with the programs I tell it to always use?

All Replies (5)

more options

Not sure if this will do any good, but "bump". Can someone please respond to this??

more options

So, after a bit of research, I've discovered that this has been an issue since the dawn of Firefox, and after a bajillion upgrades there is no official fix? Pathetic.

Oh, and also: WORST. SUPPORT. FORUM. EVER.

more options

I'm sorry to hear that you didn't receive a reply to this problem. As far as I can tell, there is no reply or solution to this problem so far, as I have exactly the same problem too.

One solution that I did try (and which worked, but not for my exact needs) was to tell Firefox to always save the torrents to the download folder. Then, in your personal torrent program, change the settings so that torrents from the download folder are automatically searched and added. In this way, torrents are automatically loaded in your torrent program. However, for me, I need to see the contents of the torrent before I download it all, which wasn't possible with this method. If that isn't important to you, this should be a sufficient solution.

Regards, Lewis

more options

For Linux users: Go to Edit->Preferences->Applications Tab->Scroll to "BitTorrent seed file"->Click on "Use Other"->Navigate to "/usr/bin/" & select your program. I somehow had Vuze as my default program, and wanted KTorrent, so I pointed firefox to "/usr/bin/ktorrent" problem solved.

more options

The InlineDisposition add-on fixes the "do this automatically..." problem.

https://addons.mozilla.org/en-US/firefox/addon/inlinedisposition/