Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox does not allow automatic opening of torrent files on OSX

  • 3 replies
  • 2 have this problem
  • 21 views
  • Last reply by FredMcD

more options

For some reason it is impossible to make Firefox automatically open a torrent file (in uTorrent for example) after downloading on OSX. When I click a .torrent link the only option Firefox gives me is to download the file. I then have to open the download menu and click the file. I want Firefox to open the file automatically after downloading, saving me two mouse clicks. Magnet files work fine.

I've even gone so far as to manually add torrent files to my mimeTypes.rdf, to no avail. Now "torrent" is listed under the applications tab in settings and I've picked uTorrent as my app to open it but when I open a .torrent link I still only get the option to download the file.

For some reason it is impossible to make Firefox automatically open a torrent file (in uTorrent for example) after downloading on OSX. When I click a .torrent link the only option Firefox gives me is to download the file. I then have to open the download menu and click the file. I want Firefox to open the file automatically after downloading, saving me two mouse clicks. Magnet files work fine. I've even gone so far as to manually add torrent files to my mimeTypes.rdf, to no avail. Now "torrent" is listed under the applications tab in settings and I've picked uTorrent as my app to open it but when I open a .torrent link I still only get the option to download the file.

Modified by lepel

All Replies (3)

more options

Firefox is a web browser. Not a torrent tool.

I don't know if anything is available.

Go to the Mozilla Add-ons Web Page {web link} (There’s a lot of good stuff here) and search for what you want.

There are also free torrent programs out there.

more options

I'm not talking about opening the torrent in Firefox, I'm talking about the "Open in" option you normally get when the download prompt appears. See added image, it does work on my Windows PC but not on my Mac. On OSX I only get the "Save file" option.

more options

Yes, I see.

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the file. Then rename or delete it. Restart Firefox.