X
Tap here to go to the mobile version of the site.

Support Forum

how to save tabs when closing firefox 4

Posted

I have just upgraded from Firefox 3.6.x to Firefox 4. I had assumed that the new version would use the same settings as the previous one but it doesn't

The previous one always asked if I wante tabs saving when I closed it but this version (4) does not.

Is there a way of making it ask?

I have just upgraded from Firefox 3.6.x to Firefox 4. I had assumed that the new version would use the same settings as the previous one but it doesn't The previous one always asked if I wante tabs saving when I closed it but this version (4) does not. Is there a way of making it ask?

Additional System Details

This happened

Every time Firefox opened

This started when...

After upgrading to version 4

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • Windows Activation Technologies Plugin for Mozilla

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

gbright12 0 solutions 3 answers

No it does not save tabs when closing multiples.

No it does not save tabs when closing multiples.
PacoBozo 0 solutions 2 answers

Thanks for the post. Fixed my issue.

Thanks for the post. Fixed my issue.
PacoBozo 0 solutions 2 answers

One change in Firefox 4 is to by default stop Firefox displaying the warning message, but it can be turned back on by changing some preferences.

 1. Type about:config into the location bar and press enter
 2. Accept the warning message that appears, 

you will be taken to a list of preferences

 3. Locate the preference browser.tabs.warnOnClose,

if its value is set to false, double-click on it to change its value

to true

 4. Repeat this for these 2 preferences 

browser.warnOnQuit, browser.warnOnRestart

 5. Starting with beta 12 there will be an additional preference 

that needs to be set to true - browser.showQuitWarning

This worked great. Very helpful, thanks.

One change in Firefox 4 is to by default stop Firefox displaying the warning message, but it can be turned back on by changing some preferences. 1. Type about:config into the location bar and press enter 2. Accept the warning message that appears, you will be taken to a list of preferences 3. Locate the preference browser.tabs.warnOnClose, if its value is set to false, double-click on it to change its value to true 4. Repeat this for these 2 preferences browser.warnOnQuit, browser.warnOnRestart 5. Starting with beta 12 there will be an additional preference that needs to be set to true - browser.showQuitWarning This worked great. Very helpful, thanks.
mmbahnasy 0 solutions 1 answers

Here How I solve this problem , First instead of close the firefox from the red X icon in the top right side close it from the mainmenu -->> close then it will ask you to save if like close it every time by this way , or I have checked the box "ask me every time" and choosed "YES" so every time it will remmember the last sessiions tabs hop it will work with you

Here How I solve this problem , First instead of close the firefox from the red X icon in the top right side close it from the mainmenu -->> close then it will ask you to save if like close it every time by this way , or I have checked the box "ask me every time" and choosed "YES" so every time it will remmember the last sessiions tabs hop it will work with you
22curious 0 solutions 1 answers

This didn't solve it for me. Assuming an undiagnosed addon conflict 4 now.

This didn't solve it for me. Assuming an undiagnosed addon conflict 4 now.
zmster 0 solutions 1 answers

Thanks for the help! That was so thoughtful a redesign:P Taking tips from FB I guess. But thanks again for your helpful and simple solution.

Thanks for the help! That was so thoughtful a redesign:P Taking tips from FB I guess. But thanks again for your helpful and simple solution.
gamebird 0 solutions 1 answers

Firefox 4 saves the session automatically.

<<You can use "Firefox > History > Restore Previous Session" to get the previous session.>> That is greyed out.

There is also a "Restore Previous Session" button on the default about:home Home page. That option does not exist,

Another possibility is to use:

   Tools > Options > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time"  I did that and it still starts with the Google Home page.
Firefox 4 saves the session automatically. <<You can use "Firefox > History > Restore Previous Session" to get the previous session.>> '''That is greyed out.''' There is also a "Restore Previous Session" button on the default about:home Home page. That option does not exist, Another possibility is to use: Tools > Options > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time" '''I did that and it still starts with the Google Home page.'''
cor-el
  • Top 10 Contributor
  • Moderator
17470 solutions 157890 answers

Make sure that you not run Firefox in (permanent) Private Browsing - Use Firefox without saving history mode.

  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Uncheck: [ ] "Permanent Private Browsing mode"
Make sure that you not run Firefox in (permanent) [[Private Browsing]] mode. * You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History" * To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting <b>Firefox will: Use custom settings for history</b> * Uncheck: [ ] "Permanent Private Browsing mode"
Mattkyle 0 solutions 2 answers

As a security approach I always set Firefox to clear history when Firefox closes (prying eyes). This means that you cannot get back the tabs which were open on previous session, when you restart Firefox.

My only option is to save all tabs for a session when I DECIDE. But I can't do that now. How can I save all open tabs?

As a security approach I always set Firefox to clear history when Firefox closes (prying eyes). This means that you cannot get back the tabs which were open on previous session, when you restart Firefox. My only option is to save all tabs for a session when I DECIDE. But I can't do that now. How can I save all open tabs?
Mattkyle 0 solutions 2 answers

Found a way. Before closing Firefox, just right click any open tab. Select Bookmark All Tabs... Type a folder name such as "Holiday cottages 9 July 2011". and you're done.

Found a way. Before closing Firefox, just right click any open tab. Select Bookmark All Tabs... Type a folder name such as "Holiday cottages 9 July 2011". and you're done.
jaxx0rr 0 solutions 1 answers

like cor-el said:

Tools > Options > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time"

is the answer you are looking for...

like cor-el said: Tools > Options > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time" is the answer you are looking for...
VeryOldFart 0 solutions 2 answers

Very simply solution that works since 4.x - it is: Simultaneously pressing: Ctrl+Alt+Del and from task manager kill firefox process.

On next start it automatically show restore windows as it was before someone decide to choose to kill firefox with all that last "new", "co-o-o-o-l", "features".

Very simply solution that works since 4.x - it is: Simultaneously pressing: Ctrl+Alt+Del and from task manager kill firefox process. On next start it automatically show restore windows as it was before someone decide to choose to kill firefox with all that last "new", "co-o-o-o-l", "features".
MacNimer 2 solutions 12 answers

this fix works great. the step after this is to go to options , select general tab in the "when Firefox start" set it to "show a blank page" or " show home page".

'''this fix works great. the step after this is to go to options , select general tab in the "when Firefox start" set it to "show a blank page" or " show home page". '''