X
Tap here to go to the mobile version of the site.

Support Forum

FF4 Menus are all uppercase

Posted

Just upgraded to FF4.

When i start it up, all the menus (File, Edit, bookmarks, etc) are displayed with all UPPERCASE characters. I've tried disabling all add-ons, creating a new profile, deleting registry entries, fresh install. Nothing I do fixes it. When I go back to 3.6, menus look fine.

Just upgraded to FF4. When i start it up, all the menus (File, Edit, bookmarks, etc) are displayed with all UPPERCASE characters. I've tried disabling all add-ons, creating a new profile, deleting registry entries, fresh install. Nothing I do fixes it. When I go back to 3.6, menus look fine.

Additional System Details

This happened

Every time Firefox opened

This started when...

installed Firefox 4.0

Installed Plug-ins

  • Shockwave Flash 10.2 r153
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

More Information

Application Basics
Name
Firefox
Version
4.0
User Agent
Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Xmarks
3.9.5
true
foxmarks@kei.com
Siphon - Sync Add-ons
0.9.0
false
siphon@siphon.ian-halpern.com
LastPass
1.72.0
true
support@lastpass.com
Fission
1.0.9
false
{1280606b-2510-4fe0-97ef-9b5a22eafe41}
Download Statusbar
0.9.8
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
Greasemonkey
0.9.1
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
FaviconizeTab
1.0.2
true
faviconizetab@espion.just-size.jp
FireGestures
1.6.1
true
firegestures@xuldev.org
Adblock Plus
1.3.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/webhp?hl=en
browser.startup.homepage_override.buildID
20110318052756
browser.startup.homepage_override.mstone
rv:2.0
browser.tabs.closeWindowWithLastTab
false
browser.tabs.insertRelatedAfterCurrent
false
browser.tabs.loadBookmarksInBackground
true
dom.disable_window_move_resize
true
extensions.lastAppVersion
4.0
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
94224
places.last_vacuum
1300751936
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Intel(R) Graphics Media Accelerator HD
Vendor ID
8086
Device ID
0046
Adapter RAM
Unknown
Adapter Drivers
igxprd32
Driver Version
6.14.10.5160
Driver Date
10-19-2009
Direct2D Enabled
false
DirectWrite Enabled
false (0.0.0.0, font cache n/a)
WebGL Renderer
(WebGL unavailable)
GPU Accelerated Windows
0/2

Question owner

Found the issue. It had to do with my windows theme. I guess FF4 uses a different resource font for the the menus then do the previous versions. Changing this font fixed the issue..

Found the issue. It had to do with my windows theme. I guess FF4 uses a different resource font for the the menus then do the previous versions. Changing this font fixed the issue..
eliteinfantry 0 solutions 1 answers

Yeah, I have this problem too, and I am indeed running a custom theme. And no, I'm not going to change my windows theme to fix this issue. If FF4 does indeed rely on a default system font, then this is very irresponsible of Mozilla, and is something that needs to be resolved. Not every server on earth runs on IIS, you know. I need lowercase letters in my URL bar.

Yeah, I have this problem too, and I am indeed running a custom theme. And no, I'm not going to change my windows theme to fix this issue. If FF4 does indeed rely on a default system font, then this is very irresponsible of Mozilla, and is something that needs to be resolved. Not every server on earth runs on IIS, you know. I need lowercase letters in my URL bar.

Modified by eliteinfantry