X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I install required plug-in jre-1_5_0_11-windows-i586.xpi

Posted

I'm trying to use Mozilla Firefox 3.6.15 with the Web Version of QPASA 4.0.0.80a, an MQSeries monitoring tool. When I point to the QPASA URL, I'm prompted to install a plugin. However, when I try to install it, Firefox looks for http://javadl-esd.sun.com/update/1.5.0/jre-1_5_0_11-windows-i586.xpi, but says it can't install it because the Install script was not found (-204).

When I google jre-1_5_0_11-windows-i586.xpi, I find it's actually located at http://java.sun.com/update/1.5.0/jre-1_5_0_11-windows-i586.xpi. However, even when I paste this location into the Firefox url window, Firefox STILL insists on looking for it in http://javadl-esd.sun.com/update/1.5.0/jre-1_5_0_11-windows-i586.xpi and fails.

How can I get Firefox to look for this file in the correct location?

Chosen solution

That xpi package looks like an installer for Java 1.5.0-11, that is from 2006 - 5 years ago. You really don't want to install Java 1.5.0-11 because it won't work with Firefox 3.6+ versions, which need Java 1.6.0-12 or higher with the Second Generation Plugin.

The file I got from both of those URL's is the same (right-click the link and use Save Link As... so Firefox doesn't try to install it and fail - then open it with 7-Zip to examine the internal files). That XPI package is too old for recent versions of Firefox, it has an install.js file that was used by Firefox 1.5 and prior versions. Firefox 2.0 and newer use an install.rdf file.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • getplusplusadobe16299
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 10.2 r152
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.60129.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Update
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15 ( .NET CLR 3.5.30729; .NET4.0E)

More Information

Application Basics
Name
Firefox
Version
3.6.15
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Microsoft .NET Framework Assistant
1.2.1
true
{20a82645-c095-46ed-80e3-08825760534b}
Java Console
6.0.24
true
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
Java Quick Starter
1.0
true
jqs@sun.com
Adobe DLM (powered by getPlus(R))
1.6.2.99
true
{E2883E8F-472F-4fb0-9522-AC9BF37916A7}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days
20
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://hcintranet.co.hennepin.mn.us/portal/site/HCNet
browser.startup.homepage_override.mstone
rv:1.9.2.15
extensions.lastAppVersion
3.6.15
general.useragent.extra.microsoftdotnet
( .NET CLR 3.5.30729; .NET4.0E)
network.cookie.prefsMigrated
true
places.last_vacuum
1299620092
print.print_printer
\\orlando\ToshibaMFD
print.printer_\\orlando\GC19ITCET3530C.print_bgcolor
false
print.printer_\\orlando\GC19ITCET3530C.print_bgimages
false
print.printer_\\orlando\GC19ITCET3530C.print_command
print.printer_\\orlando\GC19ITCET3530C.print_downloadfonts
false
print.printer_\\orlando\GC19ITCET3530C.print_edge_bottom
0
print.printer_\\orlando\GC19ITCET3530C.print_edge_left
0
print.printer_\\orlando\GC19ITCET3530C.print_edge_right
0
print.printer_\\orlando\GC19ITCET3530C.print_edge_top
0
print.printer_\\orlando\GC19ITCET3530C.print_evenpages
true
print.printer_\\orlando\GC19ITCET3530C.print_footercenter
print.printer_\\orlando\GC19ITCET3530C.print_footerleft
&PT
print.printer_\\orlando\GC19ITCET3530C.print_footerright
&D
print.printer_\\orlando\GC19ITCET3530C.print_headercenter
print.printer_\\orlando\GC19ITCET3530C.print_headerleft
&T
print.printer_\\orlando\GC19ITCET3530C.print_headerright
&U
print.printer_\\orlando\GC19ITCET3530C.print_in_color
true
print.printer_\\orlando\GC19ITCET3530C.print_margin_bottom
0.5
print.printer_\\orlando\GC19ITCET3530C.print_margin_left
0.5
print.printer_\\orlando\GC19ITCET3530C.print_margin_right
0.5
print.printer_\\orlando\GC19ITCET3530C.print_margin_top
0.5
print.printer_\\orlando\GC19ITCET3530C.print_oddpages
true
print.printer_\\orlando\GC19ITCET3530C.print_orientation
0
print.printer_\\orlando\GC19ITCET3530C.print_pagedelay
500
print.printer_\\orlando\GC19ITCET3530C.print_paper_data
1
print.printer_\\orlando\GC19ITCET3530C.print_paper_height
11.00
print.printer_\\orlando\GC19ITCET3530C.print_paper_size_type
0
print.printer_\\orlando\GC19ITCET3530C.print_paper_size_unit
0
print.printer_\\orlando\GC19ITCET3530C.print_paper_width
8.50
print.printer_\\orlando\GC19ITCET3530C.print_reversed
false
print.printer_\\orlando\GC19ITCET3530C.print_scaling
1.00
print.printer_\\orlando\GC19ITCET3530C.print_shrink_to_fit
true
print.printer_\\orlando\GC19ITCET3530C.print_to_file
false
print.printer_\\orlando\GC19ITCET3530C.print_unwriteable_margin_bottom
0
print.printer_\\orlando\GC19ITCET3530C.print_unwriteable_margin_left
0
print.printer_\\orlando\GC19ITCET3530C.print_unwriteable_margin_right
0
print.printer_\\orlando\GC19ITCET3530C.print_unwriteable_margin_top
0
print.printer_\\orlando\ToshibaMFD.print_bgcolor
false
print.printer_\\orlando\ToshibaMFD.print_bgimages
false
print.printer_\\orlando\ToshibaMFD.print_command
print.printer_\\orlando\ToshibaMFD.print_downloadfonts
false
print.printer_\\orlando\ToshibaMFD.print_edge_bottom
0
print.printer_\\orlando\ToshibaMFD.print_edge_left
0
print.printer_\\orlando\ToshibaMFD.print_edge_right
0
print.printer_\\orlando\ToshibaMFD.print_edge_top
0
print.printer_\\orlando\ToshibaMFD.print_evenpages
true
print.printer_\\orlando\ToshibaMFD.print_footercenter
print.printer_\\orlando\ToshibaMFD.print_footerleft
&PT
print.printer_\\orlando\ToshibaMFD.print_footerright
&D
print.printer_\\orlando\ToshibaMFD.print_headercenter
print.printer_\\orlando\ToshibaMFD.print_headerleft
&T
print.printer_\\orlando\ToshibaMFD.print_headerright
&U
print.printer_\\orlando\ToshibaMFD.print_in_color
true
print.printer_\\orlando\ToshibaMFD.print_margin_bottom
0.5
print.printer_\\orlando\ToshibaMFD.print_margin_left
0.5
print.printer_\\orlando\ToshibaMFD.print_margin_right
0.5
print.printer_\\orlando\ToshibaMFD.print_margin_top
0.5
print.printer_\\orlando\ToshibaMFD.print_oddpages
true
print.printer_\\orlando\ToshibaMFD.print_orientation
0
print.printer_\\orlando\ToshibaMFD.print_pagedelay
500
print.printer_\\orlando\ToshibaMFD.print_paper_data
1
print.printer_\\orlando\ToshibaMFD.print_paper_height
11.00
print.printer_\\orlando\ToshibaMFD.print_paper_size_type
0
print.printer_\\orlando\ToshibaMFD.print_paper_size_unit
0
print.printer_\\orlando\ToshibaMFD.print_paper_width
8.50
print.printer_\\orlando\ToshibaMFD.print_reversed
false
print.printer_\\orlando\ToshibaMFD.print_scaling
1.00
print.printer_\\orlando\ToshibaMFD.print_shrink_to_fit
true
print.printer_\\orlando\ToshibaMFD.print_to_file
false
print.printer_\\orlando\ToshibaMFD.print_unwriteable_margin_bottom
0
print.printer_\\orlando\ToshibaMFD.print_unwriteable_margin_left
0
print.printer_\\orlando\ToshibaMFD.print_unwriteable_margin_right
0
print.printer_\\orlando\ToshibaMFD.print_unwriteable_margin_top
0
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24389 answers

Chosen Solution

That xpi package looks like an installer for Java 1.5.0-11, that is from 2006 - 5 years ago. You really don't want to install Java 1.5.0-11 because it won't work with Firefox 3.6+ versions, which need Java 1.6.0-12 or higher with the Second Generation Plugin.

The file I got from both of those URL's is the same (right-click the link and use Save Link As... so Firefox doesn't try to install it and fail - then open it with 7-Zip to examine the internal files). That XPI package is too old for recent versions of Firefox, it has an install.js file that was used by Firefox 1.5 and prior versions. Firefox 2.0 and newer use an install.rdf file.

Question owner

Thanks. I was afraid of that. The web version of QPASA we have is at least as old as 2007. Since the web version of QPASA expects that plug-in version, there's probably no way it will work with the current Firefox version.

We intend to upgrade QPASA to the latest version, but haven't done so. I'll try Firefox again when the upgrade is complete.

Once again, thanks for your help.