X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

add-ons not working

Posted

My add-ons are not working even though they are "namely" enabled. These include among others "Better Privacy" and "NoScript" (those are basically the ones I'm concerned about). I go to the add-ons window, they seem to be enabled, when I click the options button the whole window freezes and I have to close it through task manager. I tried disabling them - restart Firefox - re-enabling them - restarting Firefox --- no good. Reinstalled Firefox --- negative. I also went to help-> troubleshooting information and they are all marked as enabled. Nevertheless, neither of them is working: No NoScript icon, no script blocking, no Better Privacy pop-up when I exit the browser - nothing. The next step would be to completely remove and do a fresh installation. But I'm wondering what caused this.

Thanks.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.2 r152
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • 4.0.50917.0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.15) Gecko/20110303 Firefox/3.6.15

More Information

Application Basics
Name
Firefox
Version
3.6.15
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Java Console
6.0.22
true
{CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA}
BetterPrivacy
1.48.3
true
{d40f5e7b-d2cf-4856-b441-cc613eeffbe3}
Adblock Plus
1.3.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
DownloadHelper
4.8.3
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
NoScript
2.0.9.8
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
Java Console
6.0.24
true
{CAFEEFAC-0016-0000-0024-ABCDEFFEDCBA}
Modified Preferences
Name
Value
accessibility.blockautorefresh
true
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days
0
browser.history_expire_days.mirror
180
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.google.com/ncr
browser.startup.homepage_override.mstone
rv:1.9.2.15
extensions.lastAppVersion
3.6.15
network.cookie.prefsMigrated
true
places.last_vacuum
1296302031
privacy.sanitize.migrateFx3Prefs
true
security.OCSP.disable_button.managecrl
false
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.warn_leaving_secure
true
security.warn_viewing_mixed
false

asphodelus 0 solutions 2 answers

Helpful Reply

i found a way to fix mine that maybe you could try.

Look in your Profile Folder (go to this link to find out how to do that: http://kb.mozillazine.org/Profile_folder_-_Firefox#Finding_the_profile_folder ) Now, delete these files but make sure Firefox isn't running when you do this:

extensions.cache extensions.ini extensions.rdf

Restart/open Firefox and they should work now.