Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Any help in fixing latest firefox update ?

  • 7 replies
  • 12 have this problem
  • 7 views
  • Last reply by cor-el

more options

Received pop up notification of available update to firefox. Installed update. Now can only play one game of pogo hearts. Attempt to play next game presents only black screen. Have to restart the computer again to play another pogo game. Have tried several solutions, e.g. clear cache, delete cookies, etc. No help. Apparently latest firfefox download has corrupted some applet or other.

Any help available ?

All Replies (7)

more options

You can try to clear the browser cache and the Java cache.

  • "Clear the Cache": Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

See:

Control Panel > Java > General tab > "Temporary Internet Files" > Settings > Delete Files

more options

Appreciate suggestion, but no help. Did find a solution, to corrupted apps, however --- simply reloaded firefox update. Seems to function, at least to this point.

more options

I had the same problem with the new version, I could go to pogo and choose a game but it would not load. I did all of the normal cleaning cookies, adobe, java, restart, made sure I had everything up to date, reloaded the new version and it still did not let me load any game in Pogo. I reinstalled Firefox 3.5.11 and all games now work. Everything in Pogo worked with Internet Explorer and Chrome, and the games in Pogo were fine before the new version this morning so I knew it was the new Firefox 3.6.

more options

Thanks.....this did the trick.......it's something with Firefox 3.6.........pogo still worked on explorer

more options

I am having problems too. How did u solve this. Did u have to uninstall firefox first, then install the older version?

more options

I was having the same problem and found a suggestion to go to the site below and download the prior version of Firefox. I did, and pogo now works. I did not uninstall the later version before doing the install.

http://www.oldapps.com/firefox.php?old_firefox=101

I hope this works for you, as well.

more options

There seem to be a problem with the Firefox 3.6.14 version and Pogo.com

See:

You can try to revert to the previous version: