Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

it wont remeber what i type in my web browser, but my history and search bar is all remembering.

  • 8 replies
  • 16 have this problem
  • 12 views
  • Last reply by cor-el

more options

normally i have always typed "face" in the address bar and i just click the first link to go to facebook home page, but on my new laptop, it wont remeber what i type in ever. i've checked all my settings, and my history is all saved and i can go back to the first site i went to when i bought the laptop.

Chosen solution

Make sure that the Location Bar is not set to "Nothing":

  • Tools > Options > Privacy > Location Bar: When using the location bar, suggest: History, Bookmarks, History and Bookmarks

See Smart Location Bar


Btw, it doesn't work if you increase the 'At least' history setting (history_expire_days_min) to 365 and leave the actual history setting (history_expire_days) at the default of 180.

browser.history_expire_days.mirror 180
browser.history_expire_days_min 365
Read this answer in context 👍 2

All Replies (8)

more options

Chosen Solution

Make sure that the Location Bar is not set to "Nothing":

  • Tools > Options > Privacy > Location Bar: When using the location bar, suggest: History, Bookmarks, History and Bookmarks

See Smart Location Bar


Btw, it doesn't work if you increase the 'At least' history setting (history_expire_days_min) to 365 and leave the actual history setting (history_expire_days) at the default of 180.

browser.history_expire_days.mirror 180
browser.history_expire_days_min 365
more options

thanks alot!!! it finally works now 0-)

more options

You're welcome

more options

I still have the sme problem..... it worked and then when i closed the window and opened a new one the same problem contined

more options
more options

I had the same problem with ubuntu 10.10 and firefox 3.6.13. I disabled my last 2 add-ons and it fixed the problem. One was "pixlr grabber 2.1.1 add-on"; which I think this was the one causing the problem, I also disabled "ubuntu firefox modifications 0.9rc2 add-on". Why firefox doesn't weed these thing out is beyond me.

more options

when i go under Tools, there is no 'option' option!

more options

On Linux use Edit > Preferences instead of Firefox (Tools) > Options

Menu differences: Windows: Tools > Options - Mac: Firefox > Preferences - Linux: Edit > Preferences